MFH: r477504

- Cosmetic fix in Makefile
- Allow chromium to use the Linux GPU access setup implementation by default since it works correctly
- Add missing file for DEBUG option in pkg-plist
- Sort pkg-plist
- Bump PORTREVISION

Approved by:	ports-secteam (blanket)
This commit is contained in:
Carlos J. Puga Medina 2018-08-18 14:46:19 +00:00
parent 43c620fa00
commit d196ed4de1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q3/; revision=477505
5 changed files with 4 additions and 58 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= chromium
PORTVERSION= 68.0.3440.106
PORTREVISION= 1
CATEGORIES?= www
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
@ -308,4 +309,5 @@ post-install-DRIVER-on:
${INSTALL_PROGRAM} ${WRKSRC}/out/${BUILDTYPE}/chromedriver \
${STAGEDIR}${PREFIX}/bin
.endif
.include <bsd.port.mk>

View File

@ -1,11 +0,0 @@
--- content/browser/gpu/gpu_process_host.cc.orig 2017-06-05 19:03:07 UTC
+++ content/browser/gpu/gpu_process_host.cc
@@ -965,7 +965,7 @@ bool GpuProcessHost::LaunchGpuProcess(gpu::GpuPreferen
std::unique_ptr<base::CommandLine> cmd_line =
base::MakeUnique<base::CommandLine>(base::CommandLine::NO_PROGRAM);
#else
-#if defined(OS_LINUX)
+#if defined(OS_LINUX) || defined(OS_BSD)
int child_flags = gpu_launcher.empty() ? ChildProcessHost::CHILD_ALLOW_SELF :
ChildProcessHost::CHILD_NORMAL;
#else

View File

@ -1,14 +0,0 @@
--- gpu/config/BUILD.gn.orig 2018-03-20 23:05:26.000000000 +0100
+++ gpu/config/BUILD.gn 2018-03-26 13:38:50.564110000 +0200
@@ -107,6 +107,11 @@
"gpu_util.h",
]
+ if (is_bsd) {
+ sources -= [ "gpu_info_collector_linux.cc" ]
+ sources += [ "gpu_info_collector_freebsd.cc" ]
+ }
+
if (is_fuchsia) {
sources += [ "gpu_info_collector_fuchsia.cc" ]
}

View File

@ -1,32 +0,0 @@
--- gpu/config/gpu_info_collector_freebsd.cc.orig 2018-08-13 21:50:38.978048000 +0200
+++ gpu/config/gpu_info_collector_freebsd.cc 2018-08-13 21:54:59.868827000 +0200
@@ -0,0 +1,29 @@
+// Copyright 2017 The Chromium Authors. All rights reserved.
+// Use of this source code is governed by a BSD-style license that can be
+// found in the LICENSE file.
+
+#include "base/trace_event/trace_event.h"
+#include "gpu/config/gpu_info_collector.h"
+#include "third_party/angle/src/gpu_info_util/SystemInfo.h"
+
+namespace gpu {
+
+bool CollectContextGraphicsInfo(GPUInfo* gpu_info) {
+ DCHECK(gpu_info);
+
+ TRACE_EVENT0("gpu", "gpu_info_collector::CollectGraphicsInfo");
+
+ return CollectGraphicsInfoGL(gpu_info);
+}
+
+bool CollectBasicGraphicsInfo(GPUInfo* gpu_info) {
+ DCHECK(gpu_info);
+
+ angle::SystemInfo system_info;
+ bool success = angle::GetSystemInfo(&system_info);
+ FillGPUInfoFromSystemInfo(gpu_info, &system_info);
+ return success;
+}
+
+
+} // namespace gpu

View File

@ -6,7 +6,6 @@ bin/chrome
%%DATADIR%%/font_service.service
%%DATADIR%%/headless_lib.pak
%%DATADIR%%/icudtl.dat
%%DATADIR%%/natives_blob.bin
%%DATADIR%%/keyboard_resources.pak
%%DATADIR%%/libEGL.so
%%DATADIR%%/libGLESv2.so
@ -117,6 +116,7 @@ bin/chrome
%%DATADIR%%/locales/zh-TW.pak
%%DATADIR%%/locales/zh-TW.pak.info
%%DATADIR%%/mksnapshot
%%DATADIR%%/natives_blob.bin
%%DATADIR%%/product_logo_48.png
%%DATADIR%%/protoc
%%DATADIR%%/resources.pak
@ -318,6 +318,7 @@ bin/chrome
%%DATADIR%%/v8_context_snapshot.bin
%%DATADIR%%/views_mus_resources.pak
%%DEBUG%%%%DATADIR%%/character_data_generator
%%DEBUG%%%%DATADIR%%/libVkICD_mock_icd.so
%%DEBUG%%%%DATADIR%%/libVkLayer_core_validation.so
%%DEBUG%%%%DATADIR%%/libVkLayer_object_tracker.so
%%DEBUG%%%%DATADIR%%/libVkLayer_parameter_validation.so