Update to 4.8. Back from hell!

Approved by:	portmgr
This commit is contained in:
CHOI Junho 2002-11-27 09:48:39 +00:00
parent fbee30d963
commit d15625b19c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71143
12 changed files with 333 additions and 0 deletions

View File

@ -54,6 +54,8 @@
SUBDIR += msdosfs
SUBDIR += mule-freewnn
SUBDIR += munhwafonts-cid
SUBDIR += netscape48-communicator
SUBDIR += netscape48-navigator
SUBDIR += nh2ps
SUBDIR += nhpf
SUBDIR += nhppf

View File

@ -0,0 +1,98 @@
# New ports collection makefile for: Netscape browser with Korean resources
# Date created: 25 Oct 1998
# Whom: CHOI Junho <cjh@kr.freebsd.org>
#
# $FreeBSD$
#
# based on japanese/netscape4-*
PORTNAME= netscape-${BROWSER_ARC}
PORTVERSION= ${BROWSER_VERSION}
CATEGORIES= korean www
MASTER_SITES= ftp://ftp.kr.freebsd.org/pub/users/cjh/netscape-ko/ \
http://www.kr.freebsd.org/~cjh/freetime/mozilla/netscape-ko/
DISTNAME= ${KOREAN_KIT}
MAINTAINER?= cjh@FreeBSD.org
# ?= for ports that include this Makefile
RUN_DEPENDS?= ${LOCALBASE}/bin/${BROWSER_ARC}-${BROWSER_VERSION}:${PORTSDIR}/www/netscape${BROWSER_VER}-${BROWSER_NAME}
RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/local/gulim12.pcf.gz:${PORTSDIR}/korean/baekmukfonts-bdf \
/compat/linux/usr/share/locale/ko/LC_MESSAGES/SYS_LC_MESSAGES:${PORTSDIR}/korean/linux_locale
NO_BUILD= yes
PKGINSTALL= ${WRKDIR}/INSTALL
PLIST_SUB= NSUBDIR=${NSUBDIR} LANG=${LANG} \
BROWSER=${BROWSER_ARC} VER=${BROWSER_VER}
NDIR= ${PREFIX}/${NSUBDIR}
NSUBDIR?= lib/netscape-linux
# should be changed by versions
BROWSER_NAME?= communicator
BROWSER_ARC?= ${BROWSER_NAME}-linux
BROWSER_BIN?= ${BROWSER_ARC}-${BROWSER_VERSION}.bin
BROWSER_CMD?= ko-${BROWSER_ARC}-${BROWSER_VER}
BROWSER_VER?= 48
BROWSER_VERSION?= 4.8
# for old version(<4.5), font name substitution required.
# newer version use baekmuk-gulim should not be affected.
PREVFONTNAME= kodig
NEWFONTNAME= gulim
KOREAN_KIT?= netscape-korean-kit-v476.20001031
NETHELP?= nethelp-v451
START_SCRIPT?= ${MASTERDIR}/files/start.sh.in
ADDXRESOURCE?= ${MASTERDIR}/files/xresource.ad
LANG= ko_KR.eucKR
MAKESCRIPT= ${SED} -e "s;@X11BASE@;${X11BASE};g" \
-e "s;@PREFIX@;${PREFIX};g" \
-e "s;@NDIR@;${NDIR};g" \
-e "s;@RDIR@;${NDIR};g" \
-e "s;@BROWSER@;${BROWSER_ARC}-${BROWSER_VERSION};g" \
-e "s;@BROWSER_BIN@;${BROWSER_BIN};g" \
-e "s;@LANG@;${LANG};g" \
-e "s;-${PREVFONTNAME}-;-${NEWFONTNAME}-;g"
do-configure:
${MAKESCRIPT} ${START_SCRIPT} >${WRKDIR}/start.sh
# add FreeBSD-specific resource
${MAKESCRIPT} ${WRKSRC}/Netscape.ad-ko >${WRKSRC}/Netscape.2.ad
${CAT} ${WRKSRC}/Netscape.2.ad ${ADDXRESOURCE} \
> ${WRKSRC}/Netscape
${MAKESCRIPT} ${FILESDIR}/INSTALL >${PKGINSTALL}
# make navigator resource
.if defined(BROWSER_NAME) && ${BROWSER_NAME} == navigator
${SED} -e "s;Communicator;Navigator;g" \
${WRKSRC}/about > ${WRKDIR}/about
${SED} -e "s;Communicator;Navigator;g" \
${WRKSRC}/splash > ${WRKDIR}/splash
.else
${CP} ${WRKSRC}/about ${WRKDIR}/about
${CP} ${WRKSRC}/splash ${WRKDIR}/splash
.endif
do-install:
${INSTALL_DATA} ${MASTERDIR}/files/preferences.js ${NDIR}
${MKDIR} ${NDIR}/locale
${LN} -sf /usr/share/locale/en_US.ISO_8859-1 ${NDIR}/locale/${LANG}
${MKDIR} ${NDIR}/${LANG}
${INSTALL_DATA} ${WRKSRC}/netscape.cfg ${NDIR}/
.for f in Netscape mail.msg plugins LICENSE.ko
${INSTALL_DATA} ${WRKSRC}/$f ${NDIR}/${LANG}/
.endfor
.for f in about splash
${INSTALL_DATA} ${WRKDIR}/$f ${NDIR}/${LANG}/
.endfor
${INSTALL_SCRIPT} ${WRKDIR}/start.sh ${PREFIX}/bin/${BROWSER_CMD}
${LN} -sf ${BROWSER_CMD} ${PREFIX}/bin/netscape.run
${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKSRC}/${NETHELP}.nif \
${EXTRACT_AFTER_ARGS} -C ${NDIR}/${LANG}
post-install:
${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (netscape-korean-kit-v476.20001031.tar.gz) = f64bd860ab0f9859ce1739d1d434c9ff

View File

@ -0,0 +1,9 @@
#!/bin/sh
[ "x$1" = "x" ] && exit 1
if [ "x$2" = "xPOST-INSTALL" -a -n "$KO_NETSCAPE_INSTALL_CFG" ]; then
CFGLOC=/usr/lib/X11/@LANG@/app-defaults
if [ ! -e $CFGLOC/netscape.cfg ]; then
mkdir -p $CFGLOC
cp @NDIR@/@LANG@/netscape.cfg $CFGLOC
fi
fi

View File

@ -0,0 +1,29 @@
--- n Sun Oct 25 19:04:57 1998
+++ Netscape.ad-ko Sun Oct 25 19:05:53 1998
@@ -83,7 +83,7 @@
! This is the directory where Netscape finds external files such as icons.
!
-*appDir: /@LOC_LANG@/netscape
+*appDir: @NDIR@/@LANG@
! This resource is the same as the -visual command line option, which selects
! an X visual on which the windows should be created. Legal options are:
@@ -2932,6 +2932,8 @@
*openURLDialog*browserToggle.set: True
*openURLDialog*XmTextField.columns: 45
!*openURLDialog.width: 500
+!*openURLDialog*XmTextField.fontList:\
+!-adobe-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*
@@ -15215,7 +15215,7 @@
!
! version of netscape
-Netscape.version: 4.76
+Netscape.version: 4.8
! Language localization:
*versionLocale: ko

View File

@ -0,0 +1,5 @@
// Netscape User Preferences
// This is a generated file! Do not edit.
user_pref("intl.character_set", 1292);
user_pref("intl.font_spec_list", "misc-gothic-120-noscale-fixed-x-ksc5601-11,misc-gothic-120-noscale-prop-x-ksc5601-11,schumacher-clean-120-noscale-fixed-x-user-defined,schumacher-clean-120-noscale-prop-x-user-defined,nsPseudoFont-courier-120-noscale-fixed-UTF-8,nsPseudoFont-helvetica-120-noscale-prop-UTF-8,isas-fangsong ti-120-noscale-fixed-gb_2312-80,isas-fangsong ti-120-noscale-prop-gb_2312-80,hanyang-kodig-140-noscale-fixed-ks_c_5601-1987,hanyang-kodig-140-noscale-prop-ks_c_5601-1987,misc-fixed-130-noscale-fixed-jis_x0201,misc-fixed-130-noscale-prop-jis_x0201,netscape-fixed-130-noscale-fixed-jis_x0208-1983,netscape-fixed-130-noscale-prop-jis_x0208-1983,sp-courier new-120-noscale-fixed-iso-8859-2,sp-arial-120-noscale-prop-iso-8859-2,adobe-courier-100-noscale-fixed-iso-8859-1,adobe-helvetica-120-noscale-prop-iso-8859-1,");

View File

@ -0,0 +1,33 @@
#!/bin/sh
if [ ! -d $HOME/.netscape ]; then
mkdir -m 700 $HOME/.netscape
cp @RDIR@/preferences.js $HOME/.netscape
chmod 644 $HOME/.netscape/preferences.js
fi
export LANG=@LANG@
export LC_ALL=${LANG}
export LC_CTYPE=${LANG}
export MOZILLA_HOME=@NDIR@
export CLASSPATH=.:${MOZILLA_HOME}
export NS_NETHELP_PATH=${MOZILLA_HOME}/${LANG}
export XKEYSYMDB=@X11BASE@/lib/X11/XKeysymDB
export XAPPLRESDIR=@RDIR@
export TIMID_DIR=/usr/local/lib/timidity
export XCMSDB=/dev/null
ulimit -c 0
ACRO_HOME=@PREFIX@/Acrobat4
if [ -d $ACRO_HOME ]; then
export PATH=${PATH}:${ACRO_HOME}/bin
ACRO_PLUGIN_PATH=:${ACRO_HOME}/Browsers/intellinux
fi
if [ -z $NPX_PLUGIN_PATH ]; then
export NPX_PLUGIN_PATH=${MOZILLA_HOME}/plugins:${HOME}/.netscape/plugins${ACRO_PLUGIN_PATH}
else
export NPX_PLUGIN_PATH=${NPX_PLUGIN_PATH}${ACRO_PLUGIN_PATH}
fi
if [ -x /compat/linux/usr/X11R6/lib/libXm-ns.so.1.0.2 ]; then
MOZILLA_BIN=${MOZILLA_HOME}/netscape-dynMotif
else
MOZILLA_BIN=${MOZILLA_HOME}/@BROWSER_BIN@
fi
exec $MOZILLA_BIN "$@"

View File

@ -0,0 +1,9 @@
! Additional resources, FreeBSD specific
! 2000/7/15 CHOI Junho <cjh@freebsd.org>
!
! These fonts is available from korean/ftghostscript* ports.
! and korean/baekmukfonts-ttf.
!
*documentFonts.EUC-KR*psname: Gulim-Medium-KSC-EUC-H
*documentFonts.EUC-KR*pswidth: 1000
*documentFonts.EUC-KR*psascent: 880

View File

@ -0,0 +1 @@
Netscape web-surfboard with Korean resources

View File

@ -0,0 +1,10 @@
This is the netscape web-surfboard.
Please read the file `/usr/local/lib/netscape/ko_KR.EUC/LICENSE.ko'
for the licensing terms.
Korean Netscape Localization(X11) page(written in Korean):
WWW: http://www.kr.freebsd.org/~cjh/freetime/mozilla/netscape-ko/
--
CHOI Junho <cjh@freebsd.org>

View File

@ -0,0 +1,124 @@
bin/ko-%%BROWSER%%-48
@exec ln -sf %f %B/netscape.run
%%NSUBDIR%%/netscape.cfg
%%NSUBDIR%%/%%LANG%%/Netscape
%%NSUBDIR%%/%%LANG%%/LICENSE.ko
%%NSUBDIR%%/%%LANG%%/about
%%NSUBDIR%%/%%LANG%%/mail.msg
%%NSUBDIR%%/%%LANG%%/plugins
%%NSUBDIR%%/%%LANG%%/splash
@exec mkdir -p %D/%%NSUBDIR%%/locale
@exec ln -sf /usr/share/locale/en_US.ISO_8859-1 %D/%%NSUBDIR%%/locale/%%LANG%%
@unexec rm -f %D/%%NSUBDIR%%/locale/%%LANG%%
@dirrm %%NSUBDIR%%/locale
%%NSUBDIR%%/%%LANG%%/nethelp/Back_dep.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Back_dis.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Back_sel.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Back_up.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Blank.htm
%%NSUBDIR%%/%%LANG%%/nethelp/Button.js
%%NSUBDIR%%/%%LANG%%/nethelp/CntData.js
%%NSUBDIR%%/%%LANG%%/nethelp/CntTool.htm
%%NSUBDIR%%/%%LANG%%/nethelp/CntTool.js
%%NSUBDIR%%/%%LANG%%/nethelp/Exit_dep.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Exit_sel.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Exit_up.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Forw_dep.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Forw_dis.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Forw_sel.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Forw_up.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Header.js
%%NSUBDIR%%/%%LANG%%/nethelp/IdxData.js
%%NSUBDIR%%/%%LANG%%/nethelp/IdxFill.htm
%%NSUBDIR%%/%%LANG%%/nethelp/IdxKey.htm
%%NSUBDIR%%/%%LANG%%/nethelp/IdxTool.htm
%%NSUBDIR%%/%%LANG%%/nethelp/IdxTopic.htm
%%NSUBDIR%%/%%LANG%%/nethelp/Local-1.js
%%NSUBDIR%%/%%LANG%%/nethelp/NavUI.htm
%%NSUBDIR%%/%%LANG%%/nethelp/NoJSerr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/NSHIfrm.htm
%%NSUBDIR%%/%%LANG%%/nethelp/Prnt_dep.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Prnt_sel.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Prnt_up.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Stack.js
%%NSUBDIR%%/%%LANG%%/nethelp/Status.htm
%%NSUBDIR%%/%%LANG%%/nethelp/System.htm
%%NSUBDIR%%/%%LANG%%/nethelp/System.js
%%NSUBDIR%%/%%LANG%%/nethelp/ToolUI.htm
%%NSUBDIR%%/%%LANG%%/nethelp/Tool_dep.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Tool_sel.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Tool_up.gif
%%NSUBDIR%%/%%LANG%%/nethelp/Topic.js
%%NSUBDIR%%/%%LANG%%/nethelp/Utility.js
%%NSUBDIR%%/%%LANG%%/nethelp/Wait.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/coll.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/collHdr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/collabra.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/discgrps.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra/mailbox2.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/comp.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/compHdr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/composer.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/comtlbr2.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/fmtlbr3.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer/tagicon2.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/home/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/home/home.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/home/home.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/home/homeHdr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/abook.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/compbar.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/mailbox.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/mailbox2.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/mess.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/messHdr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/messengr.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/mpctrl.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/newsgrp.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr/tabs.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/navigatr/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/navigatr/nav.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/navigatr/navHdr.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/navigatr/navigatr.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/abook.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/collabra.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/compbar.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/discgrps.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/mailbox2.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/news.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/news/newsgrp.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/NetHelpm.css
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/NetHelpu.css
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/NetHelpw.css
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/admnIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/calIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/collIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/commIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/compIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/confIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/ibmIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/messIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/navIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared/netIcon.gif
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/trouble/help.hpf
%%NSUBDIR%%/%%LANG%%/nethelp/netscape/trouble/trouble.htm
%%NSUBDIR%%/%%LANG%%/nethelp/netwatch.gif
%%NSUBDIR%%/%%LANG%%/nethelp/picsfail.htm
%%NSUBDIR%%/%%LANG%%/nethelp/picsfail.jar
%%NSUBDIR%%/%%LANG%%/nethelp/scraps
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/collabra
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/composer
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/home
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/messengr
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/navigatr
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/news
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/shared
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape/trouble
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp/netscape
@dirrm %%NSUBDIR%%/%%LANG%%/nethelp
@dirrm %%NSUBDIR%%/%%LANG%%
%%NSUBDIR%%/preferences.js

View File

@ -0,0 +1,12 @@
# New ports collection makefile for: Netscape browser with Korean resources
# Date created: 25 Oct 1998
# Whom: CHOI Junho <cjh@FreeBSD.org>
#
# $FreeBSD$
#
# based on japanese/netscape4-*
MASTERDIR= ${.CURDIR}/../netscape48-communicator
BROWSER_NAME= navigator
.include "${MASTERDIR}/Makefile"