MFH: r467209

Added new ports required for gitlab 10.6.x.

Reviewed by:	mat, swills (mentor)
Approved by:	swills (mentor)
Differential Revision:	https://reviews.freebsd.org/D15032

Approved by:	ports-secteam (feld)
This commit is contained in:
Matthias Fechner 2018-05-04 17:45:21 +00:00
parent e7ffa47b60
commit d146bc08cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2018Q2/; revision=469039
13 changed files with 117 additions and 0 deletions

View File

@ -1216,6 +1216,7 @@
SUBDIR += rubygem-gitaly-proto
SUBDIR += rubygem-gitaly-proto083
SUBDIR += rubygem-gitaly-proto084
SUBDIR += rubygem-gitaly-proto088
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-gitlab_omniauth-ldap1
SUBDIR += rubygem-grpc

View File

@ -0,0 +1,24 @@
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
PORTNAME= gitaly-proto
PORTVERSION= 0.88.0
CATEGORIES= net rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 088
MAINTAINER= idefix@fechner.net
COMMENT= Protobuf specifications and client libraries for Gitaly
LICENSE= MIT
RUN_DEPENDS= rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf \
rubygem-grpc>=1.0:net/rubygem-grpc
USES= gem
NO_ARCH= yes
USE_RUBY= yes
PORTSCOUT= limit:^0\.88\.
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1520006039
SHA256 (rubygem/gitaly-proto-0.88.0.gem) = f1e81bc10494fa95d50db227919dd81e5e7c0a78d82e21e1936da02d30afe232
SIZE (rubygem/gitaly-proto-0.88.0.gem) = 15872

View File

@ -0,0 +1,12 @@
Gitaly is part of GitLab. It is a server application that uses its own gRPC
protocol to communicate with its clients. This repository contains the protocol
definition and automatically generated wrapper code for Go and Ruby.
The .proto files define the remote procedure calls for interacting with Gitaly.
We keep auto-generated client libraries for Ruby and Go in their respective
subdirectories.
Use the make generate script from the root of the repository to regenerate the
client libraries after updating .proto files.
WWW: https://gitlab.com/gitlab-org/gitaly-proto

View File

@ -1515,6 +1515,7 @@
SUBDIR += rubygem-gherkin
SUBDIR += rubygem-github-linguist
SUBDIR += rubygem-github-linguist47
SUBDIR += rubygem-github-linguist53
SUBDIR += rubygem-github-markup
SUBDIR += rubygem-gitlab-grit
SUBDIR += rubygem-gitlab-linguist

View File

@ -0,0 +1,30 @@
# $FreeBSD$
PORTNAME= github-linguist
PORTVERSION= 5.3.3
CATEGORIES= textproc rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 53
MAINTAINER= idefix@fechner.net
COMMENT= GitHub Language detection
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-charlock_holmes>=0.7.5:textproc/rubygem-charlock_holmes \
rubygem-escape_utils>=1.1.0:textproc/rubygem-escape_utils \
rubygem-mime-types>=1.19:misc/rubygem-mime-types \
rubygem-rugged>=0.25.1:devel/rubygem-rugged
# bin/linguist
CONFLICTS_INSTALL= qtchooser rubygem-gitlab-linguist
USES= gem
USE_RUBY= yes
PLIST_FILES= bin/git-linguist bin/linguist
PORTSCOUT= limit:^5\.3\.
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1516795422
SHA256 (rubygem/github-linguist-5.3.3.gem) = 33b7145699948800f9866220d0f8bd0ff416622e680d539318fbfa8b17d4ea4d
SIZE (rubygem/github-linguist-5.3.3.gem) = 2425344

View File

@ -0,0 +1,11 @@
--- github-linguist.gemspec.orig 2016-03-28 14:07:51.510285000 +0000
+++ github-linguist.gemspec 2016-03-28 14:19:53.732645000 +0000
@@ -22,7 +22,7 @@
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<charlock_holmes>.freeze, ["~> 0.7.5"])
- s.add_runtime_dependency(%q<escape_utils>.freeze, ["~> 1.1.0"])
+ s.add_runtime_dependency(%q<escape_utils>.freeze, ["~> 1.1"])
s.add_runtime_dependency(%q<mime-types>.freeze, [">= 1.19"])
s.add_runtime_dependency(%q<rugged>.freeze, [">= 0.23.0b"])
s.add_development_dependency(%q<minitest>.freeze, [">= 5.0"])

View File

@ -0,0 +1,3 @@
GitHub Language detection
WWW: https://github.com/github/linguist

View File

@ -2193,6 +2193,7 @@
SUBDIR += rubygem-tinymce-rails
SUBDIR += rubygem-toml-rb
SUBDIR += rubygem-toml-rb03
SUBDIR += rubygem-toml-rb10
SUBDIR += rubygem-totoridipjp
SUBDIR += rubygem-tumblr_client
SUBDIR += rubygem-turbolinks

View File

@ -0,0 +1,22 @@
# $FreeBSD$
PORTNAME= toml-rb
PORTVERSION= 1.0.0
CATEGORIES= www rubygems
MASTER_SITES= RG
PKGNAMESUFFIX= 10
MAINTAINER= idefix@fechner.net
COMMENT= TOML parser using Citrus parsing library
LICENSE= MIT
RUN_DEPENDS= rubygem-citrus>=3.0:textproc/rubygem-citrus
NO_ARCH= yes
USES= gem
USE_RUBY= yes
PORTSCOUT= limit:^1\.0\.
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1498834101
SHA256 (rubygem/toml-rb-1.0.0.gem) = 8d440e2c075ba681d73c0537938a04f7d280896d75f4352123dbe6c36af8e65f
SIZE (rubygem/toml-rb-1.0.0.gem) = 18944

View File

@ -0,0 +1,3 @@
A TOML parser using Citrus parsing library.
WWW: https://github.com/emancu/toml-rb