- Convert to USES=libtool

- Avoid USE_AUTOTOOLS
- Fix build with clang
- Add missing -lcourierauth [1]

Reported by:	antoine [1]
This commit is contained in:
Tijl Coosemans 2014-09-08 21:58:19 +00:00
parent ba59b0ac89
commit d1241626df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=367705
5 changed files with 40 additions and 38 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= courier
PORTVERSION= 0.65.3
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= SF
@ -56,18 +56,12 @@ CALENDIR= /var/spool/calendar
MIMETYPES= ${LOCALBASE}/etc/mime.types
WITH_TRANSPORT= local esmtp dsn
AUTOMAKE_ARGS= --add-missing
USE_AUTOTOOLS= libtool aclocal automake
USES= fam gettext gmake libtool perl5 pkgconfig tar:bzip2
USE_OPENSSL= yes
USE_SUBMAKE= yes
USES= fam gettext gmake perl5 pkgconfig tar:bzip2
USE_RC_SUBR= courier
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV:= ${CONFIGURE_ENV}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-root-check \
--with-db=db \
--enable-syslog=1 --enable-use-flock \
@ -92,8 +86,9 @@ CONFIGURE_ARGS= --disable-root-check \
--with-transport='${WITH_TRANSPORT}' \
--with-default-maildrop=${MAILDROPDEFAULT} \
--with-paranoid-smtpext \
--enable-workarounds-for-imap-client-bugs \
--cache-file=${WRKDIR}/courier.cache
--enable-workarounds-for-imap-client-bugs
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip install-perms
@ -138,10 +133,6 @@ PERIODIC_DESC= modify/create periodic.conf
.include "${.CURDIR}/Makefile.doc"
.include "${.CURDIR}/Makefile.own"
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
USE_GCC= 4.6
.endif
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
WITH_AUTH_LDAP= yes
@ -298,16 +289,8 @@ post-patch:
${WRKSRC}/*/*/*/configure
@${REINPLACE_CMD} -E -e 's/(root|bin)[[:space:]]*bin/root wheel/g' \
${WRKSRC}/courier/perms.sh.in
pre-configure:
@if [ -f "${WRKDIR}/courier.cache" -a -s "${WRKDIR}/courier.cache" ]; then \
${RM} -f "${WRKDIR}/courier.cache"; \
fi
@cp ${LOCALBASE}/share/gettext/po/Makefile.in.in ${WRKSRC}/pcp/po
@cp ${LOCALBASE}/share/libtool/config/ltmain.sh ${WRKSRC}
.for oldlt in . bdbobj cgi courier courier/libs courier/filters courier/filters/perlfilter courier/module.dsn courier/module.esmtp courier/module.local courier/module.uucp gdbmobj gpglib http11 imap ldapaddressbook libhmac liblock maildir maildrop makedat md5 numlib pcp random128 rfc822 rfc1035 rfc2045 sha1 tcpd unicode webmail
@cd ${WRKSRC}/${oldlt} && ${SETENV} ${SCRIPTS_ENV} ${SH} /usr/local/bin/aclocal
.endfor
@${REINPLACE_CMD} '/^courieresmtp_LDADD =/s/$$/ -lcourierauth/' \
${WRKSRC}/courier/module.esmtp/Makefile.in
post-build:
@${PERL} -pi -e 's|^(auth)\s+(required).*|$$1\t\t$$2\tpam_unix.so\ttry_first_pass|g;' \

View File

@ -0,0 +1,10 @@
--- courier/cdmsgq.C.orig 2009-05-02 15:11:56 UTC
+++ courier/cdmsgq.C
@@ -38,6 +38,7 @@
#include <utime.h>
#include "numlib/numlib.h"
+#include <functional>
#include <vector>
#include <list>
#include <algorithm>

View File

@ -0,0 +1,11 @@
--- courier/cmlmfetch.C.orig 2009-11-08 18:14:47 UTC
+++ courier/cmlmfetch.C
@@ -334,7 +334,7 @@ int doindex(const char *n)
ack << std::setiosflags(std::ios::right)
<< std::setw(10)
<< msgs[i]
- << resetiosflags(std::ios::right) << " "
+ << std::resetiosflags(std::ios::right) << " "
<< std::setw(0) << msginfo[i].msgsubj << std::endl;
ack << std::setiosflags(std::ios::right)
<< std::setw(10)

View File

@ -1,13 +0,0 @@
--- courier/configure.in.orig 2009-09-05 13:59:26.000000000 +0200
+++ courier/configure.in 2010-02-15 19:44:35.000000000 +0100
@@ -77,6 +77,10 @@
esac
AC_SUBST(testmode)
+AC_ARG_WITH(piddir, [ --with-piddir Directory where imapd.pid is created ], piddir="$withval", piddir=$localstatedir/run)
+
+AC_SUBST(piddir)
+
version=`cat ../version`
COPYRIGHT="Courier $version Copyright 1999-2008 Double Precision, Inc."

View File

@ -0,0 +1,11 @@
--- courier/webmlmd.H.orig 2007-12-17 12:09:18 UTC
+++ courier/webmlmd.H
@@ -49,7 +49,7 @@ namespace webmlmd {
T t;
t.reserve(s.size() * 6 / 5);
- class T::iterator b=s.begin(), e=s.end(), p=b;
+ typename T::iterator b=s.begin(), e=s.end(), p=b;
while (b != e)
{