devel/py-columnize: Update version 0.3.10=>0.3.11

- Add test framework

Relnotes: https://github.com/rocky/pycolumnize/releases/tag/3.11
This commit is contained in:
Muhammad Moinur Rahman 2022-03-13 15:55:36 -05:00
parent cdb636f8c8
commit d070722720
3 changed files with 8 additions and 20 deletions

View File

@ -1,5 +1,5 @@
PORTNAME= columnize
PORTVERSION= 0.3.10
PORTVERSION= 0.3.11
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -9,15 +9,14 @@ COMMENT= Format a simple (i.e. not nested) list into aligned columns
LICENSE= MIT
MY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.0:devel/py-nose@${PY_FLAVOR}
BUILD_DEPENDS= ${MY_DEPENDS}
RUN_DEPENDS= ${MY_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist distutils
EXTRA_PATCHES= ${FILESDIR}/extra-patch-____pkginfo____.py
NO_ARCH= yes
do-test:
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1614668083
SHA256 (columnize-0.3.10.tar.gz) = 5669984ae49447ee21dc33b6635a23827b25f4015e92c0858e1ac29f4e6cf5cc
SIZE (columnize-0.3.10.tar.gz) = 9690
TIMESTAMP = 1647204252
SHA256 (columnize-0.3.11.tar.gz) = a631b863b310a6c1457629b7bf32a3777ea5a407f8985311ce8c24c31d1d8bb2
SIZE (columnize-0.3.11.tar.gz) = 18776

View File

@ -1,11 +0,0 @@
--- __pkginfo__.py.orig 2015-10-27 08:06:17 UTC
+++ __pkginfo__.py
@@ -28,7 +28,7 @@ web = 'https://github.com/rocky/pycolumn
zip_safe = False
def read(*rnames):
- return open(os.path.join(os.path.dirname(__file__), *rnames)).read()
+ return open(os.path.join(os.path.dirname(__file__), *rnames), encoding='utf8').read()
readme = 'README.txt'
if os.path.exists('README.rst'): readme = 'README.rst'