Add yet another AVR assembler. This one appears to have better

version control than Tom's AVR Assembler (tavrasm), and to accept
more of the standard Atmel source files.  This one also has an
enhanced macro facility.
This commit is contained in:
Wes Peters 2005-02-18 03:13:57 +00:00
parent b8760e254a
commit d053274d71
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=129124
7 changed files with 74 additions and 0 deletions

View File

@ -69,6 +69,7 @@
SUBDIR += avr-gcc
SUBDIR += avr-gdb
SUBDIR += avr-libc
SUBDIR += avra
SUBDIR += avrdude
SUBDIR += bcc
SUBDIR += bcpp

33
devel/avra/Makefile Normal file
View File

@ -0,0 +1,33 @@
# New ports collection makefile for: tavrasm
# Date created: 12 December 2003
# Whom: Wes Peters <wes@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= avra
PORTVERSION= 1.0.1
DISTVERSIONSUFFIX= -src
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=${PORTNAME}
MAINTAINER= wes@FreeBSD.org
COMMENT= Macro Assembler for Atmel AVR microcontrollers
USE_GMAKE= yes
WRKSRC= ${WRKDIR}
BUILD_WRKSRC= ${WRKSRC}/SOURCE
INSTALL_WRKSRC= ${WRKSRC}/SOURCE
PORTDOCS= README
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

2
devel/avra/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (avra-1.0.1-src.tar.gz) = 002a810e12d6b64f0079a7508a5b8066
SIZE (avra-1.0.1-src.tar.gz) = 90993

View File

@ -0,0 +1,13 @@
--- SOURCE/Makefile.orig Tue Feb 15 07:40:36 2005
+++ SOURCE/Makefile Tue Feb 15 07:40:58 2005
@@ -27,8 +27,8 @@
install: avra
cp avra /usr/local/bin
- cp avra.1 /usr/local/man/man1
- chmod +r /usr/local/man/man1/avra.1
+# cp avra.1 /usr/local/man/man1
+# chmod +r /usr/local/man/man1/avra.1
clean:
rm -f avra *.o *.p *~ avra.exe

View File

@ -0,0 +1,20 @@
--- SOURCE/expr.c.orig Thu Jun 10 21:01:40 2004
+++ SOURCE/expr.c Mon Feb 14 21:30:15 2005
@@ -241,7 +241,7 @@
}
-int log2(int value)
+int do_log2(int value)
{
int i = 0;
@@ -271,7 +271,7 @@
case FUNCTION_EXP2:
return(1 << value);
case FUNCTION_LOG2:
- return(log2(value));
+ return(do_log2(value));
default:
return(0);
}

4
devel/avra/pkg-descr Normal file
View File

@ -0,0 +1,4 @@
avra is an GNU GPL'ed assembler for the Atmel AVR microcontrollers.
See the file COPYING for more information regarding the license.
WWW: http://avra.sourceforge.net/

1
devel/avra/pkg-plist Normal file
View File

@ -0,0 +1 @@
bin/avra