math/facile:

- add patch to fix build with ocaml-4
- modernize Makefile (USES, staging)
- bump PORTREVISION after ocaml update
- assign maintainership to kde@
This commit is contained in:
Max Brazhnikov 2014-04-01 08:41:13 +00:00
parent 3b3348b1e1
commit d02c2961d0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=349826
3 changed files with 23 additions and 9 deletions

View File

@ -3,23 +3,26 @@
PORTNAME= facile
PORTVERSION= 1.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= math
MASTER_SITES= http://www.recherche.enac.fr/log/facile/distrib/
MAINTAINER= ports@FreeBSD.org
COMMENT= A Functional Constraint Library
MAINTAINER= kde@FreeBSD.org
COMMENT= Functional Constraint Library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake
USE_OCAML= yes
HAS_CONFIGURE= yes
USE_GMAKE= yes
ALL_TARGET= compile
NO_STAGE= yes
post-patch:
${REINPLACE_CMD} -e "s,make,${GMAKE},; \
s,cp,${INSTALL_DATA}," ${WRKSRC}/Makefile
post-configure:
${REINPLACE_CMD} -e "s,make,${MAKE_CMD},; \
s,cp,${INSTALL_DATA},;\
s,mkdir,${MKDIR}," ${WRKSRC}/Makefile
${REINPLACE_CMD} -e "s,${LOCALBASE},${STAGEDIR}${PREFIX}," \
${WRKSRC}/config_Makefile
.include <bsd.port.mk>

View File

@ -0,0 +1,11 @@
--- ./src/fcl_data.ml
+++ ./src/fcl_data.ml
@@ -16,7 +16,7 @@ end
module Hashtbl = struct
type ('a, 'b) t = ('a, 'b) Hashtbl.t
- let create = Hashtbl.create
+ let create n = Hashtbl.create n
let get h = h
let add h k d =

View File

@ -7,4 +7,4 @@ FaCiLe allows as well to build easily user-defined constraints and goals,
making pervasive use of OCaml higher-order functionals to provide a simple
and flexible interface for the user.
WWW: http://www.recherche.enac.fr/log/facile/
WWW: http://www.recherche.enac.fr/log/facile/