Fix build with gcc-3.4

This commit is contained in:
Kirill Ponomarev 2004-08-22 14:41:33 +00:00
parent f1e88b64a3
commit cffb284e1c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=117027
3 changed files with 38 additions and 0 deletions

View File

@ -26,6 +26,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB= NLS="@comment "
.endif
CFLAGS+= -fpermissive
MAN1= motor.1
.include <bsd.port.pre.mk>

View File

@ -0,0 +1,23 @@
$FreeBSD$
--- parser/src/parser.c.orig Sun Aug 22 16:26:05 2004
+++ parser/src/parser.c Sun Aug 22 16:26:25 2004
@@ -313,7 +313,7 @@
buf = mmap(0, *size, PROT_READ, MAP_SHARED, f, 0);
if (buf == MAP_FAILED) buf = NULL;
break;
- default:
+ default: break;
}
}
close(f);
@@ -333,7 +333,7 @@
// munmap
munmap(text, size);
break;
- default:
+ default: break;
}
}

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- server/Game.c.orig Sun Aug 22 16:35:40 2004
+++ server/Game.c Sun Aug 22 16:35:50 2004
@@ -226,7 +226,7 @@
case PLAYER_DESTROY : /* Destroy 状態の Player を削除する */
current = ObjList_DeleteObjToPrev(game->player_list, current);
break;
- default :
+ default : break;
}
}