tclxml-libxml2

TclXML is an API for parsing XML documents using the Tcl scripting
language. It is also a package with several parser implementations.
The goal of the TclXML package is to provide an API for Tcl scripts
that allows "Plug-and-Play" parser implementations; ie. an application
will be able to use different parser implementations without change
to the application code.

PR:		ports/123163
Submitted by:	Frank Fenor
This commit is contained in:
Beech Rintoul 2008-05-05 15:03:02 +00:00
parent 665867f4fd
commit cfc600a6c0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=212663
5 changed files with 49 additions and 0 deletions

View File

@ -2378,6 +2378,7 @@
SUBDIR += tcltls
SUBDIR += tclxml
SUBDIR += tclxml-expat
SUBDIR += tclxml-libxml2
SUBDIR += tdl
SUBDIR += templ
SUBDIR += terminality

View File

@ -0,0 +1,21 @@
# New ports collection makefile for: tclxml-libxml2
# Date created: 28 April 2008
# Whom: Frank Fenor
#
# $FreeBSD$
#
PKGNAMESUFFIX= -libxml2
MAINTAINER= frank@fenor.de
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= ${LOCALBASE}/lib/TclxmlConfig.sh:${PORTSDIR}/devel/tclxml
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/libxml2
USE_LDCONFIG= ${LOCALBASE}/lib/TclXML_libxml2${PORTVERSION}
LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
MASTERDIR= ${.CURDIR}/../tclxml
.include "${MASTERDIR}/Makefile"

View File

@ -0,0 +1,11 @@
--- configure.orig 2008-04-28 16:02:30.000000000 +0200
+++ configure 2008-04-28 16:02:51.000000000 +0200
@@ -3316,7 +3316,7 @@
TCL_INCLUDES=-I\"${INCLUDE_DIR_NATIVE}\"
-
+ TCL_SRC_DIR=${with_tclinclude}
echo $ac_n "checking for Tcl private include files""... $ac_c" 1>&6

View File

@ -0,0 +1,9 @@
tclxml-libxml2
TclXML is an API for parsing XML documents using the Tcl scripting
language. It is also a package with several parser implementations.
The goal of the TclXML package is to provide an API for Tcl scripts
that allows "Plug-and-Play" parser implementations; ie. an application
will be able to use different parser implementations without change
to the application code.
WWW: http://tclxml.sourceforge.net/

View File

@ -0,0 +1,7 @@
include/tclxml-libxml2/docObj.h
include/tclxml-libxml2/tclxml-libxml2.h
include/tclxml-libxml2/tclxml-libxml2Decls.h
lib/TclXML_libxml2%%VER%%/libTclXML_libxml2%%VER%%.so
lib/TclXML_libxml2%%VER%%/pkgIndex.tcl
@dirrm lib/TclXML_libxml2%%VER%%
@dirrm include/tclxml-libxml2