get rid of libgnugetopt dependency for -CURRENT,

use USE_GETOPT_LONG instead.
use getopt_long() instead of getopt_long_only().
This commit is contained in:
FUJISHIMA Satsuki 2003-07-14 02:37:35 +00:00
parent e496d3c279
commit cfbbad11c9
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=84835
6 changed files with 81 additions and 11 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= wmmount
PORTVERSION= 1.0b2
PORTREVISION= 1
CATEGORIES= sysutils windowmaker afterstep
MASTER_SITES= http://www.geocities.com/SiliconValley/Vista/2471/files/
DISTNAME= ${PORTNAME}-1.0-beta2
@ -15,15 +16,12 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= The freespace for Window Maker
USE_GETOPT_LONG=yes
USE_IMAKE= yes
USE_XPM= yes
USE_REINPLACE= yes
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
LIB_DEPENDS+= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
post-patch:
.for file in system.wmmount.eg system.wmmount.sh
@${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/config/${file}

View File

@ -0,0 +1,11 @@
--- dockapp.c.orig Fri Jun 18 04:41:41 1999
+++ dockapp.c Mon Jul 7 04:34:44 2003
@@ -89,7 +89,7 @@
dockapp_argv=argv;
while(true) {
option_index=0;
- option_c=getopt_long_only(argc, argv, "-hwsaf:b:", long_options, &option_index);
+ option_c=getopt_long(argc, argv, "-hwsaf:b:", long_options, &option_index);
if(option_c==-1)
break;
if(option_c==0) {

View File

@ -0,0 +1,11 @@
--- wmmount.c.orig Fri Jun 18 04:41:41 1999
+++ wmmount.c Mon Jul 7 04:35:33 2003
@@ -231,7 +231,7 @@
};
while(true) {
option_index=0;
- option_c=getopt_long_only(argc, (char * const *)argv, "-h", long_options, &option_index);
+ option_c=getopt_long(argc, (char * const *)argv, "-h", long_options, &option_index);
if(option_c==-1)
break;
if(option_c==1) {

View File

@ -7,6 +7,7 @@
PORTNAME= wmfishtime
PORTVERSION= 1.23
PORTREVISION= 1
CATEGORIES= x11-clocks windowmaker
MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
http://atreides.freenix.no/~anders/
@ -14,14 +15,14 @@ MASTER_SITES= http://www.ne.jp/asahi/linux/timecop/software/ \
MAINTAINER= anders@FreeBSD.org
COMMENT= A time/date applet for WindowMaker with fishes swimming around
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_GETOPT_LONG=yes
USE_GNOME= gtk12
USE_X_PREFIX= yes
GTK_LIBS?= `${GTK_CONFIG} --libs`
GTK_CFLAGS?= `${GTK_CONFIG} --cflags`
MAKE_ARGS+= CFLAGS="${CFLAGS} -Wall -I${LOCALBASE}/include ${GTK_CFLAGS}" \
MAKE_ARGS+= CFLAGS="${CPPFLAGS} ${CFLAGS} -Wall ${GTK_CFLAGS}" \
LDFLAGS="${LDFLAGS}" \
GTK_LIBS="${GTK_LIBS}"
do-install:

View File

@ -1,6 +1,6 @@
--- Makefile.orig Sat May 26 22:49:41 2001
+++ Makefile Sun May 27 00:14:26 2001
@@ -6,17 +6,15 @@
--- Makefile.orig Sun May 27 05:49:41 2001
+++ Makefile Sun Jul 6 20:29:07 2003
@@ -6,23 +6,21 @@
# no user serviceable parts below this line
# optimization cflags
@ -15,7 +15,14 @@
SHELL = sh
OBJS = fishmon.o
-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
+LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"` -lgnugetopt
+LIBS = `echo $(GTK_LIBS) | sed "s/-lgtk12//g"`
INSTALL = -m 755
all: wmfishtime
wmfishtime: $(OBJS)
- $(CC) $(CFLAGS) -o wmfishtime $(OBJS) $(LIBS)
+ $(CC) $(CFLAGS) -o wmfishtime $(OBJS) $(LIBS) $(LDFLAGS)
clean:
rm -rf wmfishtime *.o *.bb* *.gcov gmon.* *.da *~ .xvpics

View File

@ -0,0 +1,42 @@
--- fishmon.c.orig Sun May 27 05:53:09 2001
+++ fishmon.c Mon Jul 7 04:01:52 2003
@@ -1018,26 +1018,28 @@
{
static int ch = 0;
static struct option long_opts[] = {
- { "h", no_argument, NULL, 1 },
- { "help", no_argument, NULL, 1 },
- { "v", no_argument, NULL, 2 },
- { "version", no_argument, NULL, 2 },
- { "c", no_argument, &enable_check_mail, 1 },
- { "check-mail", no_argument, &enable_check_mail, 1 },
- { "b", no_argument, &broken_wm, 1 },
- { "broken", no_argument, &broken_wm, 1 },
+ { "help", no_argument, NULL, 'h' },
+ { "version", no_argument, NULL, 'v' },
+ { "check-mail", no_argument, &enable_check_mail, 'c' },
+ { "broken", no_argument, &broken_wm, 'b' },
{ 0, 0, 0, 0 }
};
- while ((ch = getopt_long_only(argc, argv, "", long_opts, NULL)) != -1) {
+ while ((ch = getopt_long(argc, argv, "hvcb", long_opts, NULL)) != -1) {
switch (ch) {
- case 1:
+ case 'h':
do_help();
exit(0);
break;
- case 2:
+ case 'v':
do_version();
exit(0);
+ break;
+ case 'c':
+ enable_check_mail = 1;
+ break;
+ case 'b':
+ broken_wm = 1;
break;
}
}