- Update to 2.1.17
- Add support for OpenSSL - Handle resin2_flags to pass JVM options in rc(8) - Fix the port so that it may be built (and cleaned) correctly as a user PR: 90489 Submitted by: maintainer
This commit is contained in:
parent
a7ba6c0568
commit
cfaaf7bff8
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=151798
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= resin
|
||||
PORTVERSION= 2.1.16
|
||||
PORTVERSION= 2.1.17
|
||||
CATEGORIES= www java
|
||||
MASTER_SITES= http://www.caucho.com/download/
|
||||
|
||||
@ -18,6 +18,7 @@ JAVA_VERSION= 1.2+
|
||||
HAS_CONFIGURE= yes
|
||||
USE_PYTHON= yes
|
||||
USE_REINPLACE= yes
|
||||
USE_OPENSSL= yes
|
||||
|
||||
# Customizable settings
|
||||
RUNASUSER?= www
|
||||
@ -55,7 +56,10 @@ COPYDIRS= doc lib libexec xsl
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Pass JAVA_HOME as determined by bsd.java.mk
|
||||
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
|
||||
CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME} \
|
||||
--with-openssl-lib=${OPENSSLLIB} \
|
||||
--with-openssl-include=${OPENSSLINC}
|
||||
LDFLAGS+= -L${OPENSSLLIB} -lcrypto -lssl
|
||||
|
||||
# Install the Apache plugin if needed
|
||||
.if defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES)
|
||||
@ -117,16 +121,25 @@ defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
|
||||
@${ECHO_CMD} The Resin Apache module mod_caucho has been activated \
|
||||
in the Apache configuration file, where you should also \
|
||||
add a line to specify the location of the Resin configuration \
|
||||
file, for example: | fmt -w 80 >> ${PKGMESSAGE}
|
||||
file, for example: | ${FMT} -w 80 >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} "<IfModule mod_caucho.c>" >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} " CauchoConfigFile ${PREFIX}/etc/${APP_NAME}.xml" >> ${PKGMESSAGE}
|
||||
@${ECHO_CMD} "</IfModule>" >> ${PKGMESSAGE}
|
||||
.endif
|
||||
|
||||
post-build:
|
||||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} install
|
||||
|
||||
# Resin does not handle installation, so proceed now
|
||||
post-install:
|
||||
do-install:
|
||||
@${SETENV} RUNASUSER=${RUNASUSER} GROUP=${GROUP} ${SH} ${WRKDIR}/install.sh
|
||||
.if (defined(WITH_APACHE2) && (${WITH_APACHE2} == yes || ${WITH_APACHE2} == YES))
|
||||
${APXS} -i -n caucho -a ${WRKSRC}/src/c/plugin/apache2/mod_caucho.so
|
||||
.endif
|
||||
.if (defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES))
|
||||
${APXS} -i -n caucho -a ${WRKSRC}/src/c/plugin/apache1/mod_caucho.so
|
||||
.endif
|
||||
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
|
||||
@${ECHO_MSG}
|
||||
@${ECHO_MSG} "********************************************************************************"
|
||||
|
@ -1,2 +1,3 @@
|
||||
MD5 (resin-2.1.16.tar.gz) = 0651cfa42705397be714cee27556b028
|
||||
SIZE (resin-2.1.16.tar.gz) = 3312495
|
||||
MD5 (resin-2.1.17.tar.gz) = 75c96945b8c71a193d708073d00025ae
|
||||
SHA256 (resin-2.1.17.tar.gz) = c9291e89a544809e637522dd0b47c5191263bd33942715006814147c1bd02104
|
||||
SIZE (resin-2.1.17.tar.gz) = 2956041
|
||||
|
@ -1,14 +1,11 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- src/c/plugin/apache/Makefile.in.orig Thu Nov 13 09:27:52 2003
|
||||
+++ src/c/plugin/apache/Makefile.in Thu Nov 13 09:28:36 2003
|
||||
@@ -28,8 +28,7 @@
|
||||
--- src/c/plugin/apache/Makefile.in.orig Fri Dec 16 13:18:12 2005
|
||||
+++ src/c/plugin/apache/Makefile.in Fri Dec 16 13:18:19 2005
|
||||
@@ -28,8 +28,6 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.la *.so
|
||||
|
@ -1,14 +1,11 @@
|
||||
$FreeBSD$
|
||||
|
||||
--- src/c/plugin/apache2/Makefile.in.orig Thu Nov 13 09:28:46 2003
|
||||
+++ src/c/plugin/apache2/Makefile.in Thu Nov 13 09:28:52 2003
|
||||
@@ -27,8 +27,7 @@
|
||||
--- src/c/plugin/apache2/Makefile.in.orig Fri Dec 16 13:18:09 2005
|
||||
+++ src/c/plugin/apache2/Makefile.in Fri Dec 16 13:18:21 2005
|
||||
@@ -27,8 +27,6 @@
|
||||
$(CC) -c $(INCLUDES) $(CFLAGS) $<
|
||||
|
||||
install :
|
||||
- sh install.sh -conf $(apache_conf) -libexec $(apache_libexec) \
|
||||
- -resin_home $(resin_home)
|
||||
+ %%APXS%% -i -a -n caucho mod_caucho.so
|
||||
|
||||
clean :
|
||||
- rm *.o *.lo *.so
|
||||
|
@ -8,7 +8,40 @@ Then start it:
|
||||
|
||||
env - %%PREFIX%%/etc/rc.d/%%APP_NAME%%.sh start
|
||||
|
||||
And point your web browser to the default home page at
|
||||
For this control script to run seamlessly, it is recommended to increase the
|
||||
maximum length of commands displayed by ps(1). Please append the following
|
||||
setting to /etc/sysctl.conf:
|
||||
|
||||
# Do not truncate command line arguments in ps(1) listing
|
||||
kern.ps_arg_cache_limit=10000
|
||||
|
||||
This setting will take effect at next reboot, however it is possible to have
|
||||
immediate effect with the following command as root:
|
||||
|
||||
# sysctl kern.ps_arg_cache_limit=10000
|
||||
|
||||
If you wish to skip this setting, please note that the `stop', `restart' and
|
||||
`status' will not function properly with %%APP_NAME%%.sh.
|
||||
|
||||
Once Resin is started, point your web browser to the default home page at
|
||||
http://localhost:%%PORT%%/ to read the documentation and test the samples.
|
||||
|
||||
Resin configuration is located at %%PREFIX%%/etc/%%APP_NAME%%.xml
|
||||
|
||||
|
||||
Enjoy!
|
||||
|
||||
--------------------------------------------------------------------------------
|
||||
ADVANCED USAGE
|
||||
|
||||
If you need to pass special options to Java, please set the
|
||||
%%APP_NAME%%_flags option in /etc/rc.conf, see examples below:
|
||||
|
||||
# Prevent Java from opening an X11 display
|
||||
%%APP_NAME%%_flags="-Djava.awt.headless=true"
|
||||
|
||||
# Increase memory limit of the Java virtual machine
|
||||
%%APP_NAME%%_flags="-Xms32m -Xmx256m"
|
||||
|
||||
# Run Java with remote debugging turned on on port 8000
|
||||
%%APP_NAME%%_flags="-Xdebug -Xnoagent -Xrunjdwp:transport=dt_socket,server=y,suspend=n,address=8000"
|
||||
|
@ -157,8 +157,7 @@ if __name__ == '__main__':
|
||||
COMMAND = "%%JAVA%%"
|
||||
ARGS = [COMMAND]
|
||||
|
||||
if os.environ.has_key('JAVA_OPTS'):
|
||||
ARGS += os.environ['JAVA_OPTS'].split(" ")
|
||||
ARGS += sys.argv[1:-1]
|
||||
|
||||
ARGS += [
|
||||
"-Dresin.home=%%APP_HOME%%",
|
||||
@ -169,17 +168,17 @@ if __name__ == '__main__':
|
||||
os.environ['JAVA_HOME'] = "%%JAVA_HOME%%"
|
||||
os.environ['CLASSPATH'] = classpath()
|
||||
|
||||
if len(sys.argv) != 2:
|
||||
if len(sys.argv) < 2:
|
||||
usage()
|
||||
sys.exit(1)
|
||||
|
||||
if sys.argv[1] == "start":
|
||||
if sys.argv[-1] == "start":
|
||||
start()
|
||||
|
||||
elif sys.argv[1] == "stop":
|
||||
elif sys.argv[-1] == "stop":
|
||||
stop()
|
||||
|
||||
elif sys.argv[1] == "restart":
|
||||
elif sys.argv[-1] == "restart":
|
||||
stop()
|
||||
start()
|
||||
|
||||
|
@ -117,34 +117,103 @@
|
||||
%%APP_NAME%%/doc/faq/toc.xml
|
||||
%%APP_NAME%%/doc/features.xtp
|
||||
%%APP_NAME%%/doc/future.xtp
|
||||
%%APP_NAME%%/doc/images/2020media.gif
|
||||
%%APP_NAME%%/doc/images/C5.gif
|
||||
%%APP_NAME%%/doc/images/altlinuxlogo.gif
|
||||
%%APP_NAME%%/doc/images/anonymous-caching.gif
|
||||
%%APP_NAME%%/doc/images/apache_srun.gif
|
||||
%%APP_NAME%%/doc/images/appserver.gif
|
||||
%%APP_NAME%%/doc/images/ascendim logo.gif
|
||||
%%APP_NAME%%/doc/images/av.gif
|
||||
%%APP_NAME%%/doc/images/background.gif
|
||||
%%APP_NAME%%/doc/images/backup.gif
|
||||
%%APP_NAME%%/doc/images/balance.gif
|
||||
%%APP_NAME%%/doc/images/ball8.gif
|
||||
%%APP_NAME%%/doc/images/bean.gif
|
||||
%%APP_NAME%%/doc/images/bean1.gif
|
||||
%%APP_NAME%%/doc/images/caucho-blue.gif
|
||||
%%APP_NAME%%/doc/images/beantree.gif
|
||||
%%APP_NAME%%/doc/images/bloomfield-nutrition.gif
|
||||
%%APP_NAME%%/doc/images/brave.gif
|
||||
%%APP_NAME%%/doc/images/caucho.gif
|
||||
%%APP_NAME%%/doc/images/comics.gif
|
||||
%%APP_NAME%%/doc/images/compiler.gif
|
||||
%%APP_NAME%%/doc/images/comsquared.gif
|
||||
%%APP_NAME%%/doc/images/cwi.gif
|
||||
%%APP_NAME%%/doc/images/dilbert.gif
|
||||
%%APP_NAME%%/doc/images/dual-sticky-sessions.gif
|
||||
%%APP_NAME%%/doc/images/e-gate.gif
|
||||
%%APP_NAME%%/doc/images/ecornell.gif
|
||||
%%APP_NAME%%/doc/images/edensoftlogo.gif
|
||||
%%APP_NAME%%/doc/images/efectelogo.gif
|
||||
%%APP_NAME%%/doc/images/fatwirelogo.gif
|
||||
%%APP_NAME%%/doc/images/file.gif
|
||||
%%APP_NAME%%/doc/images/filter.gif
|
||||
%%APP_NAME%%/doc/images/finatec.gif
|
||||
%%APP_NAME%%/doc/images/folder.gif
|
||||
%%APP_NAME%%/doc/images/halfcom.gif
|
||||
%%APP_NAME%%/doc/images/hbleed.gif
|
||||
%%APP_NAME%%/doc/images/head_dilbert.gif
|
||||
%%APP_NAME%%/doc/images/httpd.gif
|
||||
%%APP_NAME%%/doc/images/idetixlogo.gif
|
||||
%%APP_NAME%%/doc/images/iis_srun.gif
|
||||
%%APP_NAME%%/doc/images/inktomi.gif
|
||||
%%APP_NAME%%/doc/images/intramart1.gif
|
||||
%%APP_NAME%%/doc/images/iwon.gif
|
||||
%%APP_NAME%%/doc/images/jahialogo.gif
|
||||
%%APP_NAME%%/doc/images/javanet.gif
|
||||
%%APP_NAME%%/doc/images/jdbc-sessions.gif
|
||||
%%APP_NAME%%/doc/images/jndi_tree.gif
|
||||
%%APP_NAME%%/doc/images/jsp.gif
|
||||
%%APP_NAME%%/doc/images/jsp_log.gif
|
||||
%%APP_NAME%%/doc/images/jsp_perf.gif
|
||||
%%APP_NAME%%/doc/images/keycommerce.gif
|
||||
%%APP_NAME%%/doc/images/kibu.gif
|
||||
%%APP_NAME%%/doc/images/klopotek.gif
|
||||
%%APP_NAME%%/doc/images/klopotekcBiZZ.gif
|
||||
%%APP_NAME%%/doc/images/left_background.gif
|
||||
%%APP_NAME%%/doc/images/logo.gif
|
||||
%%APP_NAME%%/doc/images/logo2.gif
|
||||
%%APP_NAME%%/doc/images/logo60.gif
|
||||
%%APP_NAME%%/doc/images/mini.gif
|
||||
%%APP_NAME%%/doc/images/miniusa.gif
|
||||
%%APP_NAME%%/doc/images/multipage.gif
|
||||
%%APP_NAME%%/doc/images/neteverything.gif
|
||||
%%APP_NAME%%/doc/images/netregistry.gif
|
||||
%%APP_NAME%%/doc/images/new.gif
|
||||
%%APP_NAME%%/doc/images/openpath.gif
|
||||
%%APP_NAME%%/doc/images/petsmart.gif
|
||||
%%APP_NAME%%/doc/images/pixel.gif
|
||||
%%APP_NAME%%/doc/images/proosto.gif
|
||||
%%APP_NAME%%/doc/images/r950.gif
|
||||
%%APP_NAME%%/doc/images/realsecure.gif
|
||||
%%APP_NAME%%/doc/images/resin_powered.gif
|
||||
%%APP_NAME%%/doc/images/resinlogoamber.gif
|
||||
%%APP_NAME%%/doc/images/resinlogoblue.gif
|
||||
%%APP_NAME%%/doc/images/resinlogogrey.gif
|
||||
%%APP_NAME%%/doc/images/salesforce.gif
|
||||
%%APP_NAME%%/doc/images/same_srun.gif
|
||||
%%APP_NAME%%/doc/images/samlogo.gif
|
||||
%%APP_NAME%%/doc/images/script.gif
|
||||
%%APP_NAME%%/doc/images/servlets.gif
|
||||
%%APP_NAME%%/doc/images/smallnew.gif
|
||||
%%APP_NAME%%/doc/images/snoopy.gif
|
||||
%%APP_NAME%%/doc/images/snoopy2.gif
|
||||
%%APP_NAME%%/doc/images/snoopy3.gif
|
||||
%%APP_NAME%%/doc/images/srunc.gif
|
||||
%%APP_NAME%%/doc/images/sticky-sessions.gif
|
||||
%%APP_NAME%%/doc/images/style.gif
|
||||
%%APP_NAME%%/doc/images/subpage-cache.gif
|
||||
%%APP_NAME%%/doc/images/tangosollogo.gif
|
||||
%%APP_NAME%%/doc/images/template.gif
|
||||
%%APP_NAME%%/doc/images/tolerance.gif
|
||||
%%APP_NAME%%/doc/images/torchconcepts.gif
|
||||
%%APP_NAME%%/doc/images/ustobe.gif
|
||||
%%APP_NAME%%/doc/images/viewsliplogo.gif
|
||||
%%APP_NAME%%/doc/images/webcollagelogo.gif
|
||||
%%APP_NAME%%/doc/images/webserver.gif
|
||||
%%APP_NAME%%/doc/images/website_srun.gif
|
||||
%%APP_NAME%%/doc/images/xslt-perf.gif
|
||||
%%APP_NAME%%/doc/images/xtp.gif
|
||||
%%APP_NAME%%/doc/index.xtp
|
||||
%%APP_NAME%%/doc/java_tut/WEB-INF/classes/example/servlet/basic/HelloServlet.java
|
||||
%%APP_NAME%%/doc/java_tut/WEB-INF/classes/example/servlet/basic/InitServlet.java
|
||||
@ -351,10 +420,7 @@
|
||||
%%APP_NAME%%/doc/toc.xml
|
||||
%%APP_NAME%%/lib/dom.jar
|
||||
%%APP_NAME%%/lib/jaxp.jar
|
||||
%%APP_NAME%%/lib/jdbc-mysql.jar
|
||||
%%APP_NAME%%/lib/jdbc2_0-stdext.jar
|
||||
%%APP_NAME%%/lib/jmx.jar
|
||||
%%APP_NAME%%/lib/jndi.jar
|
||||
%%APP_NAME%%/lib/jsdk23.jar
|
||||
%%APP_NAME%%/lib/jta_101.jar
|
||||
%%APP_NAME%%/lib/resin.jar
|
||||
|
Loading…
Reference in New Issue
Block a user