- Update ndpi to 2.4 latest snapshot
- Update ntopng to 3.6 latest snapshot
This commit is contained in:
parent
b94037aeae
commit
cf9e8089f7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478442
@ -2,8 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ndpi
|
||||
PORTVERSION= 2.2.2.d20180406
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 2.4.d20180830
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
@ -27,18 +26,22 @@ INSTALL_TARGET= install-strip
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_PROJECT= nDPI
|
||||
GH_TAGNAME= 0e11abc
|
||||
GH_TAGNAME= 33c35f5
|
||||
|
||||
PLIST_SUB= MAJOR_VER=${PORTVERSION:R}
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} '/ndpi_config\.h/d' \
|
||||
${WRKSRC}/src/include/ndpi_main.h
|
||||
cd ${WRKSRC} && ${SH} autogen.sh
|
||||
(cd ${WRKSRC} && ${SH} autogen.sh)
|
||||
|
||||
post-configure:
|
||||
@${REINPLACE_CMD} -e 's/#define PACKAGE/#define NDPI_PACKAGE/g' \
|
||||
-e 's/#define VERSION/#define NDPI_VERSION/g' \
|
||||
${WRKSRC}/configure
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libndpi.so.${PORTVERSION:R}.0
|
||||
${RM} ${STAGEDIR}${PREFIX}/lib/libndpi.so
|
||||
${RLN} ${STAGEDIR}${PREFIX}/lib/libndpi.so.${PORTVERSION:R}.0 \
|
||||
${STAGEDIR}${PREFIX}/lib/libndpi.so
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1528128978
|
||||
SHA256 (ntop-nDPI-2.2.2.d20180406-0e11abc_GH0.tar.gz) = f59b8b4d960fb6fe3bbf8d67785c6798c34165e12c217105de3860d8fac5c372
|
||||
SIZE (ntop-nDPI-2.2.2.d20180406-0e11abc_GH0.tar.gz) = 20449092
|
||||
TIMESTAMP = 1535621920
|
||||
SHA256 (ntop-nDPI-2.4.d20180830-33c35f5_GH0.tar.gz) = 9481007a601cb5140d0269305b76abba79055a8d74363a7678d7a8db7c227781
|
||||
SIZE (ntop-nDPI-2.4.d20180830-33c35f5_GH0.tar.gz) = 19308026
|
||||
|
218
net/ndpi/files/patch-dynlibfix
Normal file
218
net/ndpi/files/patch-dynlibfix
Normal file
@ -0,0 +1,218 @@
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 17c67481..0642aec9 100644
|
||||
--- Makefile.am
|
||||
+++ Makefile.am
|
||||
@@ -1,8 +1,7 @@
|
||||
ACLOCAL_AMFLAGS = -I m4
|
||||
-
|
||||
SUBDIRS = src/lib example tests
|
||||
|
||||
pkgconfigdir = $(prefix)/libdata/pkgconfig
|
||||
pkgconfig_DATA = libndpi.pc
|
||||
|
||||
-EXTRA_DIST = libndpi.sym autogen.sh
|
||||
+EXTRA_DIST = autogen.sh
|
||||
diff --git a/autogen.sh b/autogen.sh
|
||||
index ea5ed669..20bf400a 100755
|
||||
--- configure.seed
|
||||
+++ configure.seed
|
||||
@@ -10,6 +10,7 @@ AC_PROG_CC
|
||||
AM_PROG_CC_C_O
|
||||
AX_PTHREAD
|
||||
|
||||
+NDPI_VERSION_SHORT="@NDPI_VERSION_SHORT@"
|
||||
NDPI_MAJOR="@NDPI_MAJOR@"
|
||||
NDPI_MINOR="@NDPI_MINOR@"
|
||||
NDPI_PATCH="@NDPI_PATCH@"
|
||||
@@ -127,12 +128,13 @@ AC_ARG_ENABLE([debug-messages],
|
||||
|
||||
AC_CHECK_LIB(pthread, pthread_setaffinity_np, AC_DEFINE_UNQUOTED(HAVE_PTHREAD_SETAFFINITY_NP, 1, [libc has pthread_setaffinity_np]))
|
||||
|
||||
-AC_CONFIG_FILES([Makefile example/Makefile tests/Makefile libndpi.pc src/include/ndpi_define.h])
|
||||
+AC_CONFIG_FILES([Makefile example/Makefile tests/Makefile libndpi.pc src/include/ndpi_define.h src/lib/Makefile])
|
||||
AC_CONFIG_HEADERS(src/include/ndpi_config.h)
|
||||
AC_SUBST(GIT_RELEASE)
|
||||
AC_SUBST(NDPI_MAJOR)
|
||||
AC_SUBST(NDPI_MINOR)
|
||||
AC_SUBST(NDPI_PATCH)
|
||||
+AC_SUBST(NDPI_VERSION_SHORT)
|
||||
AC_SUBST(SVN_DATE)
|
||||
AC_SUBST(JSON_C_LIB)
|
||||
AC_SUBST(PCAP_INC)
|
||||
diff --git a/libndpi.sym b/libndpi.sym
|
||||
deleted file mode 100644
|
||||
index 66cffbb1..00000000
|
||||
--- libndpi.sym
|
||||
+++ /dev/null
|
||||
@@ -1,75 +0,0 @@
|
||||
-ndpi_dump_protocols
|
||||
-ndpi_strnstr
|
||||
-ndpi_detection_giveup
|
||||
-ndpi_get_proto_name
|
||||
-ndpi_free
|
||||
-ndpi_flow_free
|
||||
-ndpi_guess_undetected_protocol
|
||||
-ndpi_tfind
|
||||
-ndpi_tsearch
|
||||
-ndpi_set_protocol_detection_bitmask2
|
||||
-ndpi_detection_get_sizeof_ndpi_id_struct
|
||||
-ndpi_detection_get_sizeof_ndpi_flow_struct
|
||||
-ndpi_load_protocols_file
|
||||
-ndpi_tdestroy
|
||||
-ndpi_exit_detection_module
|
||||
-ndpi_l4_detection_process_packet
|
||||
-ndpi_detection_process_packet
|
||||
-ndpi_process_extra_packet
|
||||
-ndpi_twalk
|
||||
-ndpi_tdelete
|
||||
-ndpi_revision
|
||||
-ndpi_init_detection_module
|
||||
-ndpi_get_num_supported_protocols
|
||||
-ndpi_set_proto_defaults
|
||||
-ndpi_get_protocol_id
|
||||
-ndpi_get_category_id
|
||||
-ndpi_find_port_based_protocol
|
||||
-ndpi_get_http_method
|
||||
-ndpi_get_http_url
|
||||
-ndpi_get_http_content_type
|
||||
-ndpi_free_flow
|
||||
-ndpi_get_proto_breed
|
||||
-ndpi_get_proto_breed_name
|
||||
-ndpi_get_proto_by_id
|
||||
-ndpi_get_proto_by_name
|
||||
-ndpi_get_protocol_id_master_proto
|
||||
-ndpi_guess_protocol_id
|
||||
-ndpi_protocol2name
|
||||
-ndpi_get_lower_proto
|
||||
-ndpi_is_proto
|
||||
-ndpi_malloc
|
||||
-ndpi_calloc
|
||||
-ndpi_set_detected_protocol
|
||||
-ndpi_match_string_subprotocol
|
||||
-ndpi_init_automa
|
||||
-ndpi_free_automa
|
||||
-ndpi_add_string_value_to_automa
|
||||
-ndpi_add_string_to_automa
|
||||
-ndpi_finalize_automa
|
||||
-ndpi_match_string
|
||||
-ndpi_match_string_id
|
||||
-set_ndpi_malloc
|
||||
-set_ndpi_flow_malloc
|
||||
-set_ndpi_free
|
||||
-set_ndpi_flow_free
|
||||
-set_ndpi_debug_function
|
||||
-ndpi_category_str
|
||||
-ndpi_get_proto_category
|
||||
-ndpi_netbios_name_interpret
|
||||
-ndpi_category_set_name
|
||||
-ndpi_category_get_name
|
||||
-ndpi_is_custom_category
|
||||
-ndpi_is_subprotocol_informative
|
||||
-ndpi_set_proto_category
|
||||
-ndpi_get_api_version
|
||||
-ndpi_network_ptree_match
|
||||
-ndpi_check_flow_func
|
||||
-ndpi_fill_protocol_category
|
||||
-ndpi_load_hostname_category
|
||||
-ndpi_enable_loaded_categories
|
||||
-ndpi_set_detection_preferences
|
||||
-ndpi_get_proto_defaults
|
||||
-ndpi_get_ndpi_num_supported_protocols
|
||||
-ndpi_get_ndpi_num_custom_protocols
|
||||
-ndpi_get_ndpi_detection_module_size
|
||||
diff --git a/src/lib/Makefile b/src/lib/Makefile
|
||||
deleted file mode 100644
|
||||
index 19c6f1cf..00000000
|
||||
--- src/lib/Makefile
|
||||
+++ /dev/null
|
||||
@@ -1,26 +0,0 @@
|
||||
-#
|
||||
-# Simple non-autotools dependent makefile
|
||||
-#
|
||||
-# ./autogen.sh
|
||||
-# cd src/lib
|
||||
-# make -f Makefile.simple
|
||||
-#
|
||||
-CFLAGS += -fPIC -DPIC -I../include -Ithird_party/include -DNDPI_LIB_COMPILATION -g
|
||||
-RANLIB = ranlib
|
||||
-
|
||||
-OBJECTS = $(patsubst protocols/%.c, protocols/%.o, $(wildcard protocols/*.c)) $(patsubst third_party/src/%.c, third_party/src/%.o, $(wildcard third_party/src/*.c)) ndpi_main.o
|
||||
-HEADERS = $(wildcard ../include/*.h)
|
||||
-
|
||||
-all: libndpi.a
|
||||
-
|
||||
-ndpi_main.c: ndpi_content_match.c.inc
|
||||
-
|
||||
-libndpi.a: $(OBJECTS)
|
||||
- ar rc $@ $(OBJECTS)
|
||||
- $(RANLIB) $@
|
||||
-
|
||||
-%.o: %.c $(HEADERS) Makefile
|
||||
- $(CC) $(CFLAGS) -c $< -o $@
|
||||
-
|
||||
-clean:
|
||||
- /bin/rm -f libndpi.a $(OBJECTS)
|
||||
diff --git a/src/lib/Makefile.in b/src/lib/Makefile.in
|
||||
new file mode 100644
|
||||
index 00000000..1bbc4095
|
||||
--- /dev/null
|
||||
+++ src/lib/Makefile.in
|
||||
@@ -0,0 +1,49 @@
|
||||
+#
|
||||
+# Simple non-autotools dependent makefile
|
||||
+#
|
||||
+# ./autogen.sh
|
||||
+# cd src/lib
|
||||
+# make Makefile
|
||||
+#
|
||||
+
|
||||
+#
|
||||
+# Installation directories
|
||||
+#
|
||||
+prefix = /usr/local
|
||||
+libdir = ${prefix}/lib
|
||||
+includedir = ${prefix}/include/ndpi
|
||||
+
|
||||
+CFLAGS += -fPIC -DPIC -I../include -Ithird_party/include -DNDPI_LIB_COMPILATION -g
|
||||
+RANLIB = ranlib
|
||||
+
|
||||
+OBJECTS != ls protocols/*.c | sed 's/\(.*\)\.c$$/\1.o/' && ls third_party/src/*.c | sed 's/\(.*\)\.c$$/\1.o/' && echo ndpi_main.o
|
||||
+HEADERS != ls ../include/*.h
|
||||
+NDPI_LIB_STATIC = libndpi.a
|
||||
+NDPI_LIB_SHARED_BASE = libndpi.so
|
||||
+NDPI_LIB_SHARED = $(NDPI_LIB_SHARED_BASE).@NDPI_VERSION_SHORT@
|
||||
+NDPI_LIBS = $(NDPI_LIB_STATIC) $(NDPI_LIB_SHARED)
|
||||
+
|
||||
+all: $(NDPI_LIBS)
|
||||
+
|
||||
+ndpi_main.c: ndpi_content_match.c.inc
|
||||
+
|
||||
+$(NDPI_LIB_STATIC): $(OBJECTS)
|
||||
+ ar rc $@ $(OBJECTS)
|
||||
+ $(RANLIB) $@
|
||||
+
|
||||
+$(NDPI_LIB_SHARED): $(OBJECTS)
|
||||
+ $(CC) -shared -fPIC -Wl,-soname,$(NDPI_LIB_SHARED) -o $@ $(OBJECTS)
|
||||
+ ln -Fs $(NDPI_LIB_SHARED) $(NDPI_LIB_SHARED_BASE)
|
||||
+
|
||||
+%.o: %.c $(HEADERS) Makefile
|
||||
+ $(CC) $(CFLAGS) -c $< -o $@
|
||||
+
|
||||
+clean:
|
||||
+ /bin/rm -f $(NDPI_LIB_STATIC) $(OBJECTS) *.o *.so *.lo
|
||||
+
|
||||
+install: $(NDPI_LIBS)
|
||||
+ mkdir -p $(DESTDIR)$(libdir)
|
||||
+ cp $(NDPI_LIBS) $(DESTDIR)$(libdir)/
|
||||
+ ln -Fs $(DESTDIR)$(libdir)/$(NDPI_LIB_SHARED) $(DESTDIR)$(libdir)/$(NDPI_LIB_SHARED_BASE)
|
||||
+ mkdir -p $(DESTDIR)$(includedir)
|
||||
+ cp ../include/*.h $(DESTDIR)$(includedir)
|
||||
diff --git a/tests/result/ssdp-m-search.pcap.out b/tests/result/ssdp-m-search.pcap.out
|
||||
new file mode 100644
|
||||
index 00000000..e975bfeb
|
||||
--- /dev/null
|
||||
+++ tests/result/ssdp-m-search.pcap.out
|
||||
@@ -0,0 +1,3 @@
|
||||
+SSDP 19 1197 1
|
||||
+
|
||||
+ 1 UDP 192.168.242.8:42253 -> 192.168.242.255:32412 [proto: 12/SSDP][cat: System/18][19 pkts/1197 bytes -> 0 pkts/0 bytes]
|
8
net/ndpi/files/patch-libndpi.pc.in
Normal file
8
net/ndpi/files/patch-libndpi.pc.in
Normal file
@ -0,0 +1,8 @@
|
||||
--- libndpi.pc.in.orig 2018-08-22 06:29:35 UTC
|
||||
+++ libndpi.pc.in
|
||||
@@ -7,4 +7,4 @@ Name: libndpi
|
||||
Description: deep packet inspection library
|
||||
Version: @VERSION@
|
||||
Libs: -L${libdir} -lndpi
|
||||
-Cflags: -I${includedir}/libndpi-@VERSION@
|
||||
+Cflags: -I${includedir}/ndpi
|
12
net/ndpi/files/patch-src_lib_ndpi__main.c
Normal file
12
net/ndpi/files/patch-src_lib_ndpi__main.c
Normal file
@ -0,0 +1,12 @@
|
||||
--- src/lib/ndpi_main.c.orig 2018-08-30 09:28:13 UTC
|
||||
+++ src/lib/ndpi_main.c
|
||||
@@ -43,9 +43,7 @@
|
||||
|
||||
#include "ndpi_content_match.c.inc"
|
||||
#include "third_party/include/ndpi_patricia.h"
|
||||
-#include "third_party/src/ndpi_patricia.c"
|
||||
#include "third_party/include/hash.h"
|
||||
-#include "third_party/src/hash.c"
|
||||
|
||||
#ifdef HAVE_HYPERSCAN
|
||||
#include <hs/hs.h>
|
@ -1,15 +1,15 @@
|
||||
bin/ndpiReader
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/libcache.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_api.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_config.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_define.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_includes.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_main.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocol_ids.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_protocols.h
|
||||
include/libndpi-%%MAJOR_VER%%/libndpi/ndpi_typedefs.h
|
||||
include/ndpi/ndpi_api.h
|
||||
include/ndpi/ndpi_config.h
|
||||
include/ndpi/ndpi_define.h
|
||||
include/ndpi/ndpi_includes.h
|
||||
include/ndpi/ndpi_main.h
|
||||
include/ndpi/ndpi_protocol_ids.h
|
||||
include/ndpi/ndpi_protocols.h
|
||||
include/ndpi/ndpi_typedefs.h
|
||||
include/ndpi/ndpi_unix.h
|
||||
include/ndpi/ndpi_win32.h
|
||||
lib/libndpi.a
|
||||
lib/libndpi.so
|
||||
lib/libndpi.so.1
|
||||
lib/libndpi.so.1.0.0
|
||||
lib/libndpi.so.%%MAJOR_VER%%.0
|
||||
libdata/pkgconfig/libndpi.pc
|
||||
|
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= ntopng
|
||||
PORTVERSION= 3.4.d20180604
|
||||
PORTVERSION= 3.6.d20180828
|
||||
PORTEPOCH= 1
|
||||
CATEGORIES= net
|
||||
|
||||
@ -17,21 +17,24 @@ LIB_DEPENDS= librrd.so:databases/rrdtool \
|
||||
libcurl.so:ftp/curl \
|
||||
libndpi.so:net/ndpi \
|
||||
libjson-c.so:devel/json-c \
|
||||
libsodium.so:security/libsodium
|
||||
libsodium.so:security/libsodium \
|
||||
libmaxminddb.so:net/libmaxminddb
|
||||
BUILD_DEPENDS= bash:shells/bash
|
||||
|
||||
USES= autoreconf cpe gmake libtool localbase mysql pathfix pkgconfig \
|
||||
shebangfix sqlite ssl
|
||||
SUB_FILES= ntopng-geoipupdate.sh pkg-deinstall
|
||||
SHEBANG_FILES= httpdocs/misc/ntopng-add-user.sh
|
||||
SHEBANG_FILES= httpdocs/misc/ntopng-add-user.sh \
|
||||
httpdocs/misc/ntopng-utils-manage-config.in
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --with-ndpi-includes=${LOCALBASE}/include/ndpi
|
||||
|
||||
USERS= ntopng
|
||||
GROUPS= ntopng
|
||||
|
||||
USE_GITHUB= yes
|
||||
GH_ACCOUNT= ntop
|
||||
GH_TAGNAME= 468d1eb
|
||||
GH_TAGNAME= 1358fdc
|
||||
|
||||
CPE_VENDOR= ntop
|
||||
|
||||
@ -50,7 +53,7 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
|
||||
${WRKSRC}/configure.seed
|
||||
@${REINPLACE_CMD} -e 's|^\(export PREFIX=\).*|\1 ${PREFIX}|' \
|
||||
${WRKSRC}/third-party/LuaJIT-2.1.0-beta3/Makefile
|
||||
${WRKSRC}/third-party/LuaJIT-2.1.0-git/Makefile
|
||||
cd ${WRKSRC} && ${SH} autogen.sh
|
||||
|
||||
post-install:
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1528128970
|
||||
SHA256 (ntop-ntopng-3.4.d20180604-468d1eb_GH0.tar.gz) = b021d7d97c2215997559bc164efca801ea889f00247ea3a16f3decf6bb2587d2
|
||||
SIZE (ntop-ntopng-3.4.d20180604-468d1eb_GH0.tar.gz) = 30715124
|
||||
TIMESTAMP = 1535622311
|
||||
SHA256 (ntop-ntopng-3.6.d20180828-1358fdc_GH0.tar.gz) = a665a82618e5d1baaa2c7815a8b356ddd5eccb69c707f463ce6e2b746dbad052
|
||||
SIZE (ntop-ntopng-3.6.d20180828-1358fdc_GH0.tar.gz) = 30351736
|
||||
|
@ -1,16 +1,6 @@
|
||||
--- Makefile.in.orig 2018-01-12 09:48:20 UTC
|
||||
--- Makefile.in.orig 2018-08-22 08:00:26 UTC
|
||||
+++ Makefile.in
|
||||
@@ -34,7 +34,8 @@ LIBPCAP=-lpcap
|
||||
MONGOOSE_HOME=${PWD}/third-party/mongoose
|
||||
MONGOOSE_INC=-I$(MONGOOSE_HOME)
|
||||
######
|
||||
-HAS_LUAJIT=$(shell pkg-config --atleast-version=2.1.0 luajit; echo $$?)
|
||||
+# Force using embedded luajit
|
||||
+HAS_LUAJIT=1
|
||||
ifeq ($(HAS_LUAJIT), 0)
|
||||
LUAJIT_INC = $(shell pkg-config --cflags luajit)
|
||||
LUAJIT_LIB = $(shell pkg-config --libs luajit)
|
||||
@@ -91,7 +92,7 @@ ifeq (@NEDGE@, 0)
|
||||
@@ -99,7 +99,7 @@ ifeq (@NEDGE@, 0)
|
||||
HAS_ZEROMQ=$(shell pkg-config --exists libzmq; echo $$?)
|
||||
ifeq ($(HAS_ZEROMQ), 0)
|
||||
ZEROMQ_INC = $(shell pkg-config --cflags libzmq)
|
||||
|
14
net/ntopng/files/patch-src_NetworkInterface.cpp
Normal file
14
net/ntopng/files/patch-src_NetworkInterface.cpp
Normal file
@ -0,0 +1,14 @@
|
||||
--- src/NetworkInterface.cpp.orig 2018-08-22 08:00:26 UTC
|
||||
+++ src/NetworkInterface.cpp
|
||||
@@ -6591,7 +6591,11 @@ bool NetworkInterface::matchLiveCapture(struct ntopngL
|
||||
|| (luactx->live_capture.matching_host == f->get_srv_host())) {
|
||||
if(luactx->live_capture.bpfFilterSet) {
|
||||
if(!bpf_filter(luactx->live_capture.fcode.bf_insns,
|
||||
+#if __FreeBSD_version >= 1100514
|
||||
(const u_char*)packet, h->caplen, h->caplen)) {
|
||||
+#else
|
||||
+ (u_char*)packet, h->caplen, h->caplen)) {
|
||||
+#endif
|
||||
return(false);
|
||||
}
|
||||
}
|
@ -1,5 +1,5 @@
|
||||
--- third-party/LuaJIT-2.1.0-beta3/src/Makefile.orig 2017-12-04 09:31:02 UTC
|
||||
+++ third-party/LuaJIT-2.1.0-beta3/src/Makefile
|
||||
--- third-party/LuaJIT-2.1.0-git/src/Makefile.orig 2018-08-22 08:00:26 UTC
|
||||
+++ third-party/LuaJIT-2.1.0-git/src/Makefile
|
||||
@@ -24,7 +24,7 @@ NODOTABIVER= 51
|
||||
# removing the '#' in front of them. Make sure you force a full recompile
|
||||
# with "make clean", followed by "make" if you change any options.
|
||||
@ -9,7 +9,7 @@
|
||||
#
|
||||
# LuaJIT builds as a native 32 or 64 bit binary by default.
|
||||
CC= $(DEFAULT_CC)
|
||||
@@ -585,9 +585,9 @@ endif
|
||||
@@ -590,9 +590,9 @@ endif
|
||||
endif
|
||||
endif
|
||||
|
@ -152,6 +152,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/inc/sprobe_process.inc
|
||||
%%DATADIR%%/httpdocs/inc/sprobe_process_header.inc
|
||||
%%DATADIR%%/httpdocs/inc/vlan_stats_id.inc
|
||||
%%DATADIR%%/httpdocs/js/ASAP.js
|
||||
%%DATADIR%%/httpdocs/js/Makefile
|
||||
%%DATADIR%%/httpdocs/js/README.gauge
|
||||
%%DATADIR%%/httpdocs/js/ays_utils.js
|
||||
@ -172,7 +173,9 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/js/deps.min.js.map
|
||||
%%DATADIR%%/httpdocs/js/gauge.js
|
||||
%%DATADIR%%/httpdocs/js/googleMapJson.js
|
||||
%%DATADIR%%/httpdocs/js/graph_utils.js
|
||||
%%DATADIR%%/httpdocs/js/html5shiv.js
|
||||
%%DATADIR%%/httpdocs/js/ie_fix.js
|
||||
%%DATADIR%%/httpdocs/js/jquery-ui.js
|
||||
%%DATADIR%%/httpdocs/js/jquery.are-you-sure.js
|
||||
%%DATADIR%%/httpdocs/js/jquery.bootstrap-duallistbox.js
|
||||
@ -201,9 +204,14 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/httpdocs/js/validator.js
|
||||
%%DATADIR%%/httpdocs/js/vfs_fonts.js
|
||||
%%DATADIR%%/httpdocs/misc/ntopng-add-user.sh
|
||||
%%DATADIR%%/httpdocs/misc/ntopng-utils-manage-config
|
||||
%%DATADIR%%/httpdocs/misc/ntopng-utils-manage-config.in
|
||||
%%DATADIR%%/httpdocs/misc/ntopng_template_elk.json
|
||||
%%DATADIR%%/httpdocs/misc/ntopng_template_elk6.json
|
||||
%%DATADIR%%/httpdocs/other/EtherOUI.txt
|
||||
%%DATADIR%%/httpdocs/other/TimeZones.txt
|
||||
%%DATADIR%%/httpdocs/other/lists/malware.txt
|
||||
%%DATADIR%%/httpdocs/other/lists/web_mining.txt
|
||||
%%DATADIR%%/httpdocs/other/trackers.txt
|
||||
%%DATADIR%%/httpdocs/ssl/README
|
||||
%%DATADIR%%/httpdocs/ssl/ntopng-cert.pem.dummy
|
||||
@ -223,6 +231,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/callbacks/system/housekeeping.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/minute.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/pinger.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/recovery.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/second.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/shutdown.lua
|
||||
%%DATADIR%%/scripts/callbacks/system/startup.lua
|
||||
@ -273,16 +282,19 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/get_arp_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_as_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_ases_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_config.lua
|
||||
%%DATADIR%%/scripts/lua/get_db_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_db_flows.lua
|
||||
%%DATADIR%%/scripts/lua/get_discover_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_discover_progress.lua
|
||||
%%DATADIR%%/scripts/lua/get_flow_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_flow_db_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_flows_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_geo_hosts.lua
|
||||
%%DATADIR%%/scripts/lua/get_grouped_hosts_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_historical_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_historical_favourites.lua
|
||||
%%DATADIR%%/scripts/lua/get_host_contacts.lua
|
||||
%%DATADIR%%/scripts/lua/get_host_daily_activity.lua
|
||||
%%DATADIR%%/scripts/lua/get_host_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_host_pools.lua
|
||||
%%DATADIR%%/scripts/lua/get_host_traffic.lua
|
||||
@ -300,6 +312,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/get_top_realtime.lua
|
||||
%%DATADIR%%/scripts/lua/get_top_talkers.lua
|
||||
%%DATADIR%%/scripts/lua/get_treemap.lua
|
||||
%%DATADIR%%/scripts/lua/get_ts.lua
|
||||
%%DATADIR%%/scripts/lua/get_unknown_devices_data.lua
|
||||
%%DATADIR%%/scripts/lua/get_user_info.lua
|
||||
%%DATADIR%%/scripts/lua/get_vlan_data.lua
|
||||
@ -346,6 +359,11 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/inc/sprobe.lua
|
||||
%%DATADIR%%/scripts/lua/inc/users.lua
|
||||
%%DATADIR%%/scripts/lua/index.lua
|
||||
%%DATADIR%%/scripts/lua/info_portal.lua
|
||||
%%DATADIR%%/scripts/lua/jsontest.lua
|
||||
%%DATADIR%%/scripts/lua/live_capture_data.lua
|
||||
%%DATADIR%%/scripts/lua/live_capture_stats.lua
|
||||
%%DATADIR%%/scripts/lua/live_traffic.lua
|
||||
%%DATADIR%%/scripts/lua/local_hosts_stats.lua
|
||||
%%DATADIR%%/scripts/lua/login.lua
|
||||
%%DATADIR%%/scripts/lua/logout.lua
|
||||
@ -353,10 +371,12 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/mac_pkt_distro.lua
|
||||
%%DATADIR%%/scripts/lua/mac_stats.lua
|
||||
%%DATADIR%%/scripts/lua/macs_stats.lua
|
||||
%%DATADIR%%/scripts/lua/manage_data.lua
|
||||
%%DATADIR%%/scripts/lua/metrics.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_consts.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/email.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/nagios.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/sample.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_endpoints/slack.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_state_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/alert_utils.lua
|
||||
@ -365,10 +385,14 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/modules/blacklist_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/callback_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/db_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/delete_data_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/discover_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/dkjson.lua
|
||||
%%DATADIR%%/scripts/lua/modules/doa_ox.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_aggregation_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_dbms/drivers/mysql.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_dbms/drivers/nindex.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_dbms/flow_dbms.lua
|
||||
%%DATADIR%%/scripts/lua/modules/flow_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/format_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/grafana/index.lua
|
||||
@ -387,24 +411,43 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/modules/i18n/variants.lua
|
||||
%%DATADIR%%/scripts/lua/modules/i18n/version.lua
|
||||
%%DATADIR%%/scripts/lua/modules/json.lua
|
||||
%%DATADIR%%/scripts/lua/modules/lists_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/live_traffic_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/locales_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/lua_trace.lua
|
||||
%%DATADIR%%/scripts/lua/modules/lua_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/mac_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/ntop_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/os_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/persistence.lua
|
||||
%%DATADIR%%/scripts/lua/modules/prefs_dump_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/prefs_menu.lua
|
||||
%%DATADIR%%/scripts/lua/modules/prefs_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/recovery_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/resty/template.lua
|
||||
%%DATADIR%%/scripts/lua/modules/resty/template/html.lua
|
||||
%%DATADIR%%/scripts/lua/modules/resty/template/microbenchmark.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_5min_dump_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_min_dump_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_paths.lua
|
||||
%%DATADIR%%/scripts/lua/modules/rrd_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/sqlite_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/telegram.lua
|
||||
%%DATADIR%%/scripts/lua/modules/template.lua
|
||||
%%DATADIR%%/scripts/lua/modules/template_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/drivers/influxdb.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/drivers/rrd.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/drivers/sample.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/schemas/ts_5min.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/schemas/ts_minute.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/schemas/ts_second.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/tests/influxdb_test.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/tests/run.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/tests/utils_test.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/ts_common.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/ts_schema.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/ts_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/timeseries/ts_utils_core.lua
|
||||
%%DATADIR%%/scripts/lua/modules/top_talkers_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/tz_utils.lua
|
||||
%%DATADIR%%/scripts/lua/modules/vlan_utils.lua
|
||||
@ -414,13 +457,13 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/network_load.lua
|
||||
%%DATADIR%%/scripts/lua/network_stats.lua
|
||||
%%DATADIR%%/scripts/lua/nindex.lua
|
||||
%%DATADIR%%/scripts/lua/nindex_topk.lua
|
||||
%%DATADIR%%/scripts/lua/os_stats.lua
|
||||
%%DATADIR%%/scripts/lua/page_not_found.lua
|
||||
%%DATADIR%%/scripts/lua/pid_stats.lua
|
||||
%%DATADIR%%/scripts/lua/please_wait.lua
|
||||
%%DATADIR%%/scripts/lua/pool_details.lua
|
||||
%%DATADIR%%/scripts/lua/pool_stats.lua
|
||||
%%DATADIR%%/scripts/lua/popKeys.lua
|
||||
%%DATADIR%%/scripts/lua/port_details.lua
|
||||
%%DATADIR%%/scripts/lua/processes_stats.lua
|
||||
%%DATADIR%%/scripts/lua/reset_stats.lua
|
||||
@ -439,6 +482,7 @@ man/man8/ntopng.8.gz
|
||||
%%DATADIR%%/scripts/lua/sprobe_hosts_data.lua
|
||||
%%DATADIR%%/scripts/lua/sprobe_hosts_interactions.lua
|
||||
%%DATADIR%%/scripts/lua/sprobe_hosts_interactions_data.lua
|
||||
%%DATADIR%%/scripts/lua/stop_live_capture.lua
|
||||
%%DATADIR%%/scripts/lua/test_locales.lua
|
||||
%%DATADIR%%/scripts/lua/test_snmp.lua
|
||||
%%DATADIR%%/scripts/lua/top_hosts.lua
|
||||
|
Loading…
Reference in New Issue
Block a user