make sure to set mode for created directory.

Reported by:	"Pascal HOARAU" <pascal@hh.nl>
This commit is contained in:
Hajimu UMEMOTO 2004-03-10 16:55:40 +00:00
parent cbe7660ce9
commit cf8c5ef050
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=103553
15 changed files with 162 additions and 30 deletions

View File

@ -0,0 +1,25 @@
Index: Makefile.in
diff -u Makefile.in.orig Makefile.in
--- Makefile.in.orig Tue Jan 13 06:02:09 2004
+++ Makefile.in Thu Mar 11 01:34:50 2004
@@ -90,13 +90,13 @@
touch distcvs
install::
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/bin
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/lib
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/include/cyrus
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man1
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man3
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man5
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man8
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/bin
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/lib
+ $(INSTALL) -d ${DESTDIR}$(prefix)/include/cyrus
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man1
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man3
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man5
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man8
@for d in $(SUBDIRS); \
do \
(cd $$d; echo "### Making" install "in" `pwd`; \

View File

@ -1,9 +1,13 @@
Index: imap/Makefile.in
diff -u imap/Makefile.in.orig imap/Makefile.in
--- imap/Makefile.in.orig Wed Nov 12 13:02:01 2003
+++ imap/Makefile.in Fri Feb 13 18:36:00 2004
@@ -135,7 +135,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ imap/Makefile.in Thu Mar 11 01:16:00 2004
@@ -132,10 +132,10 @@
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: lib/Makefile.in
diff -u lib/Makefile.in.orig lib/Makefile.in
--- lib/Makefile.in.orig Sun Jan 4 00:16:44 2004
+++ lib/Makefile.in Sun Mar 7 23:44:51 2004
+++ lib/Makefile.in Thu Mar 11 01:35:47 2004
@@ -60,7 +60,7 @@
CPPFLAGS = -I.. @CPPFLAGS@ @COM_ERR_CPPFLAGS@ @SASLFLAGS@
LIBS = @LIBS@
@ -11,3 +11,12 @@ diff -u lib/Makefile.in.orig lib/Makefile.in
LDFLAGS = @LDFLAGS@
SHELL = /bin/sh
@@ -100,7 +100,7 @@
all: $(BUILTSOURCES) libcyrus_min.a libcyrus.a
install:
- $(srcdir)/../install-sh -d $(DESTDIR)$(exec_prefix)/lib
+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus.a $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus_min.a $(DESTDIR)$(exec_prefix)/lib
$(RANLIB) $(DESTDIR)$(exec_prefix)/lib/libcyrus.a

View File

@ -1,9 +1,13 @@
Index: master/Makefile.in
diff -u master/Makefile.in.orig master/Makefile.in
--- master/Makefile.in.orig Wed Nov 12 13:02:03 2003
+++ master/Makefile.in Fri Feb 13 18:33:15 2004
@@ -78,7 +78,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ master/Makefile.in Thu Mar 11 01:18:52 2004
@@ -75,10 +75,10 @@
all: $(PROGS) $(LOBJS)
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: sieve/Makefile.in
diff -u sieve/Makefile.in.orig sieve/Makefile.in
--- sieve/Makefile.in.orig Wed Nov 12 13:02:12 2003
+++ sieve/Makefile.in Sun Mar 7 23:40:33 2004
+++ sieve/Makefile.in Thu Mar 11 01:22:05 2004
@@ -33,12 +33,13 @@
YACC = @YACC@
YFLAGS = -d
@ -17,11 +17,13 @@ diff -u sieve/Makefile.in.orig sieve/Makefile.in
LDFLAGS = @LDFLAGS@
MAKEDEPEND = @MAKEDEPEND@
@@ -59,7 +60,7 @@
@@ -58,8 +59,8 @@
dist: $(BUILT_SOURCES)
install: sievec
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -m 755 sievec $(DESTDIR)$(service_path) || exit
+ $(INSTALL) -d ${DESTDIR}$(service_path)
+ $(INSTALL) -s -m 755 sievec $(DESTDIR)$(service_path) || exit
test: $(DEPLIBS) libsieve.a test.o

View File

@ -0,0 +1,25 @@
Index: Makefile.in
diff -u Makefile.in.orig Makefile.in
--- Makefile.in.orig Tue Jan 13 06:02:09 2004
+++ Makefile.in Thu Mar 11 01:34:50 2004
@@ -90,13 +90,13 @@
touch distcvs
install::
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/bin
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/lib
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/include/cyrus
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man1
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man3
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man5
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man8
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/bin
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/lib
+ $(INSTALL) -d ${DESTDIR}$(prefix)/include/cyrus
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man1
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man3
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man5
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man8
@for d in $(SUBDIRS); \
do \
(cd $$d; echo "### Making" install "in" `pwd`; \

View File

@ -1,9 +1,13 @@
Index: imap/Makefile.in
diff -u imap/Makefile.in.orig imap/Makefile.in
--- imap/Makefile.in.orig Wed Nov 12 13:02:01 2003
+++ imap/Makefile.in Fri Feb 13 18:36:00 2004
@@ -135,7 +135,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ imap/Makefile.in Thu Mar 11 01:16:00 2004
@@ -132,10 +132,10 @@
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: lib/Makefile.in
diff -u lib/Makefile.in.orig lib/Makefile.in
--- lib/Makefile.in.orig Sun Jan 4 00:16:44 2004
+++ lib/Makefile.in Sun Mar 7 23:44:51 2004
+++ lib/Makefile.in Thu Mar 11 01:35:47 2004
@@ -60,7 +60,7 @@
CPPFLAGS = -I.. @CPPFLAGS@ @COM_ERR_CPPFLAGS@ @SASLFLAGS@
LIBS = @LIBS@
@ -11,3 +11,12 @@ diff -u lib/Makefile.in.orig lib/Makefile.in
LDFLAGS = @LDFLAGS@
SHELL = /bin/sh
@@ -100,7 +100,7 @@
all: $(BUILTSOURCES) libcyrus_min.a libcyrus.a
install:
- $(srcdir)/../install-sh -d $(DESTDIR)$(exec_prefix)/lib
+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus.a $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus_min.a $(DESTDIR)$(exec_prefix)/lib
$(RANLIB) $(DESTDIR)$(exec_prefix)/lib/libcyrus.a

View File

@ -1,9 +1,13 @@
Index: master/Makefile.in
diff -u master/Makefile.in.orig master/Makefile.in
--- master/Makefile.in.orig Wed Nov 12 13:02:03 2003
+++ master/Makefile.in Fri Feb 13 18:33:15 2004
@@ -78,7 +78,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ master/Makefile.in Thu Mar 11 01:18:52 2004
@@ -75,10 +75,10 @@
all: $(PROGS) $(LOBJS)
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: sieve/Makefile.in
diff -u sieve/Makefile.in.orig sieve/Makefile.in
--- sieve/Makefile.in.orig Wed Nov 12 13:02:12 2003
+++ sieve/Makefile.in Sun Mar 7 23:40:33 2004
+++ sieve/Makefile.in Thu Mar 11 01:22:05 2004
@@ -33,12 +33,13 @@
YACC = @YACC@
YFLAGS = -d
@ -17,11 +17,13 @@ diff -u sieve/Makefile.in.orig sieve/Makefile.in
LDFLAGS = @LDFLAGS@
MAKEDEPEND = @MAKEDEPEND@
@@ -59,7 +60,7 @@
@@ -58,8 +59,8 @@
dist: $(BUILT_SOURCES)
install: sievec
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -m 755 sievec $(DESTDIR)$(service_path) || exit
+ $(INSTALL) -d ${DESTDIR}$(service_path)
+ $(INSTALL) -s -m 755 sievec $(DESTDIR)$(service_path) || exit
test: $(DEPLIBS) libsieve.a test.o

View File

@ -0,0 +1,25 @@
Index: Makefile.in
diff -u Makefile.in.orig Makefile.in
--- Makefile.in.orig Tue Jan 13 06:02:09 2004
+++ Makefile.in Thu Mar 11 01:34:50 2004
@@ -90,13 +90,13 @@
touch distcvs
install::
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/bin
- $(srcdir)/install-sh -d ${DESTDIR}$(exec_prefix)/lib
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/include/cyrus
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man1
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man3
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man5
- $(srcdir)/install-sh -d ${DESTDIR}$(prefix)/man/man8
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/bin
+ $(INSTALL) -d ${DESTDIR}$(exec_prefix)/lib
+ $(INSTALL) -d ${DESTDIR}$(prefix)/include/cyrus
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man1
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man3
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man5
+ $(INSTALL) -d ${DESTDIR}$(prefix)/man/man8
@for d in $(SUBDIRS); \
do \
(cd $$d; echo "### Making" install "in" `pwd`; \

View File

@ -1,9 +1,13 @@
Index: imap/Makefile.in
diff -u imap/Makefile.in.orig imap/Makefile.in
--- imap/Makefile.in.orig Wed Nov 12 13:02:01 2003
+++ imap/Makefile.in Fri Feb 13 18:36:00 2004
@@ -135,7 +135,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ imap/Makefile.in Thu Mar 11 01:16:00 2004
@@ -132,10 +132,10 @@
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: lib/Makefile.in
diff -u lib/Makefile.in.orig lib/Makefile.in
--- lib/Makefile.in.orig Sun Jan 4 00:16:44 2004
+++ lib/Makefile.in Sun Mar 7 23:44:51 2004
+++ lib/Makefile.in Thu Mar 11 01:35:47 2004
@@ -60,7 +60,7 @@
CPPFLAGS = -I.. @CPPFLAGS@ @COM_ERR_CPPFLAGS@ @SASLFLAGS@
LIBS = @LIBS@
@ -11,3 +11,12 @@ diff -u lib/Makefile.in.orig lib/Makefile.in
LDFLAGS = @LDFLAGS@
SHELL = /bin/sh
@@ -100,7 +100,7 @@
all: $(BUILTSOURCES) libcyrus_min.a libcyrus.a
install:
- $(srcdir)/../install-sh -d $(DESTDIR)$(exec_prefix)/lib
+ $(INSTALL) -d $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus.a $(DESTDIR)$(exec_prefix)/lib
$(INSTALL) -m 644 libcyrus_min.a $(DESTDIR)$(exec_prefix)/lib
$(RANLIB) $(DESTDIR)$(exec_prefix)/lib/libcyrus.a

View File

@ -1,9 +1,13 @@
Index: master/Makefile.in
diff -u master/Makefile.in.orig master/Makefile.in
--- master/Makefile.in.orig Wed Nov 12 13:02:03 2003
+++ master/Makefile.in Fri Feb 13 18:33:15 2004
@@ -78,7 +78,7 @@
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+++ master/Makefile.in Thu Mar 11 01:18:52 2004
@@ -75,10 +75,10 @@
all: $(PROGS) $(LOBJS)
install:
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
+ $(INSTALL) -d ${DESTDIR}$(service_path)
for file in $(PROGS); \
do \
- $(INSTALL) -m 755 $$file $(DESTDIR)$(service_path) || exit 1; \

View File

@ -1,7 +1,7 @@
Index: sieve/Makefile.in
diff -u sieve/Makefile.in.orig sieve/Makefile.in
--- sieve/Makefile.in.orig Wed Nov 12 13:02:12 2003
+++ sieve/Makefile.in Sun Mar 7 23:40:33 2004
+++ sieve/Makefile.in Thu Mar 11 01:22:05 2004
@@ -33,12 +33,13 @@
YACC = @YACC@
YFLAGS = -d
@ -17,11 +17,13 @@ diff -u sieve/Makefile.in.orig sieve/Makefile.in
LDFLAGS = @LDFLAGS@
MAKEDEPEND = @MAKEDEPEND@
@@ -59,7 +60,7 @@
@@ -58,8 +59,8 @@
dist: $(BUILT_SOURCES)
install: sievec
$(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -d ${DESTDIR}$(service_path)
- $(srcdir)/../install-sh -m 755 sievec $(DESTDIR)$(service_path) || exit
+ $(INSTALL) -d ${DESTDIR}$(service_path)
+ $(INSTALL) -s -m 755 sievec $(DESTDIR)$(service_path) || exit
test: $(DEPLIBS) libsieve.a test.o