Add mmucl 1.4.0, a powerful MUD client written in Tcl with a GUI interface.

PR:		20238
Submitted by:	Matt Heckaman <matt@LUCIDA.QC.CA>
This commit is contained in:
Will Andrews 2000-09-16 04:21:21 +00:00
parent 0ad5fff675
commit cf622010cb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32668
7 changed files with 130 additions and 0 deletions

View File

@ -131,6 +131,7 @@
SUBDIR += mars_nwe
SUBDIR += merlinmon
SUBDIR += micq
SUBDIR += mmucl
SUBDIR += mopd
SUBDIR += mpd
SUBDIR += mpd-netgraph

28
net/mmucl/Makefile Normal file
View File

@ -0,0 +1,28 @@
# New ports collection Makefile for: mmucl
# Date created: 28 July 2000
# Whom: Matt Heckaman <matt@LUCIDA.QC.CA>
#
# $FreeBSD$
#
PORTNAME= mmucl
PORTVERSION= 1.4.0
CATEGORIES= net
MASTER_SITES= http://download.sourceforge.net/mmucl/
MAINTAINER= matt@LUCIDA.QC.CA
LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
USE_GMAKE= YES
post-install:
${MKDIR} ${PREFIX}/share/doc/${DISTNAME}
${MKDIR} ${PREFIX}/share/doc/${DISTNAME}/examples
${INSTALL_DATA} ${WRKSRC}/FAQ ${PREFIX}/share/doc/${DISTNAME}
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/${DISTNAME}
${INSTALL_DATA} ${WRKSRC}/CHANGES ${PREFIX}/share/doc/${DISTNAME}
${INSTALL_DATA} ${WRKSRC}/examples/* ${PREFIX}/share/doc/${DISTNAME}/examples
.include <bsd.port.mk>

1
net/mmucl/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (mmucl-1.4.0.tar.gz) = 72c777348a1f48353786e10dc5ee5fef

47
net/mmucl/files/patch-aa Normal file
View File

@ -0,0 +1,47 @@
--- Makefile.orig Fri Jul 28 04:29:06 2000
+++ Makefile Fri Jul 28 04:31:02 2000
@@ -3,7 +3,7 @@
# Mmucl installs itself under BASE_DIR
-BASE_DIR = /usr/local
+BASE_DIR = ${PREFIX}
# The startup script, mmucl, is put in BIN_DIR
# Everything else is put in LIB_DIR
@@ -21,7 +21,7 @@
# Location of install-info
-INSTALL_INFO = /sbin/install-info
+INSTALL_INFO = /usr/bin/install-info
# Location of install
@@ -34,17 +34,19 @@
.PHONY: install clean gzip zip dist rpm test
+all: mmucl
+
install: mmucl
$(INSTALL) -d $(LIB_DIR)/lib $(LIB_DIR)/interface $(LIB_DIR)/images
$(INSTALL) -d $(BIN_DIR) $(INFO_DIR)
- $(INSTALL) -m 0664 lib/*.tcl $(LIB_DIR)/lib
- $(INSTALL) -m 0664 images/*.gif $(LIB_DIR)/images
- $(INSTALL) -m 0664 interface/*.tcl $(LIB_DIR)/interface
- $(INSTALL) -m 0664 .tkconf $(LIB_DIR)
- $(INSTALL) -m 0775 mmucl $(BIN_DIR)
- $(INSTALL) -m 0664 mmucl.info $(INFO_DIR)
- $(INSTALL_INFO) mmucl.info --info-dir=$(INFO_DIR)
+ $(INSTALL) -cm 0644 lib/*.tcl $(LIB_DIR)/lib
+ $(INSTALL) -cm 0644 images/*.gif $(LIB_DIR)/images
+ $(INSTALL) -cm 0644 interface/*.tcl $(LIB_DIR)/interface
+ $(INSTALL) -cm 0644 .tkconf $(LIB_DIR)
+ $(INSTALL) -cm 0755 mmucl $(BIN_DIR)
+ $(INSTALL) -cm 0644 mmucl.info $(INFO_DIR)
+ $(INSTALL_INFO) $(INFO_DIR)/mmucl.info --info-dir=$(INFO_DIR)
mmucl: Makefile init
echo "#! /bin/sh" > mmucl

1
net/mmucl/pkg-comment Normal file
View File

@ -0,0 +1 @@
Powerful GUI MUD client written in TCL

10
net/mmucl/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
Mmucl - Mark's MUd CLient (pronounced muckle) is a MUD client written in TCL
and distributed under the GNU GPL. This client supports a powerful aliasing
system using TCL as well as three different interfaces that can be used.
This client also has the advantage of being able to run on any platform that
supports TCL/TK.
WWW: http://mmucl.sourceforge.net
Matt Heckaman
matt@LUCIDA.QC.CA

42
net/mmucl/pkg-plist Normal file
View File

@ -0,0 +1,42 @@
bin/mmucl
@unexec install-info --delete %D/info/mmucl.info %D/info/dir
info/mmucl.info
@exec install-info %D/info/mmucl.info %D/info/dir
lib/mmucl/images/action.gif
lib/mmucl/images/alias.gif
lib/mmucl/images/bind.gif
lib/mmucl/images/char.gif
lib/mmucl/images/connect.gif
lib/mmucl/images/help.gif
lib/mmucl/images/load.gif
lib/mmucl/images/mmucl.gif
lib/mmucl/images/quit.gif
lib/mmucl/images/save.gif
lib/mmucl/images/send.gif
lib/mmucl/images/sub.gif
@dirrm lib/mmucl/images
lib/mmucl/interface/console.tcl
lib/mmucl/interface/gtk.tcl
lib/mmucl/interface/text.tcl
lib/mmucl/interface/tk.tcl
lib/mmucl/interface/xterm.tcl
@dirrm lib/mmucl/interface
lib/mmucl/lib/balloon.tcl
lib/mmucl/lib/misc.tcl
lib/mmucl/lib/mmucl.tcl
lib/mmucl/lib/mmucl_tk.tcl
lib/mmucl/lib/ntkinfo.tcl
lib/mmucl/lib/term.tcl
lib/mmucl/lib/tkconf.tcl
@dirrm lib/mmucl/lib
lib/mmucl/.tkconf
@dirrm lib/mmucl
share/doc/mmucl-1.4.0/examples/Arithon
share/doc/mmucl-1.4.0/examples/edit.tcl
share/doc/mmucl-1.4.0/examples/map.tcl
share/doc/mmucl-1.4.0/examples/mmucl.rc
@dirrm share/doc/mmucl-1.4.0/examples
share/doc/mmucl-1.4.0/CHANGES
share/doc/mmucl-1.4.0/FAQ
share/doc/mmucl-1.4.0/README
@dirrm share/doc/mmucl-1.4.0