- Update Ruby 2.1 to 2.1.1

This commit is contained in:
Steve Wills 2014-02-25 04:23:14 +00:00
parent 4d921409e2
commit cf48be67f0
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=345918
5 changed files with 12 additions and 42 deletions

View File

@ -208,7 +208,7 @@ RUBY21= "@comment "
#
# Ruby 2.1
#
RUBY_RELVERSION= 2.1.0
RUBY_RELVERSION= 2.1.1
RUBY_PORTREVISION= 0
RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0

View File

@ -1,2 +1,2 @@
SHA256 (ruby/ruby-2.1.0.tar.bz2) = 1d3f4ad5f619ec15229206b6667586dcec7cc986672c8fbb8558161ecf07e277
SIZE (ruby/ruby-2.1.0.tar.bz2) = 12007442
SHA256 (ruby/ruby-2.1.1.tar.bz2) = 96aabab4dd4a2e57dd0d28052650e6fcdc8f133fa8980d9b936814b1e93f6cfc
SIZE (ruby/ruby-2.1.1.tar.bz2) = 11990697

View File

@ -1,6 +1,6 @@
--- configure.in.orig 2014-02-17 23:26:58.602684892 +0000
+++ configure.in 2014-02-17 23:30:59.146669242 +0000
@@ -1072,10 +1072,10 @@
--- configure.in.orig 2014-02-21 23:32:34.000000000 +0000
+++ configure.in 2014-02-24 14:54:59.432610152 +0000
@@ -1084,10 +1084,10 @@
],
[ LIBS="-lm $LIBS"])
@ -15,7 +15,7 @@
dnl Checks for header files.
AC_HEADER_DIRENT
@@ -1970,7 +1970,7 @@
@@ -1982,7 +1982,7 @@
if test x"$ac_cv_func_clock_gettime" != xyes; then
# glibc 2.17 moves clock_* functions from librt to the main C library.
# http://sourceware.org/ml/libc-announce/2012/msg00001.html
@ -24,7 +24,7 @@
if test x"$ac_cv_lib_rt_clock_gettime" = xyes; then
AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
fi
@@ -2411,7 +2411,7 @@
@@ -2423,7 +2423,7 @@
fi
if test x"$enable_pthread" = xyes; then
@ -33,7 +33,7 @@
AC_CHECK_LIB($pthread_lib, pthread_kill,
rb_with_pthread=yes, rb_with_pthread=no)
if test "$rb_with_pthread" = "yes"; then break; fi
@@ -2419,6 +2419,7 @@
@@ -2431,6 +2431,7 @@
if test x"$rb_with_pthread" = xyes; then
AC_DEFINE(_REENTRANT)
AC_DEFINE(_THREAD_SAFE)
@ -41,15 +41,15 @@
AC_DEFINE(HAVE_LIBPTHREAD)
AC_CHECK_HEADERS(pthread_np.h, [], [], [@%:@include <pthread.h>])
AS_CASE([$pthread_lib],
@@ -2656,7 +2657,6 @@
@@ -2668,7 +2669,6 @@
: ${LDSHARED='$(CC) -shared'}
if test "$rb_cv_binary_elf" = yes; then
LDFLAGS="$LDFLAGS -rdynamic"
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
- DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$@'
else
test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED='$(LD) -Bshareable'
fi
@@ -3109,6 +3109,7 @@
@@ -3136,6 +3136,7 @@
[freebsd*|dragonfly*], [
SOLIBS='$(LIBS)'
LIBRUBY_SO='lib$(RUBY_SO_NAME).so.$(MAJOR)$(MINOR)'

View File

@ -1,11 +0,0 @@
--- cont.c.orig 2013-10-09 15:37:54.000000000 +0000
+++ cont.c 2013-11-22 15:05:19.138396780 +0000
@@ -44,6 +44,8 @@
/* At least, Linux/ia64's getcontext(3) doesn't save register window.
*/
# define FIBER_USE_NATIVE 0
+# elif defined(__FreeBSD__)
+# define FIBER_USE_NATIVE 0
# elif defined(__GNU__)
/* GNU/Hurd doesn't fully support getcontext, setcontext, makecontext
* and swapcontext functions. Disabling their usage till support is

View File

@ -1,19 +0,0 @@
--- thread_pthread.c.orig 2013-05-01 15:40:57.000000000 +0000
+++ thread_pthread.c 2014-01-25 03:00:55.044466722 +0000
@@ -1420,13 +1420,13 @@
exit(EXIT_FAILURE);
}
# ifdef PTHREAD_STACK_MIN
- if (PTHREAD_STACK_MIN < 4096 * 3) {
+ if (PTHREAD_STACK_MIN < 4096 * 4) {
/* Allocate the machine stack for the timer thread
- * at least 12KB (3 pages). FreeBSD 8.2 AMD64 causes
+ * at least 16KB (4 pages). FreeBSD 8.2 AMD64 causes
* machine stack overflow only with PTHREAD_STACK_MIN.
*/
pthread_attr_setstacksize(&attr,
- 4096 * 3 + (THREAD_DEBUG ? BUFSIZ : 0));
+ 4096 * 4 + (THREAD_DEBUG ? BUFSIZ : 0));
}
else {
pthread_attr_setstacksize(&attr,