graphics/pixie: Fix build on F9

PR:		194167
Submitted by:	Ports Fury
This commit is contained in:
John Marino 2015-02-06 19:48:07 +00:00
parent f74e64dfe6
commit cf43409cc4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=378551
2 changed files with 28 additions and 4 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= pixie
PORTVERSION= 2.2.6
PORTREVISION= 11
PORTREVISION= 12
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Pixie%20${PORTVERSION}
DISTNAME= Pixie-src-${PORTVERSION}
@ -19,7 +19,7 @@ LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
libfltk_gl.so:${PORTSDIR}/x11-toolkits/fltk
USE_GL= glu
USES= bison libtool pathfix tar:tgz
USES= bison compiler:c++0x libtool pathfix tar:tgz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/pixie \
--libdir=${PREFIX}/lib/pixie \
@ -45,7 +45,7 @@ BROKEN_sparc64= Does not compile on sparc64
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.include <bsd.port.options.mk>
.if ${OSVERSION} < 1000033
BUILD_DEPENDS+= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
@ -69,4 +69,4 @@ post-install:
(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR} \
'! -name "*Makefile*"')
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -0,0 +1,24 @@
--- configure.orig
+++ configure
@@ -12199,7 +12199,7 @@
old_striplib=
{ $as_echo "$as_me:$LINENO: checking whether stripping libraries is possible" >&5
$as_echo_n "checking whether stripping libraries is possible... " >&6; }
-if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "GNU strip" >/dev/null; then
+if test -n "$STRIP" && $STRIP -V 2>&1 | $GREP "strip" >/dev/null; then
test -z "$old_striplib" && old_striplib="$STRIP --strip-debug"
test -z "$striplib" && striplib="$STRIP --strip-unneeded"
{ $as_echo "$as_me:$LINENO: result: yes" >&5
@@ -18418,10 +18418,10 @@
if test x$FLTK_CONFIG != xno ; then
if test x$STATIC_FLTK != xtrue ; then
FLTK_CXXFLAGS="`$FLTK_CONFIG --use-gl --cxxflags`"
- FLTK_LDFLAGS="`$FLTK_CONFIG --use-gl --ldstaticflags`"
+ FLTK_LDFLAGS="`$FLTK_CONFIG --use-gl --ldstaticflags | sed 's/ -R.* / /g'`"
else
FLTK_CXXFLAGS="`$FLTK_CONFIG --use-gl --cxxflags`"
- FLTK_LDFLAGS="`$FLTK_CONFIG --use-gl --ldflags`"
+ FLTK_LDFLAGS="`$FLTK_CONFIG --use-gl --ldflags | sed 's/ -R.* / /g'`"
fi
else
FLTK_CXXFLAGS=""