- Fix a dictionary bug affected on 64 bit archs.
- While I'm here: fix pkg-plist - remove radiusd.sh. - Bump PORTREVISION PR: ports/92887 Submitted by: Alessandro Dellavedova <alessandro.dellavedova@gmail.com> Obtained from: http://bugs.freeradius.org/show_bug.cgi?id=312
This commit is contained in:
parent
129e669bb2
commit
cf3ef2f991
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=155338
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= freeradius
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
|
||||
http://freeradius.portal-to-web.de/
|
||||
|
11
net/freeradius/files/patch-src-lib-dict.c
Normal file
11
net/freeradius/files/patch-src-lib-dict.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/lib/dict.c.orig Mon Feb 6 10:15:41 2006
|
||||
+++ src/lib/dict.c Mon Feb 6 10:16:07 2006
|
||||
@@ -1207,7 +1207,7 @@
|
||||
if (!name) return NULL;
|
||||
|
||||
hash = dict_hashname(name);
|
||||
- hash = lrad_hash_update(&attr, sizeof(&attr), hash);
|
||||
+ hash = lrad_hash_update(&attr, sizeof(attr), hash);
|
||||
|
||||
return lrad_hash_table_finddata(values_byname, hash);
|
||||
}
|
@ -55,7 +55,6 @@ etc/raddb/realms.sample
|
||||
etc/raddb/snmp.conf.sample
|
||||
etc/raddb/sql.conf.sample
|
||||
etc/raddb/users.sample
|
||||
etc/rc.d/radiusd.sh
|
||||
lib/libeap-%%PORTVERSION%%.la
|
||||
lib/libeap-%%PORTVERSION%%.so
|
||||
lib/libeap.a
|
||||
|
@ -7,7 +7,7 @@
|
||||
|
||||
PORTNAME= freeradius
|
||||
PORTVERSION= 1.1.0
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= net
|
||||
MASTER_SITES= ftp://ftp.freeradius.org/pub/radius/ \
|
||||
http://freeradius.portal-to-web.de/
|
||||
|
11
net/freeradius2/files/patch-src-lib-dict.c
Normal file
11
net/freeradius2/files/patch-src-lib-dict.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- src/lib/dict.c.orig Mon Feb 6 10:15:41 2006
|
||||
+++ src/lib/dict.c Mon Feb 6 10:16:07 2006
|
||||
@@ -1207,7 +1207,7 @@
|
||||
if (!name) return NULL;
|
||||
|
||||
hash = dict_hashname(name);
|
||||
- hash = lrad_hash_update(&attr, sizeof(&attr), hash);
|
||||
+ hash = lrad_hash_update(&attr, sizeof(attr), hash);
|
||||
|
||||
return lrad_hash_table_finddata(values_byname, hash);
|
||||
}
|
@ -55,7 +55,6 @@ etc/raddb/realms.sample
|
||||
etc/raddb/snmp.conf.sample
|
||||
etc/raddb/sql.conf.sample
|
||||
etc/raddb/users.sample
|
||||
etc/rc.d/radiusd.sh
|
||||
lib/libeap-%%PORTVERSION%%.la
|
||||
lib/libeap-%%PORTVERSION%%.so
|
||||
lib/libeap.a
|
||||
|
Loading…
Reference in New Issue
Block a user