Add ted-2.10

Ted is a text editor running under X Windows on Unix/Linux systems. Ted was
developed as an operating system accessory like Wordpad on MS-Windows.

Features
--------
  * Wysiwyg rich text editing.
  * Ted uses Microsoft RTF as its native file format.
  * In line bitmap pictures.
  * Postscript printing.
  * Spelling checking in several Latin languages. (English, Dutch, German,
    Portuguese, French and Spanish.)
  * Directly mailing documents from Ted.
  * Cut/Copy/Paste, also with other applications.
  * Find/Replace.
  * Ruler: Paragraph indentation, Indentation of first line, Tabs.
  * Copy/Paste
    Ruler.
  * Page breaks.
  * Tables: Insert Table, Row, Column. Changing the column width of tables
    with their ruler.
  * Symbols and accented characters are fully supported.
  * Hyperlinks.
  * Saving a document in HTML format.

Obtained from:	OpenBSD
This commit is contained in:
Kris Kennaway 2001-08-24 08:32:20 +00:00
parent 80814c743b
commit cefbf2feab
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=46769
8 changed files with 221 additions and 0 deletions

View File

@ -112,6 +112,7 @@
SUBDIR += staroffice52
SUBDIR += sted
SUBDIR += tamago
SUBDIR += ted
SUBDIR += textedit
SUBDIR += the
SUBDIR += thoteditor

56
editors/ted/Makefile Normal file
View File

@ -0,0 +1,56 @@
# Ports collection makefile for: ted
# Date created: 23 Aug 2001
# Whom: Kris Kennaway <kris@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= ted
PORTVERSION= 2.10
CATEGORIES= editors textproc print
MASTER_SITES= ftp://ftp.nluug.nl/pub/editors/ted/
DISTNAME= ted-${PORTVERSION}.src.tar.gz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
WRKSRC= ${WRKDIR}/Ted-${PORTVERSION}
USE_MOTIF= yes
ALL_TARGET= compile.shared
AFMDIR= ${PREFIX}/share/Ted/afm
INDDIR= ${PREFIX}/share/Ted/ind
INFODIR= ${PREFIX}/share/doc/Ted
post-extract:
cd ${WRKSRC}/tedPackage && ${TAR_CMD} xf TedBindist.tar
post-patch:
cd ${WRKSRC}/tedPackage/info && \
${SED} -e 's,/usr/local/afm,${AFMDIR},' \
-e 's,/usr/local/ind,${INDDIR},' \
-e 's,/usr/local/info,${INFODIR},' \
Ted.ad.sample >Ted
for d in ${WRKSRC}/Ted ${WRKSRC}/appFrame; do \
cd $$d && \
${MV} -f config.h.in config.h.in.bak && \
${ECHO} '#define PREFIX "${PREFIX}"' >config.h.in && \
${ECHO} '#define INFODIR "${INFODIR}"' >>config.h.in && \
${ECHO} '#define INDDIR "${INDDIR}"' >>config.h.in && \
${ECHO} '#define AFMDIR "${AFMDIR}"' >>config.h.in && \
${CAT} config.h.in.bak >>config.h.in; \
done
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/Ted/Ted ${PREFIX}/bin/Ted
${MKDIR} ${AFMDIR}
${INSTALL_DATA} ${WRKSRC}/tedPackage/afm/* ${AFMDIR}
${MKDIR} ${INDDIR}
${MKDIR} ${INFODIR}
${INSTALL_DATA} ${WRKSRC}/tedPackage/info/TedDocument.rtf ${INFODIR}
${INSTALL_DATA} ${WRKSRC}/tedPackage/info/Ted ${PREFIX}/lib/X11/app-defaults
.include <bsd.port.mk>

1
editors/ted/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (ted-2.10.src.tar.gz) = 32758a4b0dd6d5cd3926960859cc8d54

View File

@ -0,0 +1,12 @@
$OpenBSD: patch-appFrame_appFileChooserMotif_c,v 1.2 2001/07/13 13:28:25 espie Exp $
--- appFrame/appFileChooserMotif.c.orig Sun Apr 8 18:05:30 2001
+++ appFrame/appFileChooserMotif.c Fri Jul 13 15:04:41 2001
@@ -524,7 +524,7 @@ static int appMakeFileChooser( AppChoose
XtSetArg( al[ac], XmNuseAsyncGeometry, True ); ac++;
XtSetArg( al[ac], XmNchildPlacement,XmPLACE_ABOVE_SELECTION ); ac++;
-# if XmVersion >= 2000
+# if XmVersion >= 2000 && !defined(LESSTIF_VERSION)
XtSetArg( al[ac], XmNfileFilterStyle,
XmFILTER_HIDDEN_FILES ); ac++;
# endif

106
editors/ted/files/patch-ab Normal file
View File

@ -0,0 +1,106 @@
$OpenBSD: patch-bitmap_bmpng_c,v 1.1 2001/07/13 13:28:26 espie Exp $
--- bitmap/bmpng.c.orig Fri Jul 13 15:07:41 2001
+++ bitmap/bmpng.c Fri Jul 13 15:15:19 2001
@@ -148,7 +148,7 @@ int bmReadPngFile( const char * filenam
FILE * f;
png_struct png;
- png_info pngi;
+ png_infop pngi;
unsigned char * buffer;
@@ -167,30 +167,30 @@ int bmReadPngFile( const char * filenam
if ( setjmp( png.jmpbuf ) )
{
SDEB(filename);
- png_read_destroy( &png, &pngi, (png_info *)0 );
+ png_read_destroy( &png, pngi, (png_info *)0 );
fclose( f );
return -1;
}
- png_info_init( &pngi );
+ pngi = png_create_info_struct(&png);
png_read_init( &png );
png_init_io( &png, f );
- png_read_info( &png, &pngi );
+ png_read_info( &png, pngi );
- if ( bpPngiToBitmap( &pngi, bd ) )
+ if ( bpPngiToBitmap( pngi, bd ) )
{
LLDEB(bd->bdColorCount,bd->bdRGB8Palette);
- png_read_destroy( &png, &pngi, (png_info *)0 );
+ png_read_destroy( &png, pngi, (png_info *)0 );
fclose( f );
return -1;
}
- if ( bmPngReadContents( &pngi, &png, bd, &buffer ) )
+ if ( bmPngReadContents( pngi, &png, bd, &buffer ) )
{
LLDEB(bd->bdBufferLength,buffer);
- png_read_destroy( &png, &pngi, (png_info *)0 );
+ png_read_destroy( &png, pngi, (png_info *)0 );
fclose( f );
return -1;
}
@@ -200,6 +200,8 @@ int bmReadPngFile( const char * filenam
*pBuffer= buffer;
*pPrivateFormat= 0;
+ png_destroy_info_struct(&png, &pngi);
+
return 0;
}
@@ -227,37 +229,38 @@ int bmPngReadPng( BitmapDescription * bd
SimpleInputStream * sis )
{
png_struct png;
- png_info pngi;
+ png_infop pngi;
unsigned char * buffer;
if ( setjmp( png.jmpbuf ) )
- { LDEB(1); png_read_destroy( &png, &pngi, (png_info *)0 ); return -1; }
+ { LDEB(1); png_read_destroy( &png, pngi, (png_info *)0 ); return -1; }
- png_info_init( &pngi );
+ pngi = png_create_info_struct(&png);
png_read_init( &png );
png_init_io( &png, (FILE *)0 );
png_set_read_fn( &png, (void *)sis, bmReadPngBytes );
- png_read_info( &png, &pngi );
+ png_read_info( &png, pngi );
- if ( bpPngiToBitmap( &pngi, bd ) )
+ if ( bpPngiToBitmap( pngi, bd ) )
{
LLDEB(bd->bdColorCount,bd->bdRGB8Palette);
- png_read_destroy( &png, &pngi, (png_info *)0 );
+ png_read_destroy( &png, pngi, (png_info *)0 );
return -1;
}
- if ( bmPngReadContents( &pngi, &png, bd, &buffer ) )
+ if ( bmPngReadContents( pngi, &png, bd, &buffer ) )
{
LLDEB(bd->bdBufferLength,buffer);
- png_read_destroy( &png, &pngi, (png_info *)0 );
+ png_read_destroy( &png, pngi, (png_info *)0 );
return -1;
}
*pBuffer= buffer;
+ png_destroy_info_struct(&png, &pngi);
return 0;
}

1
editors/ted/pkg-comment Normal file
View File

@ -0,0 +1 @@
X11 based RTF editor

23
editors/ted/pkg-descr Normal file
View File

@ -0,0 +1,23 @@
Ted is a text editor running under X Windows on Unix/Linux systems. Ted was
developed as an operating system accessory like Wordpad on MS-Windows.
Features
--------
* Wysiwyg rich text editing.
* Ted uses Microsoft RTF as its native file format.
* In line bitmap pictures.
* Postscript printing.
* Spelling checking in several Latin languages. (English, Dutch, German,
Portuguese, French and Spanish.)
* Directly mailing documents from Ted.
* Cut/Copy/Paste, also with other applications.
* Find/Replace.
* Ruler: Paragraph indentation, Indentation of first line, Tabs.
* Copy/Paste
Ruler.
* Page breaks.
* Tables: Insert Table, Row, Column. Changing the column width of tables
with their ruler.
* Symbols and accented characters are fully supported.
* Hyperlinks.
* Saving a document in HTML format.

21
editors/ted/pkg-plist Normal file
View File

@ -0,0 +1,21 @@
bin/Ted
lib/X11/app-defaults/Ted
share/Ted/afm/Courier-Bold.afm
share/Ted/afm/Courier-BoldOblique.afm
share/Ted/afm/Courier-Oblique.afm
share/Ted/afm/Courier.afm
share/Ted/afm/Helvetica-Bold.afm
share/Ted/afm/Helvetica-BoldOblique.afm
share/Ted/afm/Helvetica-Oblique.afm
share/Ted/afm/Helvetica.afm
share/Ted/afm/Symbol.afm
share/Ted/afm/Times-Bold.afm
share/Ted/afm/Times-BoldItalic.afm
share/Ted/afm/Times-Italic.afm
share/Ted/afm/Times-Roman.afm
share/doc/Ted/TedDocument.rtf
@dirrm share/doc/Ted
@exec mkdir -p %D/share/Ted/ind
@dirrm share/Ted/ind
@dirrm share/Ted/afm
@dirrm share/Ted