Update to 3.0.0.b8.
PR: 129223 Submitted by: Wen Heping <wenheping@gmail.com> Approved by: maintainer timeout (3 weeks)
This commit is contained in:
parent
b41df28ab5
commit
cef7aee49d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=224562
@ -6,8 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= opengl
|
||||
PORTVERSION= 2.0.1.07
|
||||
PORTREVISION= 4
|
||||
PORTVERSION= 3.0.0.b8
|
||||
CATEGORIES= graphics python
|
||||
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
|
||||
MASTER_SITE_SUBDIR= py${PORTNAME}
|
||||
@ -19,7 +18,6 @@ COMMENT= An OpenGL (and related library) interface for Python
|
||||
|
||||
BUILD_DEPENDS= ${PYNUMERIC} \
|
||||
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
|
||||
# swig1.3:${PORTSDIR}/devel/swig13
|
||||
RUN_DEPENDS= ${PYNUMERIC} \
|
||||
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
|
||||
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
|
||||
@ -31,6 +29,7 @@ USE_GL= yes
|
||||
USE_PYTHON= yes
|
||||
USE_PYDISTUTILS= yes
|
||||
PYDISTUTILS_PKGNAME= PyOpenGL
|
||||
PYDISTUTILS_PKGVERSION= ${PORTVERSION:S/.b/b/}
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
@ -43,8 +42,6 @@ post-patch:
|
||||
@${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e "s|
||"
|
||||
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
|
||||
's|<malloc\.h>|<stdlib.h>|g'
|
||||
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
|
||||
${WRKSRC}/config/freebsd.cfg ${WRKSRC}/Tkinter.py
|
||||
@${FIND} ${WRKSRC} -name "*.bak" -delete
|
||||
|
||||
post-install:
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (PyOpenGL-2.0.1.07.tar.gz) = 02e4331778fad4da7549ff1585a7a4a4
|
||||
SHA256 (PyOpenGL-2.0.1.07.tar.gz) = 7af4abf30b873cfc00d2800ea7d2a83cc4c66b27bb7d132c1daf8ab40b76ba34
|
||||
SIZE (PyOpenGL-2.0.1.07.tar.gz) = 1884617
|
||||
MD5 (PyOpenGL-3.0.0b8.tar.gz) = 1d9afbf0a403d916997937ef0dde2520
|
||||
SHA256 (PyOpenGL-3.0.0b8.tar.gz) = 85be2fbbfad70b226caa4b3c15c472a892b76b1e7d6b4a13f8764bb1e4394205
|
||||
SIZE (PyOpenGL-3.0.0b8.tar.gz) = 438379
|
||||
|
@ -1,28 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Tkinter.py.orig Tue Jan 14 19:47:57 2003
|
||||
+++ Tkinter.py Tue Jan 14 19:57:55 2003
|
||||
@@ -0,0 +1,22 @@
|
||||
+import os
|
||||
+
|
||||
+class nullcall:
|
||||
+ def __init(self):
|
||||
+ pass
|
||||
+ def call(self, a1='', a2='', a3='', a4='', a5=''):
|
||||
+ os.system('echo' + ' ' + a1 + ' ' + a2 + ' ' + a3 + ' ' + a4 + \
|
||||
+ ' ' + a5 + ' > register.tcl')
|
||||
+
|
||||
+class Tk:
|
||||
+ tk = None
|
||||
+ def __init__(self):
|
||||
+ self.tk = nullcall()
|
||||
+ pass
|
||||
+ def getvar(self, varname):
|
||||
+ if varname == 'tk_version' or varname == 'tcl_version':
|
||||
+ return '8.4'
|
||||
+ if varname == 'tcl_library':
|
||||
+ return '%%LOCALBASE%%/lib/tcl8.4'
|
||||
+ if varname == 'tk_library':
|
||||
+ return '%%LOCALBASE%%/lib/tk8.4'
|
||||
+ return ''
|
@ -1,13 +0,0 @@
|
||||
--- config/freebsd.cfg.orig Thu May 13 09:25:15 2004
|
||||
+++ config/freebsd.cfg Thu May 13 09:25:37 2004
|
||||
@@ -11,8 +11,8 @@
|
||||
[General]
|
||||
build_togl=1
|
||||
gl_platform=GLX
|
||||
-include_dirs=/usr/include:/usr/local/include:/usr/X11/include:/usr/X11R6/include
|
||||
-library_dirs=/usr/lib:/usr/local/lib:/usr/X11/lib:/usr/X11R6/lib
|
||||
+include_dirs=/usr/include:%%LOCALBASE%%/include
|
||||
+library_dirs=/usr/lib:%%LOCALBASE%%/lib
|
||||
|
||||
; a os.pathsep separated list of the libs needed when linking GL
|
||||
[GL]
|
Loading…
Reference in New Issue
Block a user