Upgrade to 0.3.20201218: special edition for the 20th anniversary!

This commit is contained in:
Thierry Thomas 2020-12-20 21:30:26 +00:00
parent dfaf0ffdb7
commit ced507ebe2
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=558779
11 changed files with 28 additions and 178 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pinball
PORTVERSION= 0.3.4
PORTVERSION= 0.3.20201218
CATEGORIES= games
MAINTAINER= thierry@FreeBSD.org
@ -14,10 +14,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:devel/libltdl
USE_GITHUB= yes
GH_ACCOUNT= sergiomb2
GH_ACCOUNT= adoptware
USES= autoreconf gl gettext gmake localbase:ldflags libtool:keepla sdl xorg # .la needed for plugin loading
USES+= sdl
USES= autoreconf gl gmake localbase:ldflags libtool:keepla \
pkgconfig sdl xorg # .la needed for plugin loading
USE_XORG= ice sm
USE_GL= gl glu
USE_SDL= image mixer sdl
@ -27,15 +27,13 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-debug
CPPFLAGS+= -DRZR_LIBSTATIC
MAKE_JOBS_UNSAFE=yes
SCOREDIR= /var/games
PLIST_SUB= SCOREDIR=${SCOREDIR}
#MAKE_JOBS_UNSAFE=yes
OPTIONS_DEFINE= DOCS
post-install.orig:
${MV} ${STAGEDIR}/var/games/pinball/professor/highscores \
${STAGEDIR}/var/games/pinball/professor/highscores.sample
${MV} ${STAGEDIR}/var/games/pinball/tux/highscores \
${STAGEDIR}/var/games/pinball/tux/highscores.sample
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/pinball/lib*.so*
post-install-DOCS-on:

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1561318996
SHA256 (sergiomb2-pinball-0.3.4_GH0.tar.gz) = c5b7a3992fd681c0d9a907461c2c68a8d868e9e15178534529ce7b9366698542
SIZE (sergiomb2-pinball-0.3.4_GH0.tar.gz) = 24822463
TIMESTAMP = 1608457541
SHA256 (adoptware-pinball-0.3.20201218_GH0.tar.gz) = 61981c192630f3c99865dc3b3d095df94e97ede9d7df0e8d8601eb39eef54c6d
SIZE (adoptware-pinball-0.3.20201218_GH0.tar.gz) = 6054158

View File

@ -1,4 +1,4 @@
--- Makefile.am.orig 2018-03-24 23:40:31 UTC
--- Makefile.am.orig 2020-12-18 16:34:55 UTC
+++ Makefile.am
@@ -1,6 +1,6 @@
AUTOMAKE_OPTIONS = gnu
@ -8,8 +8,3 @@
EXTRA_DIST = bootstrap pinball.spec clean pinball.desktop
@@ -10,4 +10,3 @@ pininclude_HEADERS = pinconfig.h
bin_SCRIPTS = pinball-config
-ACLOCAL_AMFLAGS = -I libltdl/m4

View File

@ -1,6 +1,6 @@
--- base/TextureUtil.cpp.orig 2018-03-24 23:40:31 UTC
--- base/TextureUtil.cpp.orig 2020-12-18 16:34:55 UTC
+++ base/TextureUtil.cpp
@@ -54,6 +54,7 @@ extern "C" {
@@ -55,6 +55,7 @@ extern "C" {
#if EM_USE_ALLEGRO
#include <allegro.h>
@ -8,7 +8,7 @@
BITMAP * backbuffer = NULL;
ZBUFFER * zbuffer = NULL;
#endif // EM_USE_ALLEGRO
@@ -333,9 +334,10 @@ int TextureUtil::genTexture( char const * const filena
@@ -339,9 +340,10 @@ int TextureUtil::genTexture( char const * const filena
EmTexture * const texture)
{
//cout<<"+ Texture::genTexture : "<<filename<<endl;

View File

@ -1,21 +0,0 @@
--- configure.ac.orig 2018-03-24 23:40:31 UTC
+++ configure.ac
@@ -4,9 +4,6 @@ dnl init autoconf and automake
AC_INIT(pinball, 0.3.4.1)
AC_CONFIG_HEADERS(pinconfig.h)
-LT_CONFIG_LTDL_DIR([libltdl])
-AC_CONFIG_AUX_DIR([libltdl/config])
-AC_CONFIG_MACRO_DIR([libltdl/m4])
AC_CANONICAL_HOST
AC_CANONICAL_TARGET
@@ -22,7 +19,7 @@ AC_PROG_MKDIR_P
AM_GNU_GETTEXT([external])
#For rhel6 but rhel6 doesn't have SDL2
#AM_GNU_GETTEXT_VERSION(0.17)
-AM_GNU_GETTEXT_VERSION(0.19.8)
+AM_GNU_GETTEXT_VERSION(0.20)
dnl this is a c++ program
dnl CFLAGS="-g -W -Wall -O2"

View File

@ -1,4 +1,4 @@
--- data/tux/ModuleTux.cpp.orig 2018-03-24 23:40:31 UTC
--- data/tux/ModuleTux.cpp.orig 2020-12-18 16:34:55 UTC
+++ data/tux/ModuleTux.cpp
@@ -7,6 +7,7 @@
***************************************************************************/
@ -15,5 +15,5 @@
-#include "Config.h"
+#include <libintl.h>
#include <locale>
#define MISSION_TEXT_TIMEOUT 6000
#define INFO_TEXT_TIME 600

View File

@ -1,10 +0,0 @@
--- data/hurd/ModuleHurd.cpp.orig 2018-03-24 23:40:31 UTC
+++ data/hurd/ModuleHurd.cpp
@@ -24,6 +24,7 @@
#include "Keyboard.h"
#include "Table.h"
#include "Config.h"
+#include <libintl.h>
#include <locale>

View File

@ -1,11 +0,0 @@
--- src/Makefile.am.orig 2018-03-24 23:40:31 UTC
+++ src/Makefile.am
@@ -10,7 +10,7 @@ bin_PROGRAMS = pinball
AM_CPPFLAGS = -I../base -I../addon @INCLTDL@
pinball_LDADD = \
- libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
+ libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@ @LIBINTL@
pinball_LDFLAGS = -export-dynamic

View File

@ -1,6 +1,6 @@
--- src/EyeBehavior.cpp.orig 2018-03-24 23:40:31 UTC
--- src/EyeBehavior.cpp.orig 2020-12-18 16:34:55 UTC
+++ src/EyeBehavior.cpp
@@ -56,6 +56,7 @@ void EyeBehavior::onTick() {
@@ -57,6 +57,7 @@ void EyeBehavior::onTick() {
EmAssert(table->getBall(2) != NULL, "Ball3 group NULL");
EmAssert(this->getParent() != NULL, "Parent group NULL");
@ -8,9 +8,9 @@
// shortcuts for changing view F1, F2, F2, F4 // now F5 F6 F7 F8
// I changed to F5 F6 F7 F8 to use the Alt+F4 quit shortcut //!rzr
if (Keyboard::isKeyDown(SDLK_F5)) {
@@ -71,6 +72,7 @@ void EyeBehavior::onTick() {
} else if (Keyboard::isKeyDown(SDLK_F10)) { //rotated screen
Config::getInstance()->setView(5);
@@ -68,6 +69,7 @@ void EyeBehavior::onTick() {
} else if (Keyboard::isKeyDown(SDLK_F8)) {
Config::getInstance()->setView(3);
}
+#endif

View File

@ -1,11 +0,0 @@
--- test/Makefile.am.orig 2018-03-24 23:40:31 UTC
+++ test/Makefile.am
@@ -6,7 +6,7 @@ testdatadir = $(pkgdatadir)
noinst_PROGRAMS = scale simple light texture load explode collision signal billboard font thread menu joy sound trans math misc varray unittest
AM_CPPFLAGS = -I../base -I../addon -I../src @INCLTDL@
-LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@
+LDADD = ../src/libemilia_pin.a ../addon/libemilia_addon.a ../base/libemilia_base.a @LIBLTDL@ @LIBINTL@
testlib_LTLIBRARIES = libModuleTest.la

View File

@ -62,26 +62,11 @@ include/pinball/TextureUtil.h
include/pinball/TransformVisitor.h
include/pinball/Visitor.h
include/pinball/pinconfig.h
lib/pinball/libModuleGnu.a
lib/pinball/libModuleGnu.la
lib/pinball/libModuleGnu.so
lib/pinball/libModuleGnu.so.0
lib/pinball/libModuleGnu.so.0.0.0
lib/pinball/libModuleHurd.a
lib/pinball/libModuleHurd.la
lib/pinball/libModuleHurd.so
lib/pinball/libModuleHurd.so.0
lib/pinball/libModuleHurd.so.0.0.0
lib/pinball/libModuleProfessor.a
lib/pinball/libModuleProfessor.la
lib/pinball/libModuleProfessor.so
lib/pinball/libModuleProfessor.so.0
lib/pinball/libModuleProfessor.so.0.0.0
lib/pinball/libModuleProfessor2.a
lib/pinball/libModuleProfessor2.la
lib/pinball/libModuleProfessor2.so
lib/pinball/libModuleProfessor2.so.0
lib/pinball/libModuleProfessor2.so.0.0.0
lib/pinball/libModuleTest.a
lib/pinball/libModuleTest.la
lib/pinball/libModuleTest.so
@ -96,66 +81,8 @@ lib/pinball/libemilia_addon.a
lib/pinball/libemilia_base.a
lib/pinball/libemilia_pin.a
%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/de_DE/LC_MESSAGES/pinball.mo
share/locale/fr_FR/LC_MESSAGES/pinball.mo
share/locale/pt_PT/LC_MESSAGES/pinball.mo
%%DATADIR%%/font_34.png
%%DATADIR%%/font_35.pcx
%%DATADIR%%/gnu/bump.ogg
%%DATADIR%%/gnu/bumpsoft.wav
%%DATADIR%%/gnu/flip2b.ogg
%%DATADIR%%/gnu/flip2br.ogg
%%DATADIR%%/gnu/free_all.ogg
%%DATADIR%%/gnu/free_letter.ogg
%%DATADIR%%/gnu/freeball.ogg
%%DATADIR%%/gnu/freedom0.ogg
%%DATADIR%%/gnu/freedom1.ogg
%%DATADIR%%/gnu/freedom2.ogg
%%DATADIR%%/gnu/freedom3.ogg
%%DATADIR%%/gnu/gnu.png
%%DATADIR%%/gnu/gnu2b.png
%%DATADIR%%/gnu/gnu_all.ogg
%%DATADIR%%/gnu/gnu_letter.ogg
%%DATADIR%%/gnu/gplv1.ogg
%%DATADIR%%/gnu/gplv2.ogg
%%DATADIR%%/gnu/gplv3.ogg
%%DATADIR%%/gnu/hit-freeball-target.ogg
%%DATADIR%%/gnu/hit-freedom-target.ogg
%%DATADIR%%/gnu/knockdown.ogg
%%DATADIR%%/gnu/lock.ogg
%%DATADIR%%/gnu/multiball.wav
%%DATADIR%%/gnu/music.ogg
%%DATADIR%%/gnu/nudge.wav
%%DATADIR%%/gnu/pinball.pbl
%%DATADIR%%/gnu/plunger.wav
%%DATADIR%%/gnu/raise-stopper.ogg
%%DATADIR%%/gnu/reset_knockdowns.ogg
%%DATADIR%%/gnu/shoot.ogg
%%DATADIR%%/gnu/tiles.png
%%DATADIR%%/gnu/tiles2.png
%%DATADIR%%/gnu/tiles3.png
%%DATADIR%%/hurd/Wood.jpg
%%DATADIR%%/hurd/bump.wav
%%DATADIR%%/hurd/bumphard.wav
%%DATADIR%%/hurd/bumpsoft.wav
%%DATADIR%%/hurd/flip.wav
%%DATADIR%%/hurd/floor-room.jpg
%%DATADIR%%/hurd/floor.png
%%DATADIR%%/hurd/floor3.png
%%DATADIR%%/hurd/game.ogg
%%DATADIR%%/hurd/gameover.wav
%%DATADIR%%/hurd/gnu.png
%%DATADIR%%/hurd/hurd.png
%%DATADIR%%/hurd/intro.ogg
%%DATADIR%%/hurd/label.png
%%DATADIR%%/hurd/loop.wav
%%DATADIR%%/hurd/nudge.wav
%%DATADIR%%/hurd/pinball.pbl
%%DATADIR%%/hurd/shoot.wav
%%DATADIR%%/hurd/sub.png
%%DATADIR%%/hurd/tiles.png
%%DATADIR%%/hurd/tiles2.png
%%DATADIR%%/hurd/up.wav
%%DATADIR%%/pinball.xpm
%%DATADIR%%/professor/bump.wav
%%DATADIR%%/professor/bumphard.wav
@ -169,28 +96,6 @@ share/locale/pt_PT/LC_MESSAGES/pinball.mo
%%DATADIR%%/professor/pinball.pbl
%%DATADIR%%/professor/professor.ogg
%%DATADIR%%/professor/professor.png
%%DATADIR%%/professor2/blue.png
%%DATADIR%%/professor2/blue2.png
%%DATADIR%%/professor2/bump.wav
%%DATADIR%%/professor2/bumper.png
%%DATADIR%%/professor2/bumphard.wav
%%DATADIR%%/professor2/bumpsoft.wav
%%DATADIR%%/professor2/flip.wav
%%DATADIR%%/professor2/floor-room.jpg
%%DATADIR%%/professor2/gameover.wav
%%DATADIR%%/professor2/intro.ogg
%%DATADIR%%/professor2/introp.ogg
%%DATADIR%%/professor2/label.png
%%DATADIR%%/professor2/nudge.wav
%%DATADIR%%/professor2/pinball.pbl
%%DATADIR%%/professor2/professor.ogg
%%DATADIR%%/professor2/professor.png
%%DATADIR%%/professor2/shoot.wav
%%DATADIR%%/professor2/tiles.png
%%DATADIR%%/professor2/triangle.png
%%DATADIR%%/professor2/up.wav
%%DATADIR%%/professor2/wall.jpg
%%DATADIR%%/professor2/wheel.png
%%DATADIR%%/splash.png
%%DATADIR%%/splash.png.pcx
%%DATADIR%%/tux/bump.wav
@ -216,3 +121,8 @@ share/locale/pt_PT/LC_MESSAGES/pinball.mo
%%DATADIR%%/tux/tiles.png
%%DATADIR%%/tux/tiles.png.pcx
%%DATADIR%%/tux/up.wav
@sample(,games,664) %%SCOREDIR%%/pinball/professor/highscores
@sample(,games,664) %%SCOREDIR%%/pinball/tux/highscores
@dir %%SCOREDIR%%/pinball/professor
@dir %%SCOREDIR%%/pinball/tux
@dir %%SCOREDIR%%/pinball