Update to 3.80.

PR:		ports/51359
Submitted by:	Ports Fury
This commit is contained in:
Norikatsu Shigemura 2003-04-26 22:30:59 +00:00
parent 041e3325dc
commit ced4d92504
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=79703
5 changed files with 109 additions and 46 deletions

View File

@ -5,69 +5,94 @@
# $FreeBSD$
PORTNAME= terminatorx
PORTVERSION= 3.73
PORTVERSION= 3.80
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/
MASTER_SITES= http://www.terminatorx.cx/dist/
DISTNAME= terminatorX-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Realtime audio synthesizer that allows you to "scratch" on audio data
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomehier gnomelibs
CONFIGURE_ARGS+= --disable-gtk2
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_SOX)
BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
CONFIGURE_ARGS+= --enable-sox
.endif
.if !defined(WITHOUT_VORBIS)
BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
CONFIGURE_ARGS+= --enable-vorbis
.endif
.if !defined(WITHOUT_MAD)
LIB_DEPENDS+= mad.1:${PORTSDIR}/audio/mad
CONFIGURE_ARGS+= --enable-mad
.endif
GNU_CONFIGURE= yes
USE_GNOME= gnomehier libxml2 gtk20
USE_REINPLACE= yes
USE_GMAKE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-lrdf --with-docdir="${PREFIX}/share/gnome"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= terminatorX.1
.if !defined(WITHOUT_MPG123)
BUILD_DEPENDS+= mpg123:${PORTSDIR}/audio/mpg123
.else
CONFIGURE_ARGS+= --disable-mpg123
.endif
.if !defined(WITHOUT_SOX)
BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
.else
CONFIGURE_ARGS+= --disable-sox
.endif
.if !defined(WITHOUT_VORBIS)
BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+= --disable-vorbis
.endif
.if !defined(WITHOUT_MAD)
LIB_DEPENDS+= mad.1:${PORTSDIR}/audio/mad
.else
CONFIGURE_ARGS+= --disable-mad
.endif
pre-everything::
.if !defined(WITHOUT_MPG123)
@${ECHO_MSG} "You can disable support for mpg123 by defining WITHOUT_MPG123."
.endif
.if !defined(WITHOUT_SOX)
@${ECHO_MSG} "You can disable support for sox by defining WITHOUT_SOX."
.endif
.if !defined(WITHOUT_VORBIS)
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
.endif
.if !defined(WITHOUT_MAD)
@${ECHO_MSG} "You can disable support for mad by defining WITHOUT_MAD."
.endif
post-patch:
${REINPLACE_CMD} -e "s,function option_info,option_info," ${WRKSRC}/configure
${REINPLACE_CMD} -e "s,malloc.h,stdlib.h," ${WRKSRC}/src/main.cc \
${WRKSRC}/src/tX_audiofile.cc ${WRKSRC}/src/tX_flash.c \
${WRKSRC}/src/tX_seqpar.cc ${WRKSRC}/src/tX_vtt.cc \
${WRKSRC}/src/tX_widget.c
@${REINPLACE_CMD} -e \
's|function option_info|option_info|g' ${WRKSRC}/configure
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/terminatorX.1 ${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX-mime.png ${WRKSRC}/gnome-support/terminatorX-app.png ${PREFIX}/share/gnome/pixmaps
${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.mime ${WRKSRC}/gnome-support/terminatorX.keys ${PREFIX}/share/gnome/mime-info
${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.desktop ${PREFIX}/share/gnome/apps/Multimedia/terminatorX.desktop
.for file in terminatorX-app.png terminatorX-mime.png
${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
${PREFIX}/share/gnome/pixmaps
.endfor
.for file in terminatorX.mime terminatorX.keys
${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
${PREFIX}/share/gnome/mime-info
.endfor
.for file in terminatorX.desktop
${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
${PREFIX}/share/gnome/apps/Multimedia
.endfor
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (terminatorX-3.73.tar.gz) = b1cc4d1f08d3768286584416ed4dfd4b
MD5 (terminatorX-3.80.tar.bz2) = 542dfbcec3504ff61aa59dda924f1f24

View File

@ -0,0 +1,34 @@
--- src/tX_global.c.orig Thu Apr 17 04:45:56 2003
+++ src/tX_global.c Thu Apr 24 21:21:59 2003
@@ -230,7 +230,7 @@
char indent[]="\t";
FILE *rc=NULL;
gzFile rz=NULL;
- _store_compress_xml=0;
+ int _store_compress_xml=0;
char tmp_xml_buffer[4096];
get_rc_name(rc_name);
@@ -314,7 +314,7 @@
}
char *encode_xml(char *dest, const char *src) {
- int i, t, max;
+ int i, t, max, inlen, outlen, res;
char tmp[4096];
tmp[0]=0;
@@ -333,10 +333,10 @@
}
tmp[t]=0;
- int outlen=4096;
- int inlen=t;
+ outlen=4096;
+ inlen=t;
- int res=isolat1ToUTF8((unsigned char *) dest, &outlen, (unsigned char *) tmp, &inlen);
+ res=isolat1ToUTF8((unsigned char *) dest, &outlen, (unsigned char *) tmp, &inlen);
dest[outlen]=0;
if (res<0) {
tX_error("failed to encode string (%s) to UTF-8.", src);

View File

@ -0,0 +1,15 @@
--- src/tX_widget.c.orig Sat Apr 19 13:56:36 2003
+++ src/tX_widget.c Sat Apr 19 14:13:50 2003
@@ -154,10 +154,10 @@
}
static void gtk_tx_destroy(GtkObject * object) {
+ GtkTx *tx=GTK_TX(object);
+
g_return_if_fail(object != NULL);
g_return_if_fail(GTK_IS_TX(object));
-
- GtkTx *tx=GTK_TX(object);
if (tx->disp_data) { free(tx->disp_data); tx->disp_data=NULL; }

View File

@ -1,11 +0,0 @@
--- src/tX_mastergui.cc.orig Sat Feb 1 22:20:23 2003
+++ src/tX_mastergui.cc Sat Feb 1 22:20:49 2003
@@ -1125,7 +1125,7 @@
gtk_widget_destroy(GTK_WIDGET(mbox));
}
-void tx_note(const char *message, bool isError=false)
+void tx_note(const char *message, bool isError)
{
char buffer[4096]="terminatorX ";
if (isError) {