- Update to 201606062303

- Add fix for issue #702 (in OpenSMTPD) which was resulting in build
  error on FreeBSD 9.x
This commit is contained in:
Ashish SHUKLA 2016-06-07 09:20:07 +00:00
parent d52e89e235
commit cec8c4fe51
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=416503
4 changed files with 42 additions and 6 deletions

View File

@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= opensmtpd
PORTVERSION= 201605221711
PORTVERSION= 201606062303
DISTVERSIONSUFFIX= p1
PORTEPOCH= 1
PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.opensmtpd.org/archives/ \
http://distfiles.pirateparty.in/ashish/

View File

@ -1,2 +1,3 @@
SHA256 (opensmtpd-201605221711p1.tar.gz) = e7f63a4d5c26386cffe61f35d6e4a959a1f6f38b3fbe0351c746326cf2329418
SIZE (opensmtpd-201605221711p1.tar.gz) = 691693
TIMESTAMP = 1465270468
SHA256 (opensmtpd-201606062303p1.tar.gz) = f54a496ec4729073bba2efec2daca69a469b2fd7666dbcc309d21324f76d16ad
SIZE (opensmtpd-201606062303p1.tar.gz) = 692651

View File

@ -1,6 +1,6 @@
--- mk/smtpd/Makefile.in.orig 2016-02-02 20:40:51 UTC
--- mk/smtpd/Makefile.in.orig 2016-06-06 21:03:28 UTC
+++ mk/smtpd/Makefile.in
@@ -1365,13 +1365,7 @@ install-exec-hook: $(CONFIGFILES) $(MANP
@@ -1366,13 +1366,7 @@ install-exec-hook: $(CONFIGFILES) $(MANP
$(MKDIR_P) $(DESTDIR)$(bindir)
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)5
$(MKDIR_P) $(DESTDIR)$(mandir)/$(mansubdir)8

View File

@ -0,0 +1,36 @@
--- smtpd/smtpd.c.orig 2016-06-06 20:51:18 UTC
+++ smtpd/smtpd.c
@@ -1,4 +1,4 @@
-/* $OpenBSD: smtpd.c,v 1.277 2016/05/28 21:21:20 eric Exp $ */
+/* $OpenBSD: smtpd.c,v 1.278 2016/06/07 06:52:49 gilles Exp $ */
/*
* Copyright (c) 2008 Gilles Chehade <gilles@poolp.org>
@@ -843,9 +843,12 @@ start_child(int save_argc, char **save_a
if (save_argc >= SMTPD_MAXARG - 2)
fatalx("too many arguments");
- if (socketpair(AF_UNIX, SOCK_STREAM|SOCK_NONBLOCK, PF_UNSPEC, sp) == -1)
+ if (socketpair(AF_UNIX, SOCK_STREAM, PF_UNSPEC, sp) == -1)
fatal("socketpair");
+ io_set_nonblocking(sp[0]);
+ io_set_nonblocking(sp[1]);
+
switch (pid = fork()) {
case -1:
fatal("%s: fork", save_argv[0]);
@@ -884,9 +887,12 @@ setup_peers(struct mproc *a, struct mpro
{
int sp[2];
- if (socketpair(AF_UNIX, SOCK_STREAM|SOCK_NONBLOCK, PF_UNSPEC, sp) == -1)
+ if (socketpair(AF_UNIX, SOCK_STREAM, PF_UNSPEC, sp) == -1)
fatal("socketpair");
+ io_set_nonblocking(sp[0]);
+ io_set_nonblocking(sp[1]);
+
if (imsg_compose(&a->imsgbuf, IMSG_SETUP_PEER, b->proc, b->pid, sp[0],
NULL, 0) == -1)
fatal("imsg_compose");