Lime Suite is a collection of software supporting several hardware platforms

including the LimeSDR, drivers for the LMS7002M transceiver RFIC, and other
tools for developing with LMS7-based hardware. Installing the Lime Suite
enables many SDR applications such as GQRX to work with supported hardware
through the bundled SoapySDR support module.

PR:		ports/252032
Submitted by:	tomek@cedro.info
This commit is contained in:
Diane Bruce 2020-12-31 01:35:40 +00:00
parent 02eb878f5d
commit ce86f1187c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559702
11 changed files with 452 additions and 0 deletions

View File

@ -85,6 +85,7 @@
SUBDIR += libticables2
SUBDIR += libticalcs2
SUBDIR += libusbmuxd
SUBDIR += limesuite
SUBDIR += linrad
SUBDIR += liquid-dsp
SUBDIR += lirc

93
comms/limesuite/Makefile Normal file
View File

@ -0,0 +1,93 @@
# $FreeBSD$
PORTNAME= limesuite
DISTVERSIONPREFIX= v
DISTVERSION= 20.10.0
CATEGORIES= comms astro hamradio
MAINTAINER= tomek@cedro.info
COMMENT= Software Defined Radio Software Suite from Lime Microsystems
LICENSE= APACHE20
BUILD_DEPENDS= gnuplot:math/gnuplot
RUN_DEPENDS= sqlite3:databases/sqlite3
USES= cmake
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= myriadrf
GH_PROJECT= LimeSuite
# DESKTOP IS LINUX ONLY.
# SPI IS LINUX ONLY.
# STREAM UNITE BROKEN UPSTREAM
CMAKE_OFF= ENABLE_DESKTOP \
ENABLE_SPI \
ENABLE_STREAM \
ENABLE_STREAM_UNITE
CMAKE_ON= ENABLE_LIBRARY \
ENABLE_LIME_UTIL \
ENABLE_EXAMPLES \
ENABLE_LIMERFE \
ENABLE_EVB7COM
OPTIONS_DEFINE= DOCS GUI QUICKTEST OCTAVE REMOTE SOAPYSDR
OPTIONS_DEFAULT= GUI QUICKTEST SOAPYSDR
OPTIONS_UNSET= DOCS
OPTIONS_SUB= yes
QUICKTEST_DESC= Build QuickTest Self-Test suite
OCTAVE_DESC= Enable Octave integration
REMOTE_DESC= Enable remote testing operations
SOAPYSDR_DESC= Build LMS7 SoapySDR bindings
PLIST_SUB= PORTVERSION=${PORTVERSION}
DOCS_CMAKE_BOOL= ENABLE_API_DOXYGEN
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
GUI_CMAKE_BOOL= ENABLE_GUI
QUICKTEST_CMAKE_BOOL= ENABLE_QUICKTEST
QUICKTEST_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
OCTAVE_CMAKE_BOOL= ENABLE_OCTAVE
OCTAVE_BUILD_DEPENDS= octave:math/octave
PLIST_SUB+= OCTAVE_VERSION=${OCTAVE_VERSION}
REMOTE_CMAKE_BOOL= ENABLE_REMOTE
SOAPYSDR_CMAKE_BOOL= ENABLE_SOAPY_LMS7
SOAPYSDR_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGUI}
USES+= gl xorg
USE_XORG= x11 ice sm xcursor xext xfixes xinerama xft xrender
USE_GL= gl glu
USE_WX= 3.1
WX_COMPS= wx:lib
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
.endif
post-build:
# N.B. COPYTREE_BIN here chmods 555 which breaks CMAKE_INSTALL in user mode!
(cd ${BUILD_WRKSRC}/bin && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/bin)
${CHMOD} u+w ${STAGEDIR}${PREFIX}/bin/*
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.endif
.if ${PORT_OPTIONS:MGUI}
${MKDIR} ${STAGEDIR}${PREFIX}/share/pixmaps
${MKDIR} ${STAGEDIR}${PREFIX}/share/applications
(cd ${WRKSRC}/Desktop && ${CP} *.png ${STAGEDIR}${PREFIX}/share/pixmaps/)
(cd ${WRKSRC}/Desktop && ${CP} lime-suite.desktop ${STAGEDIR}${PREFIX}/share/applications/)
.endif
.include "../../math/octave/Makefile.version"
.include <bsd.port.post.mk>

3
comms/limesuite/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1608434916
SHA256 (myriadrf-LimeSuite-v20.10.0_GH0.tar.gz) = f6d79dc67cb52a5aea839d1dc00e65f85367cb2c275d77f149833d32cf79b467
SIZE (myriadrf-LimeSuite-v20.10.0_GH0.tar.gz) = 5421065

View File

@ -0,0 +1,14 @@
--- CMakeLists.txt.orig 2020-10-29 09:52:56 UTC
+++ CMakeLists.txt
@@ -171,6 +171,11 @@ if (ENABLE_NEW_GAIN_BEHAVIOUR)
add_definitions(-DNEW_GAIN_BEHAVIOUR)
endif()
+if (CMAKE_SYSTEM_NAME MATCHES "BSD")
+ include_directories("/usr/local/include")
+ add_definitions(-D__unix__=1) #we use this for unix detection, but clang does not define it
+endif()
+
########################################################################
# rpath setup - http://www.cmake.org/Wiki/CMake_RPATH_handling
########################################################################

View File

@ -0,0 +1,19 @@
--- Desktop/CMakeLists.txt.orig 2020-10-29 09:52:56 UTC
+++ Desktop/CMakeLists.txt
@@ -1,13 +1,13 @@
########################################################################
## Feature registration
########################################################################
-if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- set(LINUX TRUE)
+if(CMAKE_SYSTEM_NAME STREQUAL "Linux" OR "FreeBSD")
+ set(UNIX TRUE)
endif()
include(FeatureSummary)
include(CMakeDependentOption)
-cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;LINUX" OFF)
+cmake_dependent_option(ENABLE_DESKTOP "Enable LimeSuite launcher and icons" ON "ENABLE_GUI;UNIX" OFF)
add_feature_info(LimeSuiteDesktop ENABLE_DESKTOP "LimeSuite freedesktop integration")
if (NOT ENABLE_DESKTOP)
return()

View File

@ -0,0 +1,13 @@
--- src/ConnectionRemote/ConnectionRemote.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionRemote/ConnectionRemote.cpp
@@ -31,6 +31,10 @@
#include <Winsock.h>
#endif // LINUX
+#if defined(__FreeBSD__)
+#include <sys/socket.h>
+#endif
+
using namespace std;
using namespace lime;

View File

@ -0,0 +1,10 @@
--- src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITE.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITE.cpp
@@ -5,7 +5,6 @@
*/
#include "ConnectionSTREAM_UNITE.h"
-#include "ErrorReporting.h"
using namespace std;
namespace lime
{

View File

@ -0,0 +1,11 @@
--- src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITEEntry.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/ConnectionSTREAM_UNITE/ConnectionSTREAM_UNITEEntry.cpp
@@ -16,7 +16,7 @@ static ConnectionSTREAM_UNITEEntry STREAM_UNITEEntry;
}
ConnectionSTREAM_UNITEEntry::ConnectionSTREAM_UNITEEntry(void):
- ConnectionFX3Entry("STREAM+UNITE")
+ ConnectionFX3Entry()
{
}

View File

@ -0,0 +1,11 @@
--- src/FPGAcontrols_wxgui/FPGAcontrols_wxgui.cpp.orig 2020-10-29 09:52:56 UTC
+++ src/FPGAcontrols_wxgui/FPGAcontrols_wxgui.cpp
@@ -166,7 +166,7 @@ int ReadWFM(const wxString filename, std::vector<int16
if( fpin.IsOpened() == false)
{
#ifndef NDEBUG
- lime::debug("WFM reading: Input file can not be opened (%s)", filename);
+ lime::debug("WFM reading: Input file can not be opened (%s)", filename.mb_str().data());
#endif
return -1;
}

View File

@ -0,0 +1,7 @@
Lime Suite is a collection of software supporting several hardware platforms
including the LimeSDR, drivers for the LMS7002M transceiver RFIC, and other
tools for developing with LMS7-based hardware. Installing the Lime Suite
enables many SDR applications such as GQRX to work with supported hardware
through the bundled SoapySDR support module.
WWW: https://github.com/myriadrf/LimeSuite

270
comms/limesuite/pkg-plist Normal file
View File

@ -0,0 +1,270 @@
bin/LimeUtil
bin/basicRX
bin/basicTX
bin/dualRXTX
bin/gpio_example
bin/limeRFE_ADC_example
bin/limeRFE_I2C_example
bin/limeRFE_USB_example
bin/singleRX
include/lime/ADCUnits.h
include/lime/ADF4002.h
include/lime/ConnectionHandle.h
include/lime/ConnectionRegistry.h
include/lime/FPGA_common.h
include/lime/IConnection.h
include/lime/LMS64CCommands.h
include/lime/LMS64CProtocol.h
include/lime/LMS7002M.h
include/lime/LMS7002M_RegistersMap.h
include/lime/LMS7002M_parameters.h
include/lime/LMSBoards.h
include/lime/LimeSuite.h
include/lime/LimeSuiteConfig.h
include/lime/Logger.h
include/lime/MCU_BD.h
include/lime/MCU_File.h
include/lime/Si5351C.h
include/lime/Streamer.h
include/lime/SystemResources.h
include/lime/VersionInfo.h
include/lime/dataTypes.h
include/lime/fifo.h
include/lime/limeRFE.h
include/lime/lms7_device.h
lib/cmake/LimeSuite/LimeSuiteConfig.cmake
lib/cmake/LimeSuite/LimeSuiteConfigVersion.cmake
lib/libLimeSuite.so
lib/libLimeSuite.so.20.10-1
lib/libLimeSuite.so.%%PORTVERSION%%
libdata/pkgconfig/LimeSuite.pc
%%SOAPYSDR%%lib/SoapySDR/modules0.7/libLMS7Support.so
%%GUI%%bin/LimeSuiteGUI
%%GUI%%share/applications/lime-suite.desktop
%%GUI%%share/pixmaps/lime-suite-128.png
%%GUI%%share/pixmaps/lime-suite-16.png
%%GUI%%share/pixmaps/lime-suite-22.png
%%GUI%%share/pixmaps/lime-suite-32.png
%%GUI%%share/pixmaps/lime-suite-48.png
%%GUI%%share/pixmaps/lime-suite-64.png
%%QUICKTEST%%bin/LimeQuickTest
%%OCTAVE%%lib/octave/%%OCTAVE_VERSION%%/site/oct/%%CONFIGURE_TARGET%%/LimeSuite.oct
%%OCTAVE%%share/octave/%%OCTAVE_VERSION%%/site/m/LoadLimeSuite.m
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h_source.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/annotated_dup.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/bc_s.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/classes.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/closed.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/deprecated.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_32ceaae954650ed827ac1560ef6f4ef9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_32ceaae954650ed827ac1560ef6f4ef9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_34940aac630699970110928b60ddb4bc.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d250019ea536d42a5797d8e92eb15235.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d250019ea536d42a5797d8e92eb15235.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d2e0d63e6f0c29b47fae2fad83249b64.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_d2e0d63e6f0c29b47fae2fad83249b64.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dir_e3821db3a7cd44f7328e850c7cb284c9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doc.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/files.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/files_dup.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/functions.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/functions_eval.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/functions_vars.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_defs.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_enum.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_eval.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_func.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_type.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/globals_vars.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___b_o_a_r_d___p_a_r_a_m.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___b_o_a_r_d___p_a_r_a_m.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___a_d_v_a_n_c_e_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___a_d_v_a_n_c_e_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___h_i_g_h___l_v_l.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___h_i_g_h___l_v_l.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___i_n_i_t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___i_n_i_t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___l_o_w___l_v_l.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___l_o_w___l_v_l.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___s_t_r_e_a_m.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___s_t_r_e_a_m.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___v_e_r_s_i_o_n.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___f_n___v_e_r_s_i_o_n.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___l_m_s___c_l_o_c_k___i_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___l_m_s___c_l_o_c_k___i_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___l_m_s___l_o_g___l_e_v_e_l.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___l_m_s___l_o_g___l_e_v_e_l.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___s_t_r_e_a_m___c_h___f_l_a_g_s.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/group___s_t_r_e_a_m___c_h___f_l_a_g_s.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/index.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/jquery.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/menu.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/menudata.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/modules.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/modules.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_f.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/nav_h.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtree.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtree.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreedata.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreeindex0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/navtreeindex1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/open.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/page_changelog.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/pages.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/resize.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_10.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_10.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_11.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_11.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_a.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_a.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_b.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_b.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_c.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_c.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_e.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_e.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_f.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/all_f.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/classes_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/classes_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/close.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enums_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enums_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enumvalues_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/enumvalues_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/files_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/files_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/functions_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/functions_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/groups_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/mag_sel.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/nomatches.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/pages_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search.css
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_l.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_m.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/search_r.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/searchdata.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/typedefs_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_0.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_0.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_1.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_1.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_10.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_10.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_2.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_2.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_3.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_3.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_4.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_4.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_5.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_5.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_6.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_6.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_7.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_7.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_8.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_8.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_9.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_9.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_a.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_a.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_b.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_b.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_c.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_c.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_d.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_d.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_e.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_e.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_f.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/search/variables_f.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/splitbar.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__dev__info__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__dev__info__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__range__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__range__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__meta__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__meta__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__status__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__status__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__t.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/structlms__stream__t.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_a.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_b.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_h.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tab_s.png
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/Lime_Suite_Compilation_Guide.odt
%%PORTDOCS%%%%DOCSDIR%%/Lime_Suite_Compilation_Guide.pdf
%%PORTDOCS%%%%DOCSDIR%%/StreamProtocol.doc
%%PORTDOCS%%%%DOCSDIR%%/StreamProtocol.pdf
%%PORTDOCS%%%%DOCSDIR%%/doxygen/Doxyfile.in
%%PORTDOCS%%%%DOCSDIR%%/doxygen/DoxyfileAPI.in
%%PORTDOCS%%%%DOCSDIR%%/doxygen/mainpage.dox
%%PORTDOCS%%%%DOCSDIR%%/lms7_api_quick_start_guide.odt
%%PORTDOCS%%%%DOCSDIR%%/lms7_api_quick_start_guide.pdf