Upgrade to 0.4.4.

PR:		ports/52077
Submitted by:	maintainer
This commit is contained in:
Oliver Braun 2003-05-11 21:11:48 +00:00
parent e1629c50f3
commit ce801f61fa
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=80696
3 changed files with 5 additions and 55 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= gtk-imonc
PORTVERSION= 0.3a
PORTVERSION= 0.4.4
CATEGORIES= sysutils
MASTER_SITES= http://userpage.fu-berlin.de/~zeank/gtk-imonc/download/
@ -17,13 +17,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
ALL_TARGET= #empty
HAS_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gtk12 gnomehier
USE_GNOME= gtk12
USE_REINPLACE= yes
USE_X_PREFIX= yes
post-patch:
@${REINPLACE_CMD} -e 's|gtk-config|gtk12-config|g ; \
s|/usr/local|${X11BASE}|g' \
${WRKSRC}/configure
pre-configure:
@${REINPLACE_CMD} -e 's|ac_default_prefix=/usr/local|ac_default_prefix=${PREFIX}|g' ${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (gtk-imonc-0.3a.tar.gz) = b4718cea4076e7af1581092ade9b61f1
MD5 (gtk-imonc-0.4.4.tar.gz) = 4e6a6a5f5bdbba928940571d8b2d3774

View File

@ -1,48 +0,0 @@
--- gtk-imonc/timer.c.orig Fri Aug 16 21:52:15 2002
+++ gtk-imonc/timer.c Sat Oct 26 15:43:20 2002
@@ -183,12 +183,12 @@
row[i] = chargebuf;
break;
case 8: /* IBytes */
- tmpbytes = atoll (strtok (NULL, " "));
+ tmpbytes = atoi (strtok (NULL, " "));
ibytes += tmpbytes;
row[i] = get_bytes (tmpbytes, ibytebuf);
break;
case 9: /* OBytes */
- tmpbytes = atoll (strtok (NULL, " "));
+ tmpbytes = atoi (strtok (NULL, " "));
obytes += tmpbytes;
row[i] = get_bytes (tmpbytes, obytebuf);
break;
@@ -773,8 +773,8 @@
gtk_clist_set_text (GTK_CLIST (clist), j, 2, get_answer (fd));
send_command (fd, "quantity pppoe");
- gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes (atoll (strtok (get_answer (fd), " ")), buf));
- gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes (atoll (strtok (NULL, " ")), buf));
+ gtk_clist_set_text (GTK_CLIST (clist), j, 3, get_bytes (atoi (strtok (get_answer (fd), " ")), buf));
+ gtk_clist_set_text (GTK_CLIST (clist), j, 4, get_bytes (atoi (strtok (NULL, " ")), buf));
send_command (fd, "online-time pppoe");
gtk_clist_set_text (GTK_CLIST (clist), j, 5, get_answer (fd));
@@ -814,8 +814,8 @@
sprintf (buf, "quantity %i", i);
send_command (fd, buf);
- gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 3, get_bytes (atoll (strtok (get_answer (fd), " ")), buf));
- gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 4, get_bytes (atoll (strtok (NULL, " ")), buf));
+ gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 3, get_bytes (atoi (strtok (get_answer (fd), " ")), buf));
+ gtk_clist_set_text (GTK_CLIST (clist), (j+i-1), 4, get_bytes (atoi (strtok (NULL, " ")), buf));
sprintf (buf, "online-time %i", i);
send_command (fd, buf);
@@ -892,7 +892,7 @@
return buf;
}
- sprintf (buf, "%lu", (ulong) bytes);
+ sprintf (buf, "%lu", (long) bytes);
return buf;
} /* get_bytes (bytes, *buf) */