- Update To 6.0.3

PR:		ports/160310
Submitted by:	Laurent Berthelet <laurent@ospowa.com> (maintainer)
This commit is contained in:
Beech Rintoul 2011-09-06 23:08:36 +00:00
parent 7ddd5c11c0
commit ce5d2946b1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=281326
8 changed files with 190 additions and 58 deletions

View File

@ -1,13 +1,12 @@
# New ports collection makefile for: openerp-server
# Date created: 27 February 2009
# Whom: Wen Heping<wenheping@gmail.com>
# Date created: 27 February 2009
# Whom: Wen Heping <wenheping@gmail.com>
#
# $FreeBSD$
#
PORTNAME= openerp-server
PORTVERSION= 5.0.15
PORTREVISION= 1
PORTVERSION= 6.0.3
PORTEPOCH= 1
CATEGORIES= finance python
MASTER_SITES= http://www.openerp.com/download/stable/source/
@ -25,8 +24,24 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imag
${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
${PYTHON_PKGNAMEPREFIX}chart>0:${PORTSDIR}/graphics/py-chart \
${PYTHON_PKGNAMEPREFIX}pydot>0:${PORTSDIR}/graphics/py-pydot \
${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RC_SUBR= openerpd
SUB_FILES= openerp-server.conf pkg-message
@ -34,7 +49,11 @@ SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFO= openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
PYDISTUTILS_EGGINFO= PKG-INFO
USERS= openerpd
GROUPS= openerpd
MAN1= openerp-server.1
MAN5= openerp_serverrc.5
@ -70,6 +89,10 @@ post-install:
-type f | ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
@${FIND} -s -d ${PYTHON_SITELIBDIR}/${PORTNAME} \
-type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
@${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
-type f -print |grep -v PKG-INFO| ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
@${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
-type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}

View File

@ -1,2 +1,2 @@
SHA256 (openerp-server-5.0.15.tar.gz) = 021dd27f352e1c92c0912d8b50f05cfcee39052551a2c6d90ee1677f4e361504
SIZE (openerp-server-5.0.15.tar.gz) = 10529558
SHA256 (openerp-server-6.0.3.tar.gz) = 763296aef9967848506daa23dca017b2f341d12936d1db9df1f2ba1412b218a9
SIZE (openerp-server-6.0.3.tar.gz) = 28477345

View File

@ -26,9 +26,48 @@ load_rc_config $name
: ${openerpd_enable="NO"}
: ${openerpd_config="%%PREFIX%%/etc/openerp-server.conf"}
: ${openerpd_user="openerpd"}
openerpd_pidfile=${openerpd_pidfile:-"/var/run/openerp-server/openerpd.pid"}
openerpd_config=${openerpd_config:-"/usr/local/etc/openerpd.conf"}
openerpd_flags=${openerpd_flags:-"--config=${openerpd_config}"}
required_files="$openerpd_config"
start_precmd="${name}_prestart"
stop_cmd="${name}_stop"
openerpd_prestart()
{
if [ ! -d `dirname ${openerpd_pidfile}` ]
then
mkdir -p `dirname ${openerpweb_pidfile}`
fi
chown ${openerpd_user} `dirname ${openerpd_pidfile}`
}
openerpd_stop()
{
# ensure the server is stopped
if [ -f ${openerpd_pidfile} ]
then
echo "Stopping ${name}."
kill -15 `cat ${openerpd_pidfile}`
else
openerpd_pid=`pgrep -f "openerp-server.py ${openerpd_flags}"`
if [ ${openerpd_pid} ]
then
echo "Stopping ${name}."
kill -15 ${openerpd_pid}
else
echo "${name} not running? (pidfile not found)"
fi
fi
}
command_args="-c $openerpd_config >/dev/null 2>&1 &"
load_rc_config $name
run_rc_command "$1"

View File

@ -1,25 +1,29 @@
--- setup.py.orig 2009-02-09 20:32:57.000000000 +0800
+++ setup.py 2009-02-09 20:33:48.000000000 +0800
@@ -92,14 +92,14 @@
opj('bin', 'server.pkey'),
opj('bin', 'server.cert')]))
--- setup.py 2011-08-21 16:34:59.526991138 +0200
+++ setup.diffs 2011-08-21 16:35:49.515560426 +0200
@@ -145,16 +145,16 @@
# files.append((root, [join(root, name) for name in names]))
files.append(('.', [join('bin', 'import_xml.rng'),]))
else:
- man_directory = opj('share', 'man')
- files.append((opj(man_directory, 'man1'), ['man/openerp-server.1']))
- files.append((opj(man_directory, 'man5'), ['man/openerp_serverrc.5']))
- man_directory = join('share', 'man')
- files.append((join(man_directory, 'man1'), ['man/openerp-server.1']))
- files.append((join(man_directory, 'man5'), ['man/openerp_serverrc.5']))
-
- doc_directory = opj('share', 'doc', 'openerp-server-%s' % version)
- files.append((doc_directory, [f for f in glob.glob('doc/*') if os.path.isfile(f)]))
- files.append((opj(doc_directory, 'migrate', '3.3.0-3.4.0'), [f for f in glob.glob('doc/migrate/3.3.0-3.4.0/*') if os.path.isfile(f)]))
- files.append((opj(doc_directory, 'migrate', '3.4.0-4.0.0'), [f for f in glob.glob('doc/migrate/3.4.0-4.0.0/*') if os.path.isfile(f)]))
+# man_directory = opj('share', 'man')
+# files.append((opj(man_directory, 'man1'), ['man/openerp-server.1']))
+# files.append((opj(man_directory, 'man5'), ['man/openerp_serverrc.5']))
+
+# doc_directory = opj('share', 'doc', 'openerp-server-%s' % version)
+# files.append((doc_directory, [f for f in glob.glob('doc/*') if os.path.isfile(f)]))
+# files.append((opj(doc_directory, 'migrate', '3.3.0-3.4.0'), [f for f in glob.glob('doc/migrate/3.3.0-3.4.0/*') if os.path.isfile(f)]))
+# files.append((opj(doc_directory, 'migrate', '3.4.0-4.0.0'), [f for f in glob.glob('doc/migrate/3.4.0-4.0.0/*') if os.path.isfile(f)]))
- doc_directory = join('share', 'doc', 'openerp-server-%s' % version)
- files.append((doc_directory, filter(isfile, glob.glob('doc/*'))))
- files.append((join(doc_directory, 'migrate', '3.3.0-3.4.0'),
- filter(isfile, glob.glob('doc/migrate/3.3.0-3.4.0/*'))))
- files.append((join(doc_directory, 'migrate', '3.4.0-4.0.0'),
- filter(isfile, glob.glob('doc/migrate/3.4.0-4.0.0/*'))))
+# man_directory = join('share', 'man')
+# files.append((join(man_directory, 'man1'), ['man/openerp-server.1']))
+# files.append((join(man_directory, 'man5'), ['man/openerp_serverrc.5']))
+#
+# doc_directory = join('share', 'doc', 'openerp-server-%s' % version)
+# files.append((doc_directory, filter(isfile, glob.glob('doc/*'))))
+# files.append((join(doc_directory, 'migrate', '3.3.0-3.4.0'),
+# filter(isfile, glob.glob('doc/migrate/3.3.0-3.4.0/*'))))
+# files.append((join(doc_directory, 'migrate', '3.4.0-4.0.0'),
+# filter(isfile, glob.glob('doc/migrate/3.4.0-4.0.0/*'))))
openerp_site_packages = opj('lib', 'python%s' % py_short_version, 'site-packages', 'openerp-server')
openerp_site_packages = join(get_python_lib(prefix=''), 'openerp-server')

View File

@ -1,13 +1,12 @@
# New ports collection makefile for: openerp-server
# Date created: 27 February 2009
# Whom: Wen Heping<wenheping@gmail.com>
# Date created: 27 February 2009
# Whom: Wen Heping <wenheping@gmail.com>
#
# $FreeBSD$
#
PORTNAME= openerp-server
PORTVERSION= 5.0.15
PORTREVISION= 1
PORTVERSION= 6.0.3
PORTEPOCH= 1
CATEGORIES= finance python
MASTER_SITES= http://www.openerp.com/download/stable/source/
@ -25,8 +24,24 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imag
${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/__init__.py:${PORTSDIR}/graphics/py-imaging \
${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_SITELIBDIR}/mx/__init__.py:${PORTSDIR}/lang/py-mx-base \
${PYTHON_PKGNAMEPREFIX}psycopg2>0:${PORTSDIR}/databases/py-psycopg2 \
${PYTHON_PKGNAMEPREFIX}chart>0:${PORTSDIR}/graphics/py-chart \
${PYTHON_PKGNAMEPREFIX}pydot>0:${PORTSDIR}/graphics/py-pydot \
${PYTHON_PKGNAMEPREFIX}libxslt>0:${PORTSDIR}/textproc/py-libxslt \
${PYTHON_PKGNAMEPREFIX}lxml>0:${PORTSDIR}/devel/py-lxml \
${PYTHON_PKGNAMEPREFIX}xml>0:${PORTSDIR}/textproc/py-xml \
${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}mako>0:${PORTSDIR}/textproc/py-mako \
${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RC_SUBR= openerpd
SUB_FILES= openerp-server.conf pkg-message
@ -34,7 +49,11 @@ SUB_LIST= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR}
USE_PYTHON= 2.5+
USE_PYDISTUTILS= yes
PYDISTUTILS_EGGINFO= openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
PYDISTUTILS_EGGINFODIR= ${PYTHON_SITELIBDIR}/openerp_server-${PORTVERSION}-${PYTHON_VERSION:S/thon//}.egg-info
PYDISTUTILS_EGGINFO= PKG-INFO
USERS= openerpd
GROUPS= openerpd
MAN1= openerp-server.1
MAN5= openerp_serverrc.5
@ -70,6 +89,10 @@ post-install:
-type f | ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
@${FIND} -s -d ${PYTHON_SITELIBDIR}/${PORTNAME} \
-type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
@${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
-type f -print |grep -v PKG-INFO| ${SED} 's#${PREFIX}/##g' >> ${TMPPLIST}
@${FIND} -s -d ${PYDISTUTILS_EGGINFODIR} \
-type d | ${SED} 's#${PREFIX}/#@dirrm #g' >> ${TMPPLIST}
@${CAT} ${PKGMESSAGE}

View File

@ -1,2 +1,2 @@
SHA256 (openerp-server-5.0.15.tar.gz) = 021dd27f352e1c92c0912d8b50f05cfcee39052551a2c6d90ee1677f4e361504
SIZE (openerp-server-5.0.15.tar.gz) = 10529558
SHA256 (openerp-server-6.0.3.tar.gz) = 763296aef9967848506daa23dca017b2f341d12936d1db9df1f2ba1412b218a9
SIZE (openerp-server-6.0.3.tar.gz) = 28477345

View File

@ -26,9 +26,48 @@ load_rc_config $name
: ${openerpd_enable="NO"}
: ${openerpd_config="%%PREFIX%%/etc/openerp-server.conf"}
: ${openerpd_user="openerpd"}
openerpd_pidfile=${openerpd_pidfile:-"/var/run/openerp-server/openerpd.pid"}
openerpd_config=${openerpd_config:-"/usr/local/etc/openerpd.conf"}
openerpd_flags=${openerpd_flags:-"--config=${openerpd_config}"}
required_files="$openerpd_config"
start_precmd="${name}_prestart"
stop_cmd="${name}_stop"
openerpd_prestart()
{
if [ ! -d `dirname ${openerpd_pidfile}` ]
then
mkdir -p `dirname ${openerpweb_pidfile}`
fi
chown ${openerpd_user} `dirname ${openerpd_pidfile}`
}
openerpd_stop()
{
# ensure the server is stopped
if [ -f ${openerpd_pidfile} ]
then
echo "Stopping ${name}."
kill -15 `cat ${openerpd_pidfile}`
else
openerpd_pid=`pgrep -f "openerp-server.py ${openerpd_flags}"`
if [ ${openerpd_pid} ]
then
echo "Stopping ${name}."
kill -15 ${openerpd_pid}
else
echo "${name} not running? (pidfile not found)"
fi
fi
}
command_args="-c $openerpd_config >/dev/null 2>&1 &"
load_rc_config $name
run_rc_command "$1"

View File

@ -1,25 +1,29 @@
--- setup.py.orig 2009-02-09 20:32:57.000000000 +0800
+++ setup.py 2009-02-09 20:33:48.000000000 +0800
@@ -92,14 +92,14 @@
opj('bin', 'server.pkey'),
opj('bin', 'server.cert')]))
--- setup.py 2011-08-21 16:34:59.526991138 +0200
+++ setup.diffs 2011-08-21 16:35:49.515560426 +0200
@@ -145,16 +145,16 @@
# files.append((root, [join(root, name) for name in names]))
files.append(('.', [join('bin', 'import_xml.rng'),]))
else:
- man_directory = opj('share', 'man')
- files.append((opj(man_directory, 'man1'), ['man/openerp-server.1']))
- files.append((opj(man_directory, 'man5'), ['man/openerp_serverrc.5']))
- man_directory = join('share', 'man')
- files.append((join(man_directory, 'man1'), ['man/openerp-server.1']))
- files.append((join(man_directory, 'man5'), ['man/openerp_serverrc.5']))
-
- doc_directory = opj('share', 'doc', 'openerp-server-%s' % version)
- files.append((doc_directory, [f for f in glob.glob('doc/*') if os.path.isfile(f)]))
- files.append((opj(doc_directory, 'migrate', '3.3.0-3.4.0'), [f for f in glob.glob('doc/migrate/3.3.0-3.4.0/*') if os.path.isfile(f)]))
- files.append((opj(doc_directory, 'migrate', '3.4.0-4.0.0'), [f for f in glob.glob('doc/migrate/3.4.0-4.0.0/*') if os.path.isfile(f)]))
+# man_directory = opj('share', 'man')
+# files.append((opj(man_directory, 'man1'), ['man/openerp-server.1']))
+# files.append((opj(man_directory, 'man5'), ['man/openerp_serverrc.5']))
+
+# doc_directory = opj('share', 'doc', 'openerp-server-%s' % version)
+# files.append((doc_directory, [f for f in glob.glob('doc/*') if os.path.isfile(f)]))
+# files.append((opj(doc_directory, 'migrate', '3.3.0-3.4.0'), [f for f in glob.glob('doc/migrate/3.3.0-3.4.0/*') if os.path.isfile(f)]))
+# files.append((opj(doc_directory, 'migrate', '3.4.0-4.0.0'), [f for f in glob.glob('doc/migrate/3.4.0-4.0.0/*') if os.path.isfile(f)]))
- doc_directory = join('share', 'doc', 'openerp-server-%s' % version)
- files.append((doc_directory, filter(isfile, glob.glob('doc/*'))))
- files.append((join(doc_directory, 'migrate', '3.3.0-3.4.0'),
- filter(isfile, glob.glob('doc/migrate/3.3.0-3.4.0/*'))))
- files.append((join(doc_directory, 'migrate', '3.4.0-4.0.0'),
- filter(isfile, glob.glob('doc/migrate/3.4.0-4.0.0/*'))))
+# man_directory = join('share', 'man')
+# files.append((join(man_directory, 'man1'), ['man/openerp-server.1']))
+# files.append((join(man_directory, 'man5'), ['man/openerp_serverrc.5']))
+#
+# doc_directory = join('share', 'doc', 'openerp-server-%s' % version)
+# files.append((doc_directory, filter(isfile, glob.glob('doc/*'))))
+# files.append((join(doc_directory, 'migrate', '3.3.0-3.4.0'),
+# filter(isfile, glob.glob('doc/migrate/3.3.0-3.4.0/*'))))
+# files.append((join(doc_directory, 'migrate', '3.4.0-4.0.0'),
+# filter(isfile, glob.glob('doc/migrate/3.4.0-4.0.0/*'))))
openerp_site_packages = opj('lib', 'python%s' % py_short_version, 'site-packages', 'openerp-server')
openerp_site_packages = join(get_python_lib(prefix=''), 'openerp-server')