- Update to 0.2.1

- Bumped shlib version to 1
- Conditionalize libgnugetopt dependency

PR:		48702
Submitted by:	Sergei Kolobov <sergei@kolobov.com>
This commit is contained in:
Christian Weisgerber 2003-02-27 20:09:41 +00:00
parent c19d348710
commit ce4b1510c1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=76592
4 changed files with 31 additions and 20 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= libtasn1
PORTVERSION= 0.1.2
PORTVERSION= 0.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG} \
http://www.mirrors.wiretapped.net/security/network-security/gnutls/libtasn1/ \
@ -17,33 +17,30 @@ MASTER_SITE_SUBDIR= alpha/gnutls/libtasn1
MAINTAINER= sergei@kolobov.com
COMMENT= ASN.1 structure parser library
.if !exists(/usr/include/getopt.h)
LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
.endif
USE_REINPLACE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnugetopt
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
DOCS= AUTHORS NEWS README THANKS
DOCS2= asn1.ps asn1.tex fdl.tex
DOCS= AUTHORS NEWS README THANKS doc/asn1.ps doc/asn1.tex doc/fdl.tex
post-patch:
.for file in asn1Coding.c asn1Decoding.c asn1Parser.c
${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/src/${file}
.endfor
post-install:
${RM} -f ${PREFIX}/lib/libtasn1.la
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
.for file in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.for file in ${DOCS2}
${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
.endfor
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (libtasn1-0.1.2.tar.gz) = 6c8c376e5582f6845371a939869166dd
MD5 (libtasn1-0.2.1.tar.gz) = 738810df8f97b9b457a5dc6aa5ad2065

View File

@ -0,0 +1,13 @@
$FreeBSD$
--- configure.orig Thu Feb 27 21:02:03 2003
+++ configure Thu Feb 27 21:02:16 2003
@@ -8617,6 +8617,7 @@
# This can be used to rebuild libtool when needed
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'

View File

@ -1,12 +1,13 @@
@comment $FreeBSD$
include/libtasn1.h
lib/libtasn1.so.0
lib/libtasn1.so.1
lib/libtasn1.so
lib/libtasn1.a
%%PORTDOCS%%share/doc/libtasn1/AUTHORS
%%PORTDOCS%%share/doc/libtasn1/NEWS
%%PORTDOCS%%share/doc/libtasn1/README
%%PORTDOCS%%share/doc/libtasn1/THANKS
%%PORTDOCS%%share/doc/libtasn1/asn1.ps
%%PORTDOCS%%share/doc/libtasn1/asn1.tex
%%PORTDOCS%%share/doc/libtasn1/fdl.tex
%%PORTDOCS%%@dirrm share/doc/libtasn1
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/THANKS
%%PORTDOCS%%%%DOCSDIR%%/asn1.ps
%%PORTDOCS%%%%DOCSDIR%%/asn1.tex
%%PORTDOCS%%%%DOCSDIR%%/fdl.tex
%%PORTDOCS%%@dirrm %%DOCSDIR%%