Add xmms-mailnotify, plays a sound on incoming mail and opens the MUA
PR: 35062
This commit is contained in:
parent
fbe2fe602e
commit
cdbd4b39db
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70205
@ -295,6 +295,7 @@
|
||||
SUBDIR += xmms-ladspa
|
||||
SUBDIR += xmms-liveice
|
||||
SUBDIR += xmms-mad
|
||||
SUBDIR += xmms-mailnotify
|
||||
SUBDIR += xmms-midi
|
||||
SUBDIR += xmms-musepack
|
||||
SUBDIR += xmms-osssurround
|
||||
|
23
audio/xmms-mailnotify/Makefile
Normal file
23
audio/xmms-mailnotify/Makefile
Normal file
@ -0,0 +1,23 @@
|
||||
# New ports collection makefile for: xmms-mailnotify
|
||||
# Date created: 03.02.2002
|
||||
# Whom: Tilman Linneweh <arved@FreeBSD.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= xmms-mailnotify
|
||||
PORTVERSION= 0.2.0
|
||||
CATEGORIES= audio
|
||||
MASTER_SITES= http://iso.kapsobor.de/xmms/
|
||||
|
||||
MAINTAINER= arved@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
|
||||
|
||||
USE_X_PREFIX= yes
|
||||
USE_LIBTOOL= yes
|
||||
USE_GMAKE= yes
|
||||
USE_GNOMENG= yes
|
||||
USE_GNOME= gtk12
|
||||
INSTALLS_SHLIB= yes
|
||||
|
||||
.include <bsd.port.mk>
|
1
audio/xmms-mailnotify/distinfo
Normal file
1
audio/xmms-mailnotify/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (xmms-mailnotify-0.2.0.tar.gz) = 83d4bcb11c9fcdcf17c73a0a4a9cbd77
|
19
audio/xmms-mailnotify/files/patch-aa
Normal file
19
audio/xmms-mailnotify/files/patch-aa
Normal file
@ -0,0 +1,19 @@
|
||||
--- mailnotify.c.orig Sun Feb 3 21:12:45 2002
|
||||
+++ mailnotify.c Sun Feb 3 21:13:05 2002
|
||||
@@ -82,14 +82,14 @@
|
||||
gchar command[256];
|
||||
gboolean runcmd;
|
||||
gchar alertfile[256];
|
||||
- } folders[MAX_FOLDERS] = {0};
|
||||
+ } folders[MAX_FOLDERS] = {{{0}}};
|
||||
|
||||
struct origin {
|
||||
gchar senderaddr[256];
|
||||
gboolean runcmd;
|
||||
gchar command[256];
|
||||
gchar alertfile[256];
|
||||
- } origins[MAX_ORIGINS] = {0};
|
||||
+ } origins[MAX_ORIGINS] = {{{0}}};
|
||||
|
||||
|
||||
/* #if !defined(UTIMBUF)
|
1
audio/xmms-mailnotify/pkg-comment
Normal file
1
audio/xmms-mailnotify/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
XMMS plugin, that plays a sound on incoming mail and opens the MUA
|
4
audio/xmms-mailnotify/pkg-descr
Normal file
4
audio/xmms-mailnotify/pkg-descr
Normal file
@ -0,0 +1,4 @@
|
||||
XMMS plugin, that plays a sound on incoming mail and opens the MUA
|
||||
|
||||
WWW: http://iso.kapsobor.de/xmms/
|
||||
Author: Felix Willmann <iso@kapsobor.de>
|
2
audio/xmms-mailnotify/pkg-plist
Normal file
2
audio/xmms-mailnotify/pkg-plist
Normal file
@ -0,0 +1,2 @@
|
||||
lib/xmms/General/libmailnotify.so
|
||||
lib/xmms/General/alert.wav
|
Loading…
Reference in New Issue
Block a user