Remove dns/bind95 which entered EOL 2010-09

This commit is contained in:
Doug Barton 2011-01-01 00:38:44 +00:00
parent da1c267852
commit cdac3d6e78
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=267244
8 changed files with 1 additions and 547 deletions

1
MOVED
View File

@ -4744,3 +4744,4 @@ www/linux-flock||2010-12-31|Has expired: Flock 3 moves from Firefox to Chromium
x11-clocks/xtu||2010-12-31|Has expired: Looks like abandonware
java/tya||2010-12-31|Has expired: looks like abandonware and does not compile wth gcc4.2
net-p2p/qbittorrent-22||2011-01-01|Old version no longer updated
dns/bind95||2011-01-01|Entered EOL 2010-09 - Update to dns/bind97 or dns/bind96

View File

@ -11,7 +11,6 @@
SUBDIR += bind9-sdb-postgresql
SUBDIR += bind94
SUBDIR += bind94-geoip
SUBDIR += bind95
SUBDIR += bind96
SUBDIR += bind97
SUBDIR += bind98

View File

@ -1,223 +0,0 @@
# New ports collection makefile for: BIND 9.5.x
# Date created: 2 July 2008
# Whom: dougb
#
# $FreeBSD$
#
# I stay very aware of developments with BIND in general, and with
# BIND 9 in particular. I frequently delay updating this port from
# a known-stable version due to concerns about stability of a newer
# version. If you are concerned about using the most recent ISC
# release you can generally build it cleanly from the source - Doug
PORTNAME= bind95
PORTVERSION= 9.5.2.4
CATEGORIES= dns net ipv6
MASTER_SITES= ${MASTER_SITE_ISC} \
http://dougbarton.us/Downloads/%SUBDIR%/
MASTER_SITE_SUBDIR= bind9/${ISCVERSION}
DISTNAME= bind-${ISCVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= dougb@FreeBSD.org
COMMENT= The BIND DNS suite with updated DNSSEC and threads
# ISC releases things like 9.4.0b3, which our versioning doesn't like
ISCVERSION= 9.5.2-P4
DEPRECATED= Past EOL
EXPIRATION_DATE= 2011-01-01
MAKE_JOBS_UNSAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var --disable-linux-caps \
--with-randomdev=/dev/random
CONFLICTS= bind9*-9.[4678].* bind9-sdb-* host-* bind-tools-9.*
OPTIONS= SSL "Building without OpenSSL removes DNSSEC" on \
LINKS "Create conf file symlinks in ${PREFIX}" on \
XML "Support for xml statistics output" on \
IDN "Add IDN support to dig, host, etc." off \
REPLACE_BASE "Replace base BIND with this version" off \
LARGE_FILE "64-bit file support" off \
SIGCHASE "dig/host/nslookup will do DNSSEC validation" off \
IPV6 "IPv6 Support (autodetected by default)" off \
THREADS "Compile with thread support" on \
DLZ_POSTGRESQL "DLZ Postgres driver" off \
DLZ_MYSQL "DLZ MySQL driver (single-threaded BIND)" off \
DLZ_BDB "DLZ BDB driver" off \
DLZ_LDAP "DLZ LDAP driver" off \
DLZ_FILESYSTEM "DLZ filesystem driver" off \
DLZ_STUB "DLZ stub driver" off
# Just in case
USE_OPENSSL= yes
.include <bsd.port.pre.mk>
.if (${ARCH} == "amd64")
ARCH= x86_64
.endif
.if !defined(WITHOUT_SSL)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}
.else
CONFIGURE_ARGS+= --disable-openssl-version-check
CONFIGURE_ARGS+= --without-openssl
.endif
.if !defined(WITHOUT_XML)
CONFIGURE_ARGS+= --with-libxml2=${LOCALBASE}
LIB_DEPENDS+= xml2.5:${PORTSDIR}/textproc/libxml2
.else
CONFIGURE_ARGS+= --without-libxml2
.endif
.if defined(WITH_IDN)
CONFIGURE_ARGS+= --with-idn=${LOCALBASE} --with-libiconv=${LOCALBASE}
LIB_DEPENDS+= idnkit.1:${PORTSDIR}/dns/idnkit
.else
CONFIGURE_ARGS+= --without-idn
.endif
.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
PLIST_SUB+= LINKS=""
.else
PLIST_SUB+= LINKS="@comment "
.endif
.if defined(WITH_LARGE_FILE)
CONFIGURE_ARGS+= --enable-largefile
.endif
.if defined(WITH_SIGCHASE)
CONFIGURE_ARGS+= STD_CDEFINES="-DDIG_SIGCHASE=1"
.endif
.if defined(WITH_IPV6)
CONFIGURE_ARGS+= --enable-ipv6
.endif
.if defined(WITH_DLZ_POSTGRESQL)
CONFIGURE_ARGS+= --with-dlz-postgres=yes
USE_PGSQL= yes
.endif
.if defined(WITH_DLZ_MYSQL)
CONFIGURE_ARGS+= --with-dlz-mysql=yes
USE_MYSQL= yes
WITHOUT_THREADS= yes
.endif
.if defined(WITH_DLZ_BDB)
CONFIGURE_ARGS+= --with-dlz-bdb=yes
USE_BDB= yes
.endif
.if defined(WITH_DLZ_LDAP)
CONFIGURE_ARGS+= --with-dlz-ldap=yes
USE_OPENLDAP= yes
.endif
.if defined(WITH_DLZ_FILESYSTEM)
CONFIGURE_ARGS+= --with-dlz-filesystem=yes
.endif
.if defined(WITH_DLZ_STUB)
CONFIGURE_ARGS+= --with-dlz-stub=yes
.endif
# Has to be after the DLZ_MYSQL option
.if !defined(WITHOUT_THREADS)
CONFIGURE_ARGS+= --enable-threads
.else
CONFIGURE_ARGS+= --disable-threads
.endif
.if defined(WITH_REPLACE_BASE)
PKGNAMESUFFIX= -base
PREFIX= /usr
BIND_DESTETC= /etc/namedb
CONFIGURE_ARGS+= --prefix=${PREFIX} \
--sysconfdir=${BIND_DESTETC}
.else
BIND_DESTETC= ${PREFIX}/etc
.endif
PLIST_SUB+= BIND_DESTETC="${BIND_DESTETC}"
MAN1= dig.1 host.1 isc-config.sh.1 nslookup.1 nsupdate.1
MAN3= lwres.3 lwres_addr_parse.3 lwres_buffer.3 lwres_buffer_add.3 \
lwres_buffer_back.3 lwres_buffer_clear.3 lwres_buffer_first.3 \
lwres_buffer_forward.3 lwres_buffer_getmem.3 lwres_buffer_getuint16.3 \
lwres_buffer_getuint32.3 lwres_buffer_getuint8.3 lwres_buffer_init.3 \
lwres_buffer_invalidate.3 lwres_buffer_putmem.3 \
lwres_buffer_putuint16.3 lwres_buffer_putuint32.3 \
lwres_buffer_putuint8.3 lwres_buffer_subtract.3 lwres_conf_clear.3 \
lwres_conf_get.3 lwres_conf_init.3 lwres_conf_parse.3 \
lwres_conf_print.3 lwres_config.3 lwres_context.3 \
lwres_context_allocmem.3 lwres_context_create.3 \
lwres_context_destroy.3 lwres_context_freemem.3 \
lwres_context_initserial.3 lwres_context_nextserial.3 \
lwres_context_sendrecv.3 lwres_endhostent.3 lwres_endhostent_r.3 \
lwres_freeaddrinfo.3 lwres_freehostent.3 lwres_gabn.3 \
lwres_gabnrequest_free.3 lwres_gabnrequest_parse.3 \
lwres_gabnrequest_render.3 lwres_gabnresponse_free.3 \
lwres_gabnresponse_parse.3 lwres_gabnresponse_render.3 \
lwres_gai_strerror.3 lwres_getaddrinfo.3 lwres_getaddrsbyname.3 \
lwres_gethostbyaddr.3 lwres_gethostbyaddr_r.3 lwres_gethostbyname.3 \
lwres_gethostbyname2.3 lwres_gethostbyname_r.3 lwres_gethostent.3 \
lwres_gethostent_r.3 lwres_getipnode.3 lwres_getipnodebyaddr.3 \
lwres_getipnodebyname.3 lwres_getnamebyaddr.3 lwres_getnameinfo.3 \
lwres_getrrsetbyname.3 lwres_gnba.3 lwres_gnbarequest_free.3 \
lwres_gnbarequest_parse.3 lwres_gnbarequest_render.3 \
lwres_gnbaresponse_free.3 lwres_gnbaresponse_parse.3 \
lwres_gnbaresponse_render.3 lwres_herror.3 lwres_hstrerror.3 \
lwres_inetntop.3 lwres_lwpacket_parseheader.3 \
lwres_lwpacket_renderheader.3 lwres_net_ntop.3 lwres_noop.3 \
lwres_nooprequest_free.3 lwres_nooprequest_parse.3 \
lwres_nooprequest_render.3 lwres_noopresponse_free.3 \
lwres_noopresponse_parse.3 lwres_noopresponse_render.3 \
lwres_packet.3 lwres_resutil.3 lwres_sethostent.3 \
lwres_sethostent_r.3 lwres_string_parse.3
MAN5= named.conf.5 rndc.conf.5
MAN8= dnssec-keygen.8 dnssec-signzone.8 lwresd.8 named-checkconf.8 \
named-checkzone.8 named.8 rndc-confgen.8 rndc.8
MLINKS= named-checkzone.8 named-compilezone.8
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
post-patch:
.for FILE in check/named-checkconf.8 named/named.8 nsupdate/nsupdate.1 \
rndc/rndc.8
@${MV} ${WRKSRC}/bin/${FILE} ${WRKSRC}/bin/${FILE}.Dist
@${SED} -e 's#/etc/named.conf#${BIND_DESTETC}/named.conf#g' \
-e 's#/etc/rndc.conf#${BIND_DESTETC}/rndc.conf#g' \
${WRKSRC}/bin/${FILE}.Dist > ${WRKSRC}/bin/${FILE}
.endfor
PKGINSTALL= ${.CURDIR}/../bind97/pkg-install
post-install:
${INSTALL_DATA} ${WRKSRC}/bin/rndc/rndc.conf \
${BIND_DESTETC}/rndc.conf.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}/arm ${DOCSDIR}/misc
${INSTALL_DATA} ${WRKSRC}/doc/arm/*.html ${DOCSDIR}/arm
${INSTALL_DATA} ${WRKSRC}/doc/arm/Bv9ARM.pdf ${DOCSDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/misc/[a-z]* ${DOCSDIR}/misc
${CP} ${WRKSRC}/CHANGES ${WRKSRC}/COPYRIGHT ${WRKSRC}/FAQ \
${WRKSRC}/README ${WRKSRC}/README.idnkit \
${DOCSDIR}/
.endif
.if !defined(WITHOUT_LINKS) && !defined(WITH_REPLACE_BASE)
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,4 +0,0 @@
SHA256 (bind-9.5.2-P4.tar.gz) = 2ff8dd299947fce68b687f2e203c3731a7fc5a3f8120263def0ca882deb7d0a9
SIZE (bind-9.5.2-P4.tar.gz) = 6678015
SHA256 (bind-9.5.2-P4.tar.gz.asc) = 690ab49229f9e8e8d15f1e5c5f80822a9d381e949f46217eac05320b44aaaf5b
SIZE (bind-9.5.2-P4.tar.gz.asc) = 481

View File

@ -1,19 +0,0 @@
--- bin/dig/dighost.c.orig 2009-06-23 20:42:32.000000000 -0700
+++ bin/dig/dighost.c 2009-11-07 11:10:12.000000000 -0800
@@ -2606,10 +2606,12 @@
if (sevent->result == ISC_R_CANCELED) {
debug("in cancel handler");
- isc_socket_detach(&query->sock);
- sockcount--;
- INSIST(sockcount >= 0);
- debug("sockcount=%d", sockcount);
+ if (query->sock != NULL) {
+ isc_socket_detach(&query->sock);
+ sockcount--;
+ INSIST(sockcount >= 0);
+ debug("sockcount=%d", sockcount);
+ }
query->waiting_connect = ISC_FALSE;
isc_event_free(&event);
l = query->lookup;

View File

@ -1,24 +0,0 @@
BIND version 9 is a major rewrite of nearly all aspects of the underlying BIND
architecture. Some of the important features of BIND 9 are:
DNS Security: DNSSEC (signed zones), TSIG (signed DNS requests)
IP version 6: Answers DNS queries on IPv6 sockets, IPv6 resource records (AAAA)
Experimental IPv6 Resolver Library
DNS Protocol Enhancements: IXFR, DDNS, Notify, EDNS0
Improved standards conformance
Views: One server process can provide multiple "views" of the DNS namespace,
e.g. an "inside" view to certain clients, and an "outside" view to others.
Multiprocessor Support, including working threads in this version
BIND 9.5 has a number of new features over previous versions, including:
GSS-TSIG support (RFC 3645), DHCID support
Experimental http server and statistics support for named via xml
More detailed statistics counters, compatible with the ones supported in BIND 8
Faster ACL processing
Efficient LRU cache cleaning mechanism.
NSID support (RFC 5001).
WWW: https://www.isc.org/software/bind
- Doug Barton
DougB@FreeBSD.org

View File

@ -1,18 +0,0 @@
*************************************************************************
* _ _____ _____ _____ _ _ _____ ___ ___ _ _ *
* / \|_ _|_ _| ____| \ | |_ _|_ _/ _ \| \ | | *
* / _ \ | | | | | _| | \| | | | | | | | | \| | *
* / ___ \| | | | | |___| |\ | | | | | |_| | |\ | *
* /_/ \_\_| |_| |_____|_| \_| |_| |___\___/|_| \_| *
* *
* If you are running BIND 9 in a chroot environment, make *
* sure that there is a /dev/random device in the chroot. *
* *
* BIND 9 also requires configuration of rndc, including a *
* "secret" key. The easiest, and most secure way to configure *
* rndc is to run 'rndc-confgen -a' to generate the proper conf *
* file, with a new random key, and appropriate file permissions. *
* *
* The /etc/rc.d/named script in the base will do both for you. *
* *
*************************************************************************

View File

@ -1,258 +0,0 @@
bin/dig
bin/host
bin/isc-config.sh
bin/nslookup
bin/nsupdate
%%LINKS%%etc/named.conf
%%LINKS%%etc/rndc.key
include/bind9/check.h
include/bind9/getaddresses.h
include/bind9/version.h
include/dns/acl.h
include/dns/adb.h
include/dns/byaddr.h
include/dns/cache.h
include/dns/callbacks.h
include/dns/cert.h
include/dns/compress.h
include/dns/db.h
include/dns/dbiterator.h
include/dns/dbtable.h
include/dns/diff.h
include/dns/dispatch.h
include/dns/dlz.h
include/dns/dnssec.h
include/dns/ds.h
include/dns/enumclass.h
include/dns/enumtype.h
include/dns/events.h
include/dns/fixedname.h
include/dns/iptable.h
include/dns/journal.h
include/dns/keyflags.h
include/dns/keytable.h
include/dns/keyvalues.h
include/dns/lib.h
include/dns/log.h
include/dns/master.h
include/dns/masterdump.h
include/dns/message.h
include/dns/name.h
include/dns/ncache.h
include/dns/nsec.h
include/dns/peer.h
include/dns/portlist.h
include/dns/rbt.h
include/dns/rcode.h
include/dns/rdata.h
include/dns/rdataclass.h
include/dns/rdatalist.h
include/dns/rdataset.h
include/dns/rdatasetiter.h
include/dns/rdataslab.h
include/dns/rdatastruct.h
include/dns/rdatatype.h
include/dns/sdlz.h
include/dns/request.h
include/dns/resolver.h
include/dns/result.h
include/dns/rootns.h
include/dns/sdb.h
include/dns/secalg.h
include/dns/secproto.h
include/dns/soa.h
include/dns/ssu.h
include/dns/tcpmsg.h
include/dns/time.h
include/dns/tkey.h
include/dns/tsig.h
include/dns/ttl.h
include/dns/types.h
include/dns/validator.h
include/dns/version.h
include/dns/view.h
include/dns/xfrin.h
include/dns/zone.h
include/dns/zonekey.h
include/dns/zt.h
include/dst/dst.h
include/dst/gssapi.h
include/dst/lib.h
include/dst/result.h
include/isc/app.h
include/isc/assertions.h
include/isc/atomic.h
include/isc/base64.h
include/isc/bitstring.h
include/isc/boolean.h
include/isc/buffer.h
include/isc/bufferlist.h
include/isc/commandline.h
include/isc/condition.h
include/isc/dir.h
include/isc/entropy.h
include/isc/error.h
include/isc/event.h
include/isc/eventclass.h
include/isc/file.h
include/isc/formatcheck.h
include/isc/fsaccess.h
include/isc/hash.h
include/isc/heap.h
include/isc/hex.h
include/isc/hmacmd5.h
include/isc/httpd.h
include/isc/int.h
include/isc/interfaceiter.h
include/isc/lang.h
include/isc/lex.h
include/isc/lfsr.h
include/isc/lib.h
include/isc/list.h
include/isc/log.h
include/isc/magic.h
include/isc/md5.h
include/isc/mem.h
include/isc/msgcat.h
include/isc/msgs.h
include/isc/mutex.h
include/isc/mutexblock.h
include/isc/net.h
include/isc/netaddr.h
include/isc/netdb.h
include/isc/offset.h
include/isc/once.h
include/isc/ondestroy.h
include/isc/os.h
include/isc/parseint.h
include/isc/platform.h
include/isc/print.h
include/isc/quota.h
include/isc/radix.h
include/isc/random.h
include/isc/ratelimiter.h
include/isc/refcount.h
include/isc/region.h
include/isc/resource.h
include/isc/result.h
include/isc/resultclass.h
include/isc/rwlock.h
include/isc/serial.h
include/isc/sha1.h
include/isc/sha2.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stdio.h
include/isc/stdlib.h
include/isc/stdtime.h
include/isc/string.h
include/isc/symtab.h
include/isc/syslog.h
include/isc/task.h
include/isc/taskpool.h
include/isc/thread.h
include/isc/time.h
include/isc/timer.h
include/isc/types.h
include/isc/util.h
include/isc/version.h
include/isc/xml.h
include/isccc/alist.h
include/isccc/base64.h
include/isccc/cc.h
include/isccc/ccmsg.h
include/isccc/events.h
include/isccc/lib.h
include/isccc/result.h
include/isccc/sexpr.h
include/isccc/symtab.h
include/isccc/symtype.h
include/isccc/types.h
include/isccc/util.h
include/isccc/version.h
include/isccfg/aclconf.h
include/isccfg/cfg.h
include/isccfg/grammar.h
include/isccfg/log.h
include/isccfg/namedconf.h
include/isccfg/version.h
include/lwres/context.h
include/lwres/int.h
include/lwres/ipv6.h
include/lwres/lang.h
include/lwres/list.h
include/lwres/lwbuffer.h
include/lwres/lwpacket.h
include/lwres/lwres.h
include/lwres/net.h
include/lwres/netdb.h
include/lwres/platform.h
include/lwres/result.h
include/lwres/version.h
lib/libbind9.a
lib/libdns.a
lib/libisc.a
lib/libisccc.a
lib/libisccfg.a
lib/liblwres.a
sbin/dnssec-keygen
sbin/dnssec-signzone
sbin/lwresd
sbin/named
sbin/named-checkconf
sbin/named-checkzone
sbin/named-compilezone
sbin/rndc
sbin/rndc-confgen
%%PORTDOCS%%%%DOCSDIR%%/Bv9ARM.pdf
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.idnkit
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch01.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch02.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch03.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch04.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch05.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch06.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch07.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch08.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch09.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.ch10.html
%%PORTDOCS%%%%DOCSDIR%%/arm/Bv9ARM.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.dig.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-keygen.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.dnssec-signzone.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.host.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkconf.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.named-checkzone.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.named.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc-confgen.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.conf.html
%%PORTDOCS%%%%DOCSDIR%%/arm/man.rndc.html
%%PORTDOCS%%%%DOCSDIR%%/misc/dnssec
%%PORTDOCS%%%%DOCSDIR%%/misc/format-options.pl
%%PORTDOCS%%%%DOCSDIR%%/misc/ipv6
%%PORTDOCS%%%%DOCSDIR%%/misc/migration
%%PORTDOCS%%%%DOCSDIR%%/misc/migration-4to9
%%PORTDOCS%%%%DOCSDIR%%/misc/options
%%PORTDOCS%%%%DOCSDIR%%/misc/rfc-compliance
%%PORTDOCS%%%%DOCSDIR%%/misc/roadmap
%%PORTDOCS%%%%DOCSDIR%%/misc/sdb
%%PORTDOCS%%%%DOCSDIR%%/misc/sort-options.pl
%%PORTDOCS%%@dirrm %%DOCSDIR%%/arm
%%PORTDOCS%%@dirrm %%DOCSDIR%%/misc
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%LINKS%%@unexec rm -f /var/named/%D/etc/named.conf
%%LINKS%%@unexec rm -f /var/named/%D/etc/rndc.key
%%LINKS%%@unexec rm -rf /var/named/%D
%%LINKS%%@unexec rmdir /var/named/usr 2>/dev/null || true
@unexec rm -f %%BIND_DESTETC%%/rndc.conf.sample
@dirrm include/bind9
@dirrm include/dns
@dirrm include/dst
@dirrmtry include/isc
@dirrm include/isccc
@dirrm include/isccfg
@dirrm include/lwres