Movit is the Modern Video Toolkit, notwithstanding that anything

that's called "modern" usually isn't, and it's really not a toolkit.

Movit aims to be a _high-quality_, _high-performance_, _open-source_
library for video filters.

WWW: https://movit.sesse.net
This commit is contained in:
Alberto Villa 2016-12-23 02:35:32 +00:00
parent dd24078860
commit cd6aad30b4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=429213
7 changed files with 173 additions and 0 deletions

View File

@ -600,6 +600,7 @@
SUBDIR += mirage
SUBDIR += mitsuba
SUBDIR += mmrecover
SUBDIR += movit
SUBDIR += mozjpeg
SUBDIR += mscgen
SUBDIR += mtpaint

44
graphics/movit/Makefile Normal file
View File

@ -0,0 +1,44 @@
# $FreeBSD$
PORTNAME= movit
PORTVERSION= 1.4.0
CATEGORIES= graphics
MASTER_SITES= http://${PORTNAME}.sesse.net/
MAINTAINER= avilla@FreeBSD.org
COMMENT= High-performance video filters for the GPU
LICENSE= GPLv2+
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libfftw3.so:math/fftw3
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen3.pc:math/eigen3
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= autoreconf gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
PORTDOCS= NEWS README
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e '/AC_INIT/ s/git/${PORTVERSION}/' \
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e '/^all/ s/$$(TESTS)//' \
${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e '/features\.h/ d' \
${WRKSRC}/demo.cpp
post-install:
.if ${PORT_OPTIONS:MDOCS}
. for f in ${PORTDOCS}
cd ${WRKSRC} && ${COPYTREE_SHARE} ${f} ${STAGEDIR}${DOCSDIR}
. endfor
.endif
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib${PORTNAME}.so.*
.include <bsd.port.mk>

3
graphics/movit/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1482449930
SHA256 (movit-1.4.0.tar.gz) = cc6bbcd0c907f47cfa7bb3401a30bda849e6a0de2a3ed5c895badbc116d51512
SIZE (movit-1.4.0.tar.gz) = 578195

View File

@ -0,0 +1,11 @@
--- configure.ac.orig 2016-11-05 10:46:12 UTC
+++ configure.ac
@@ -17,7 +17,7 @@ PKG_CHECK_MODULES([FFTW3], [fftw3])
with_SDL2=no
with_demo_app=yes
PKG_CHECK_MODULES([SDL2], [sdl2], [with_SDL2=yes], [
- PKG_CHECK_MODULES([SDL], [sdl])
+ PKG_CHECK_MODULES([SDL], [sdl], [], [x=x])
])
# These are only needed for the demo app.

View File

@ -0,0 +1,14 @@
--- movit.pc.in.orig 2016-11-05 10:46:12 UTC
+++ movit.pc.in
@@ -10,9 +10,9 @@ shaderdir=@datadir@/movit
Name: movit
Description: Movit is a library for high-quality, high-performance video filters.
-Version: git
+Version: @PACKAGE_VERSION@
Requires: epoxy eigen3
Requires.private: fftw3
Conflicts:
-Libs: -lmovit
+Libs: -L${libdir} -lmovit
Cflags: -I${includedir}/movit

7
graphics/movit/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
Movit is the Modern Video Toolkit, notwithstanding that anything
that's called "modern" usually isn't, and it's really not a toolkit.
Movit aims to be a _high-quality_, _high-performance_, _open-source_
library for video filters.
WWW: https://movit.sesse.net

93
graphics/movit/pkg-plist Normal file
View File

@ -0,0 +1,93 @@
include/movit/alpha_division_effect.h
include/movit/alpha_multiplication_effect.h
include/movit/blur_effect.h
include/movit/colorspace_conversion_effect.h
include/movit/complex_modulate_effect.h
include/movit/deconvolution_sharpen_effect.h
include/movit/defs.h
include/movit/deinterlace_effect.h
include/movit/diffusion_effect.h
include/movit/dither_effect.h
include/movit/effect.h
include/movit/effect_chain.h
include/movit/effect_util.h
include/movit/fft_convolution_effect.h
include/movit/fft_input.h
include/movit/fft_pass_effect.h
include/movit/flat_input.h
include/movit/fp16.h
include/movit/gamma_compression_effect.h
include/movit/gamma_expansion_effect.h
include/movit/glow_effect.h
include/movit/image_format.h
include/movit/init.h
include/movit/input.h
include/movit/lift_gamma_gain_effect.h
include/movit/luma_mix_effect.h
include/movit/mirror_effect.h
include/movit/mix_effect.h
include/movit/multiply_effect.h
include/movit/overlay_effect.h
include/movit/padding_effect.h
include/movit/resample_effect.h
include/movit/resize_effect.h
include/movit/resource_pool.h
include/movit/sandbox_effect.h
include/movit/saturation_effect.h
include/movit/slice_effect.h
include/movit/unsharp_mask_effect.h
include/movit/util.h
include/movit/version.h
include/movit/vignette_effect.h
include/movit/white_balance_effect.h
include/movit/ycbcr.h
include/movit/ycbcr_422interleaved_input.h
include/movit/ycbcr_conversion_effect.h
include/movit/ycbcr_input.h
lib/libmovit.a
lib/libmovit.so
lib/libmovit.so.5
lib/libmovit.so.5.0.0
libdata/pkgconfig/movit.pc
%%DATADIR%%/alpha_division_effect.frag
%%DATADIR%%/alpha_multiplication_effect.frag
%%DATADIR%%/blur_effect.frag
%%DATADIR%%/colorspace_conversion_effect.frag
%%DATADIR%%/complex_modulate_effect.frag
%%DATADIR%%/deconvolution_sharpen_effect.frag
%%DATADIR%%/deinterlace_effect.frag
%%DATADIR%%/dither_effect.frag
%%DATADIR%%/fft_pass_effect.frag
%%DATADIR%%/flat_input.frag
%%DATADIR%%/footer.frag
%%DATADIR%%/gamma_compression_effect.frag
%%DATADIR%%/gamma_expansion_effect.frag
%%DATADIR%%/header.130.frag
%%DATADIR%%/header.150.frag
%%DATADIR%%/header.300es.frag
%%DATADIR%%/highlight_cutoff_effect.frag
%%DATADIR%%/identity.frag
%%DATADIR%%/lift_gamma_gain_effect.frag
%%DATADIR%%/luma_mix_effect.frag
%%DATADIR%%/mirror_effect.frag
%%DATADIR%%/mix_effect.frag
%%DATADIR%%/multiply_effect.frag
%%DATADIR%%/overlay_effect.frag
%%DATADIR%%/overlay_matte_effect.frag
%%DATADIR%%/padding_effect.frag
%%DATADIR%%/resample_effect.frag
%%DATADIR%%/sandbox_effect.frag
%%DATADIR%%/saturation_effect.frag
%%DATADIR%%/slice_effect.frag
%%DATADIR%%/texture1d.130.frag
%%DATADIR%%/texture1d.150.frag
%%DATADIR%%/texture1d.300es.frag
%%DATADIR%%/vignette_effect.frag
%%DATADIR%%/vs.130.vert
%%DATADIR%%/vs.150.vert
%%DATADIR%%/vs.300es.vert
%%DATADIR%%/vs.vert
%%DATADIR%%/white_balance_effect.frag
%%DATADIR%%/ycbcr_422interleaved_input.frag
%%DATADIR%%/ycbcr_conversion_effect.frag
%%DATADIR%%/ycbcr_input.frag