- Update to 0.4.0

PR:		118621
Submitted by:	KATO Tsuguru <tkato432@yahoo.com>
This commit is contained in:
Martin Wilke 2007-12-14 16:50:53 +00:00
parent 485887847e
commit cd48a869e8
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203556
7 changed files with 13 additions and 63 deletions

View File

@ -6,30 +6,28 @@
#
PORTNAME= qcomicbook
PORTVERSION= 0.3.4
PORTREVISION= 2
PORTVERSION= 0.4.0
CATEGORIES= graphics
MASTER_SITES= http://linux.bydg.org/~yogin/
MASTER_SITES= http://linux.bydg.org/~yogin/qcomicbook/
MAINTAINER= ports@FreeBSD.org
COMMENT= QT-based comic book archive viewer
LIB_DEPENDS= Imlib2.4:${PORTSDIR}/graphics/imlib2
RUN_DEPENDS= unzip:${PORTSDIR}/archivers/unzip \
unrar:${PORTSDIR}/archivers/unrar
USE_X_PREFIX= yes
USE_QT_VER= 3
USE_QT_VER= 4
QT_COMPONENTS= gui moc
USE_GNOME= gnometarget
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-Qt-dir="${QT_PREFIX}"
CONFIGURE_ENV= QtGui_CFLAGS="${QtGui_CFLAGS}"
MAN1= qcomicbook.1
# Luckily, QT apps on FreeBSD don't compile against
# pthread by default. That might *gasp* make them work!
QTCPPFLAGS+= ${PTHREAD_CFLAGS}
QTCFGLIBS+= ${PTHREAD_LIBS}
QtGui_CFLAGS= -DQT_SHARED \
-I${QT_PREFIX}/include/QtGui \
-I${QT_PREFIX}/include/QtCore \
-I${QT_PREFIX}/include
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (qcomicbook-0.3.4.tar.gz) = f93f29e0635f8fe64f036bf654050438
SHA256 (qcomicbook-0.3.4.tar.gz) = 7accb599b05b5d5a52b66dde1f3cbb41af8eac8d5bdce0d637f06d348cfdb6a9
SIZE (qcomicbook-0.3.4.tar.gz) = 384681
MD5 (qcomicbook-0.4.0.tar.gz) = a0ef74e5478d66e3538a362ec691999d
SHA256 (qcomicbook-0.4.0.tar.gz) = d6f07803f543d8597378df8c3f6e3ff186d7b7c022178dbdd6185d77ad07eb3b
SIZE (qcomicbook-0.4.0.tar.gz) = 363715

View File

@ -1,11 +0,0 @@
--- configure.orig Thu Jul 6 01:52:40 2006
+++ configure Thu Jul 6 01:53:18 2006
@@ -5822,7 +5822,7 @@
}
EOF
- bnv_cv_qt_test_result="failure"
+ bnv_cv_qt_test_result=""
bnv_try_1="$QT_MOC bnv_qt_test.h -o moc_bnv_qt_test.$ac_ext >/dev/null 2>/dev/null"
{ (eval echo "$as_me:$LINENO: \"$bnv_try_1\"") >&5
(eval $bnv_try_1) 2>&5

View File

@ -1,10 +0,0 @@
--- src/thumbnail.cpp.orig Sat Apr 2 19:59:03 2005
+++ src/thumbnail.cpp Fri May 20 00:51:33 2005
@@ -11,6 +11,7 @@
*/
#include "thumbnail.h"
+#include <sys/types.h>
#include <utime.h>
int Thumbnail::thwidth = 100;

View File

@ -1,10 +0,0 @@
--- src/imgarchiver.cpp.orig Tue Aug 15 20:51:05 2006
+++ src/imgarchiver.cpp Sun Aug 27 20:12:00 2006
@@ -13,6 +13,7 @@
#include "imgarchiver.h"
#include <qprocess.h>
#include <qapplication.h>
+#include <unistd.h>
using namespace QComicBook;

View File

@ -1,10 +0,0 @@
--- src/imgdirsink.cpp.orig Thu Aug 24 03:07:06 2006
+++ src/imgdirsink.cpp Sun Aug 27 20:14:19 2006
@@ -404,6 +404,6 @@
for (int i=0; imgext[i]; i++)
if (path.endsWith(imgext[i], false))
return imgext[i];
- return false;
+ return QString::null;
}

View File

@ -5,11 +5,6 @@ bin/qcomicbook
%%DATADIR%%/fforward.png
%%DATADIR%%/fitheight.png
%%DATADIR%%/fitwidth.png
%%DATADIR%%/help/en/index.html
%%DATADIR%%/help/en/internals.html
%%DATADIR%%/help/en/intro.html
%%DATADIR%%/help/en/keyboard.html
%%DATADIR%%/help/en/menu.html
%%DATADIR%%/info.png
%%DATADIR%%/japanese.png
%%DATADIR%%/nextpage.png
@ -27,6 +22,4 @@ bin/qcomicbook
%%DATADIR%%/thumbnails.png
%%DATADIR%%/twopages.png
%%DATADIR%%/wholepage.png
@dirrm %%DATADIR%%/help/en
@dirrm %%DATADIR%%/help
@dirrm %%DATADIR%%