Make those ports more likely to build with texinfo from ports

With hat:	portmgr
This commit is contained in:
Antoine Brodin 2014-07-01 17:37:41 +00:00
parent 9426d28e77
commit cd419fd1df
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=360062
16 changed files with 28 additions and 12 deletions

View File

@ -28,6 +28,6 @@ post-patch:
@${REINPLACE_CMD} '24,27d' ${WRKSRC}/configure
post-install:
@${RM} ${STAGEDIR}${PREFIX}/info/dir
@-${RM} ${STAGEDIR}${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -12,7 +12,7 @@ COMMENT= The Emacs Multi-Media System
LICENSE= GPLv3
USES= gmake
USES= gmake makeinfo
USE_EMACS= yes
MAKE_ENV+= EMMSPREFIX=${STAGEDIR}${PREFIX} LOCALBASE=${LOCALBASE} \
EMACS_SITE_LISPDIR=${EMACS_SITE_LISPDIR}

View File

@ -14,7 +14,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= PlannerMode is an organizer and day planner for Emacs
USE_EMACS= yes
USES= gmake
USES= gmake makeinfo
BUILD_DEPENDS+= ${LOCALBASE}/${EMACS_SITE_LISPDIR}/muse/muse.el:${PORTSDIR}/textproc/muse

View File

@ -1,5 +1,5 @@
--- Makefile.orig 2012-09-25 04:41:19.000000000 +0900
+++ Makefile 2013-09-21 23:01:04.000000000 +0900
--- ./Makefile.orig 2012-09-24 19:41:19.000000000 +0000
+++ ./Makefile 2014-07-01 17:24:01.000000000 +0000
@@ -1,5 +1,5 @@
VERSION=1.2.0
-EMACS=emacs
@ -7,7 +7,16 @@
PREFIX=/usr/local
SYSCONFDIR=/etc
ELS=magit.el magit-svn.el magit-topgit.el magit-stgit.el magit-key-mode.el magit-bisect.el magit-wip.el rebase-mode.el magit-blame.el
@@ -64,15 +64,13 @@
@@ -40,7 +40,7 @@
magit.elc: magit.el
dir: magit.info
- install-info --dir=$@ $<
+ touch $@
magit.info:
@@ -64,15 +64,12 @@
install: install_core install_docs
install_core: core
@ -24,7 +33,6 @@
- install-info --info-dir=$(DESTDIR)$(PREFIX)/share/info $(DESTDIR)$(PREFIX)/share/info/magit.info
+ mkdir -p $(INFODIR)
+ install -m 644 magit.info $(INFODIR)
+ install-info --info-dir=$(INFODIR) $(INFODIR)/magit.info
install_contrib: contrib
mkdir -p $(DESTDIR)$(PREFIX)/share/emacs/site-lisp

View File

@ -23,7 +23,7 @@ LISPDIR= ${STAGEDIR}${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME}
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --with-emacs=${EMACS_NAME} --with-diff=gdiff --with-patch=gpatch
USES= gmake
USES= gmake makeinfo
INFO= xtla
OPTIONS_DEFINE= DOCS

View File

@ -9,7 +9,7 @@ MASTER_SITES= https://codeload.github.com/slime/slime/legacy.tar.gz/v${PORTVERSI
MAINTAINER= joe@thrallingpenguin.com
COMMENT= Superior Lisp Interaction Mode for Emacs
USES= gmake
USES= gmake makeinfo
USE_EMACS= yes
SLIME_LISPDIR= ${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/slime

View File

@ -26,6 +26,7 @@ DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
PLIST_SUB= TARGET="${CONFIGURE_TARGET}"
.if !defined(NOPORTDOCS)
USES= makeinfo
INFO= gauche-gl-refe gauche-gl-refj
.endif

View File

@ -13,7 +13,7 @@ LICENSE= LGPL21
RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
USES= libtool motif tar:bzip2
USES= libtool makeinfo motif tar:bzip2
USE_GL= glu
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-htmlbrowser=xdg-open --with-pdfviewer=xdg-open \
@ -38,7 +38,7 @@ post-patch:
${WRKSRC}/src/bin/geomview/x11/Makefile.in
post-build:
@(cd ${WRKSRC}/doc && /usr/bin/makeinfo --no-split --no-validate \
@(cd ${WRKSRC}/doc && makeinfo --no-split --no-validate \
-o geomview.info geomview.texi)
post-install:

View File

@ -14,7 +14,7 @@ COMMENT= A mail reader running inside Emacs or XEmacs
GNU_CONFIGURE= yes
USE_EMACS= yes
USES= gmake
USES= gmake makeinfo
CONFIGURE_ARGS+= --with-emacs=${EMACS_CMD}
MAKE_ARGS= prefix=${PREFIX} \
lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/${PORTNAME} \

View File

@ -23,6 +23,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
USES+= makeinfo
INFO= ess
.endif

View File

@ -23,6 +23,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
USES+= makeinfo
USE_TEX+= pdftex:build
PORTDOCS= de.pdf fr.pdf
INFO= eukleides

View File

@ -13,6 +13,7 @@ COMMENT= Binkley-style outbound netmail packer
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
USES= makeinfo
MAN1= bsopack.1
MANCOMPRESSED= yes
INFO= bsopack

View File

@ -22,6 +22,7 @@ USES= perl5
MAKE_ARGS+= PERL=0
.endif
USES+= makeinfo
MAN1= hpt.1 hptlink.1 hpttree.1 txt2pkt.1
MANCOMPRESSED= yes
INFO= hpt

View File

@ -13,6 +13,7 @@ COMMENT= Scan for UUE in message base
LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
USES= makeinfo
MAN1= hpucode.1
MANCOMPRESSED= yes
INFO= hpucode

View File

@ -15,6 +15,7 @@ LIB_DEPENDS= fidoconfig.0:${PORTSDIR}/news/husky-fidoconf
CONFLICTS= husky-htick-devel-[0-9]*
USES= makeinfo
MAN1= htick.1
INFO= htick

View File

@ -14,6 +14,7 @@ COMMENT= Msged/TE (full-featured FTN mail reader)
LIB_DEPENDS= libfidoconfig.so:${PORTSDIR}/news/husky-fidoconf
USES= makeinfo
MAKE_ARGS= MSGEDCFG="\\\"~/.msged\\\""
INFO= msged