irc/weechat: Update to 2.9
* Fix REINPLACE_CMD warnings
This commit is contained in:
parent
f2cfaf9f52
commit
cd32065868
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=542549
@ -2,7 +2,7 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= weechat
|
||||
DISTVERSION= 2.8
|
||||
DISTVERSION= 2.9
|
||||
CATEGORIES= irc
|
||||
MASTER_SITES= https://weechat.org/files/src/
|
||||
|
||||
@ -14,16 +14,17 @@ LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS+= libcurl.so:ftp/curl \
|
||||
libgcrypt.so:security/libgcrypt \
|
||||
libgnutls.so:security/gnutls \
|
||||
libgpg-error.so:security/libgpg-error
|
||||
|
||||
USES= cmake ncurses libtool tar:xz
|
||||
USES= cmake ncurses libtool pkgconfig tar:xz
|
||||
USE_LDCONFIG= yes
|
||||
|
||||
CMAKE_ARGS= -DLIBDATADIR=${LOCALBASE}/libdata
|
||||
|
||||
OPTIONS_DEFINE= BACKTRACE DOCS CA_BUNDLE GNUTLS HEADLESS ICON ICONV \
|
||||
OPTIONS_DEFINE= BACKTRACE DOCS CA_BUNDLE HEADLESS ICON ICONV \
|
||||
MANPAGES NLS
|
||||
OPTIONS_DEFAULT= ASPELL BACKTRACE CA_BUNDLE CHARSET GNUTLS HEADLESS \
|
||||
OPTIONS_DEFAULT= ASPELL BACKTRACE CA_BUNDLE CHARSET HEADLESS \
|
||||
ICON LUA MANPAGES PERL PYTHON RUBY TCL
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
@ -55,8 +56,6 @@ CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root
|
||||
CHARSET_IMPLIES= ICONV
|
||||
DOCS_CMAKE_BOOL= ENABLE_DOC
|
||||
DOCS_BUILD_DEPENDS= ${LOCALBASE}/bin/asciidoctor:textproc/rubygem-asciidoctor
|
||||
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
|
||||
GNUTLS_USES= pkgconfig
|
||||
GUILE_LIB_DEPENDS= libguile-2.2.so:lang/guile2
|
||||
GUILE_CMAKE_BOOL= ENABLE_GUILE
|
||||
ICONV_USES= iconv
|
||||
@ -82,12 +81,11 @@ CMAKE_ARGS+= -DENABLE_PYTHON2:BOOL=true \
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's|$${LIBDIR}/../pkgconfig|$${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig|' \
|
||||
${WRKSRC}/CMakeLists.txt
|
||||
.for f in src/CMakeLists.txt src/core/CMakeLists.txt cmake/*.cmake
|
||||
@${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' \
|
||||
${WRKSRC}/${f}
|
||||
.endfor
|
||||
.if ${LOCALBASE} != "/usr/local"
|
||||
. for f in src/core/CMakeLists.txt cmake/*.cmake
|
||||
@${REINPLACE_CMD} 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/$f
|
||||
. endfor
|
||||
.endif
|
||||
@${REINPLACE_CMD} 's|python${PYTHON_MAJOR_VER}|python-${PYTHON_VER}|' \
|
||||
${WRKSRC}/cmake/FindPython.cmake
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
TIMESTAMP = 1585485484
|
||||
SHA256 (weechat-2.8.tar.xz) = 553ea295edad3b03cf88e6029c21e7bde32ff1cc026d35386ba9da3e56a6018c
|
||||
SIZE (weechat-2.8.tar.xz) = 2248868
|
||||
TIMESTAMP = 1595146022
|
||||
SHA256 (weechat-2.9.tar.xz) = eab406c385c3a10d0107ddc3aac6596ae8c59af99e9158c6d769e90ec9adfa0e
|
||||
SIZE (weechat-2.9.tar.xz) = 2206584
|
||||
|
@ -1,18 +1,7 @@
|
||||
--- CMakeLists.txt.orig 2019-06-06 18:43:20 UTC
|
||||
--- CMakeLists.txt.orig 2020-07-07 18:29:03 UTC
|
||||
+++ CMakeLists.txt
|
||||
@@ -66,6 +66,10 @@ if(NOT DEFINED WEECHAT_LIBDIR)
|
||||
set(WEECHAT_LIBDIR ${LIBDIR}/${PROJECT_NAME})
|
||||
endif()
|
||||
|
||||
+if(NOT DEFINED LIBDATADIR)
|
||||
+ set (LIBDATADIR ${CMAKE_INSTALL_PREFIX}/lib)
|
||||
+endif()
|
||||
+
|
||||
if(NOT DEFINED SHAREDIR)
|
||||
set(SHAREDIR ${CMAKE_INSTALL_PREFIX}/share)
|
||||
endif()
|
||||
@@ -90,11 +94,13 @@ option(ENABLE_NLS "Enable Native Language Su
|
||||
option(ENABLE_GNUTLS "Enable SSLv3/TLS support" ON)
|
||||
@@ -93,11 +97,13 @@ option(ENABLE_HEADLESS "Compile the headless bina
|
||||
option(ENABLE_NLS "Enable Native Language Support" ON)
|
||||
option(ENABLE_LARGEFILE "Enable Large File Support" ON)
|
||||
option(ENABLE_ALIAS "Enable Alias plugin" ON)
|
||||
+option(ENABLE_BACKTRACE "Enable backtraces (via libexecinfo)" ON)
|
||||
@ -25,7 +14,7 @@
|
||||
option(ENABLE_IRC "Enable IRC plugin" ON)
|
||||
option(ENABLE_LOGGER "Enable Logger plugin" ON)
|
||||
option(ENABLE_RELAY "Enable Relay plugin" ON)
|
||||
@@ -186,6 +192,7 @@ endif()
|
||||
@@ -195,6 +201,7 @@ endif()
|
||||
# Check for libgcrypt
|
||||
find_package(GCRYPT REQUIRED)
|
||||
add_definitions(-DHAVE_GCRYPT)
|
||||
@ -33,7 +22,7 @@
|
||||
list(APPEND EXTRA_LIBS ${GCRYPT_LDFLAGS})
|
||||
|
||||
# Check for GnuTLS
|
||||
@@ -204,10 +211,12 @@ endif()
|
||||
@@ -208,10 +215,12 @@ list(APPEND EXTRA_LIBS gnutls)
|
||||
find_package(ZLIB REQUIRED)
|
||||
add_definitions(-DHAVE_ZLIB)
|
||||
|
||||
@ -50,7 +39,7 @@
|
||||
endif()
|
||||
|
||||
# Check for CURL
|
||||
@@ -266,7 +275,7 @@ set(exec_prefix "\${prefix}")
|
||||
@@ -280,7 +289,7 @@ set(exec_prefix "\${prefix}")
|
||||
string(REPLACE "${CMAKE_INSTALL_PREFIX}" "\${prefix}" libdir "${LIBDIR}")
|
||||
set(includedir "\${prefix}/include")
|
||||
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/weechat.pc.in ${CMAKE_CURRENT_BINARY_DIR}/weechat.pc @ONLY)
|
||||
|
Loading…
Reference in New Issue
Block a user