finance/py-stripe: Update to 2.28.0

Changelog:

  https://github.com/stripe/stripe-python/blob/v2.28.0/CHANGELOG.md
This commit is contained in:
Kubilay Kocak 2019-05-18 07:48:03 +00:00
parent 800236defe
commit ccf33088f3
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=501919
3 changed files with 34 additions and 32 deletions

View File

@ -3,7 +3,7 @@
#
PORTNAME= stripe
DISTVERSION= 1.30.0
PORTVERSION= 2.28.0
CATEGORIES= finance python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@ -14,10 +14,10 @@ COMMENT= Stripe Python bindings
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0.8.8:www/py-requests@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycurl>=7.19:ftp/py-pycurl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}unittest2>0:devel/py-unittest2@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.20:www/py-requests@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=3.4:devel/py-pytest@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-mock>=1.7:devel/py-pytest-mock@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytest-xdist>=1.22:devel/py-pytest-xdist@${PY_FLAVOR}
USES= python
USE_PYTHON= autoplist distutils
@ -25,6 +25,14 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
do-test:
@cd ${WRKSRC} && ${SETENV} STRIPE_TEST_PYCURL=yes ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
# requests[security]
.if ${PYTHON_VER} < 3.0
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}openssl>=0.14:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=1.3.4:security/py-cryptography@${PY_FLAVOR}
.endif
.include <bsd.port.post.mk>

View File

@ -1,2 +1,3 @@
SHA256 (stripe-1.30.0.tar.gz) = 90d8c6f6acc9485bae5d106b62c6b09b62eea9d7fb1c8476fb4c85b04777fa3a
SIZE (stripe-1.30.0.tar.gz) = 176841
TIMESTAMP = 1558157705
SHA256 (stripe-2.28.0.tar.gz) = 1036267bbc4c394376bd3f4fc5a7867b7fe3cc1f0c4444b49cdd6929cee36daf
SIZE (stripe-2.28.0.tar.gz) = 204467

View File

@ -1,24 +1,17 @@
--- setup.py.orig 2016-03-03 09:42:16 UTC
# pytest-cov is not a compulsory test dependency
# TODO: Upstream
--- setup.py.orig 2019-04-08 18:44:53 UTC
+++ setup.py
@@ -28,6 +28,11 @@ if sys.version_info < (2, 6):
else:
install_requires.append('requests >= 0.8.8')
+tests_require = [
+ 'unittest2',
+ 'pycurl>=7.19',
+ 'mock',
+]
with open('LONG_DESCRIPTION.rst') as f:
long_description = f.read()
@@ -56,8 +61,8 @@ setup(
packages=['stripe', 'stripe.test', 'stripe.test.resources'],
package_data={'stripe': ['data/ca-certificates.crt']},
install_requires=install_requires,
+ tests_require=tests_require,
test_suite='stripe.test.all',
- tests_require=['unittest2', 'mock'],
use_2to3=True,
classifiers=[
"Development Status :: 5 - Production/Stable",
@@ -54,8 +54,10 @@ setup(
"pytest >= 3.4",
"pytest-mock >= 1.7",
"pytest-xdist >= 1.22",
- "pytest-cov >= 2.5",
],
+ extras_require={
+ 'dev': ['pytest-cov >= 2.5'],
+ },
cmdclass={"test": PyTest},
project_urls={
"Bug Tracker": "https://github.com/stripe/stripe-python/issues",