- Update to bzr revision 104238.

- Update emacs.desktop to launch Emacs in Terminal when WITHOUT_X11 is defined.[1]
- Emacs picks up giflib if available instead of libungif. Account for
  this.[2]

PR:		ports/156167[1]
Submitted by:	Zhihao Yuan <lichray@gmail.com>[1]
	  	Herbert J. Skuhra <h.skuhra@gmail.com>[2] (via private email)
This commit is contained in:
Ashish SHUKLA 2011-05-16 12:14:17 +00:00
parent b62adc8768
commit cc53588749
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=274178
3 changed files with 16 additions and 9 deletions

View File

@ -26,7 +26,7 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
INSTALLS_ICONS= yes
EMACS_VER= 24.0.50
EMACS_REV= 104000
EMACS_REV= 104238
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_XZ= yes
@ -148,7 +148,11 @@ LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
.if defined(WITHOUT_GIF)
CONFIGURE_ARGS+= --without-gif
.else
LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
. if exists(${LOCALBASE}/lib/libgif.so)
LIB_DEPENDS+= gif.5:${PORTSDIR}/graphics/giflib
. else
LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
. endif
.endif
.if defined(WITHOUT_PNG)
@ -241,6 +245,9 @@ BROKEN= Emacs 24.X does not currently build on ia64
post-patch:
@${RM} -f ${WRKSRC}/info/*
@${REINPLACE_CMD} -e "s/%%EMACS_VER%%/${EMACS_VER}/g" -e "s/%%DATADIR%%/${DATADIR:C/\//\\\//g}/g" ${WRKSRC}/sources.el
.if defined(WITHOUT_X11)
@${REINPLACE_CMD} -e 's/^Terminal=.*$$/Terminal=true/' ${WRKSRC}/etc/emacs.desktop
.endif
post-configure:
@${REINPLACE_CMD} -e "s/^\(DBUS_LIBS.*\)-pthread\(.*\)$$/\1$$(${DBUS_PTHREAD_LIBS})\2/" ${WRKSRC}/src/Makefile

View File

@ -1,2 +1,2 @@
SHA256 (emacs-24.0.50.104000.tar.xz) = 6468383e33333a05ab98262508db96348f1928cdeeb9d377fcc20e373207cbb5
SIZE (emacs-24.0.50.104000.tar.xz) = 23265108
SHA256 (emacs-24.0.50.104238.tar.xz) = 7f7ea4ad582360c8f3c9aefe67d1b21dc6801b6e189f69d8cecc4b2db64da9b2
SIZE (emacs-24.0.50.104238.tar.xz) = 23255172

View File

@ -3,7 +3,7 @@ $FreeBSD$
--- Makefile.in.orig
+++ Makefile.in
@@ -509,14 +509,6 @@
@@ -517,14 +517,6 @@
install-arch-indep: mkdir info install-etc
-set ${COPYDESTS} ; \
@ -18,10 +18,10 @@ $FreeBSD$
mkdir ${COPYDESTS} ; \
chmod ugo+rx ${COPYDESTS} ; \
unset CDPATH; \
@@ -616,9 +608,9 @@
@@ -624,9 +616,9 @@
cd ${srcdir}/info ; \
for elt in $(INFO_FILES); do \
test "$(HAVE_MAKEINFO)" = "no" && ! test -e $$elt && continue; \
test "$(HAVE_MAKEINFO)" = "no" && test ! -f $$elt && continue; \
- for f in `ls $$elt $$elt-[1-9] $$elt-[1-9][0-9] 2>/dev/null`; do \
- ${INSTALL_DATA} $$f $(DESTDIR)${infodir}/$$f; \
- chmod a+r $(DESTDIR)${infodir}/$$f; \
@ -31,9 +31,9 @@ $FreeBSD$
if [ -n "${GZIP_INFO}" ] && [ -n "${GZIP_PROG}" ]; then \
rm -f $(DESTDIR)${infodir}/$$f.gz; \
${GZIP_PROG} -9n $(DESTDIR)${infodir}/$$f; \
@@ -633,7 +625,7 @@
@@ -641,7 +633,7 @@
for elt in $(INFO_FILES); do \
test "$(HAVE_MAKEINFO)" = "no" && ! test -e $$elt && continue; \
test "$(HAVE_MAKEINFO)" = "no" && test ! -f $$elt && continue; \
(cd $${thisdir}; \
- ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt); \
+ ${INSTALL_INFO} --info-dir=$(DESTDIR)${infodir} $(DESTDIR)${infodir}/$$elt.info); \