chinese/fcitx: 4.2.8.6 -> 4.2.9.1

PR:		210782
Submitted by:	Iblis Lin <iblis@hs.ntnu.edu.tw>
Approved by:	lichray@gmail.com (maintainer)
This commit is contained in:
Kurt Jaeger 2016-07-09 11:37:36 +00:00
parent 5bf0c4d130
commit cc30a2c7e1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=418269
9 changed files with 48 additions and 41 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fcitx
PORTVERSION= 4.2.8.6
PORTREVISION= 3
PORTVERSION= 4.2.9.1
CATEGORIES= chinese x11
MASTER_SITES= http://download.fcitx-im.org/fcitx/:fcitx \
http://download.fcitx-im.org/data/:data
@ -21,9 +20,15 @@ COMMENT= Flexible Input Method Framework
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libicuuc.so:devel/icu
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
${LOCALBASE}/share/ECM/cmake/ECMConfig.cmake:devel/extra-cmake-modules
LIB_DEPENDS= libcairo.so:graphics/cairo \
libdbus-1.so:devel/dbus \
libicuuc.so:devel/icu \
libXfixes.so:x11/libXfixes \
libXinerama.so:x11/libXinerama \
libXrender.so:x11/libXrender \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= xdg-open:devel/xdg-utils
SUB_FILES= pkg-message
@ -40,9 +45,16 @@ INSTALLS_ICONS= yes
OPTIONS_DEFINE= GTK2 GTK3 QT4 OPENCC TPUNC DOCS
OPTIONS_DEFAULT=GTK2 QT4
OPTIONS_SUB= yes
GTK2_DESC= Enable Gtk2 IM module
GTK2_USE= GNOME=gtk20
GTK2_CMAKE_ON= -DENABLE_GTK2_IM_MODULE=ON
GTK3_DESC= Enable Gtk3 IM module
GTK3_USE= GNOME=gtk30
GTK3_CMAKE_ON= -DENABLE_GTK3_IM_MODULE=ON
QT4_DESC= Enable Qt4 IM module
OPENCC_DESC= Enable OpenCC for Chinese Transform
TPUNC_DESC= Use traditional quotation marks
@ -60,18 +72,12 @@ CMAKE_ARGS+= -DENABLE_XDGAUTOSTART=OFF -DFORCE_ENCHANT=ON \
-DQT_PLUGINS_DIR=${PREFIX}/lib/qt4/plugins
.if ${PORT_OPTIONS:MGTK2}
USE_GNOME+= gtk20
PLIST_SUB+= GTK2=""
SUB_LIST+= GTK2_IM=fcitx
.else
CMAKE_ARGS+= -DENABLE_GTK2_IM_MODULE=OFF
PLIST_SUB+= GTK2="@comment "
SUB_LIST+= GTK2_IM=xim
.endif
.if ${PORT_OPTIONS:MGTK3}
USE_GNOME+= gtk30
CMAKE_ARGS+= -DENABLE_GTK3_IM_MODULE=ON
PLIST_SUB+= GTK3=""
SUB_LIST+= GTK3_IM=fcitx
.else

View File

@ -1,5 +1,6 @@
SHA256 (fcitx/fcitx-4.2.8.6.tar.xz) = 60cbaaf73d2a8b96b6e1c3772473f4fba5271521af7edbdacaed92ea284a125b
SIZE (fcitx/fcitx-4.2.8.6.tar.xz) = 1664648
TIMESTAMP = 1464749421
SHA256 (fcitx/fcitx-4.2.9.1.tar.xz) = 25661907903e4ccaa4cf62cc389c006e280d31bce84147e203d7310fb4cd42ed
SIZE (fcitx/fcitx-4.2.9.1.tar.xz) = 1655504
SHA256 (fcitx/en_dict-20121020.tar.gz) = c44a5d7847925eea9e4d2d04748d442cd28dd9299a0b572ef7d91eac4f5a6ceb
SIZE (fcitx/en_dict-20121020.tar.gz) = 630491
SHA256 (fcitx/pinyin.tar.gz) = 583829b24a758c087c08de4a69480d0bf5946354fe77db360d6d7f467c2bd8e1

View File

@ -1,6 +1,6 @@
--- ./CMakeLists.txt.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./CMakeLists.txt 2014-03-19 13:45:08.000000000 +0900
@@ -207,16 +207,21 @@
--- CMakeLists.txt.orig 2015-12-12 08:02:09 UTC
+++ CMakeLists.txt
@@ -206,16 +206,21 @@ if (NOT DEFINED SYSCONFDIR)
set(SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/etc" CACHE PATH "sys config directory [default=PREFIX/etc/]")
endif()
@ -28,7 +28,7 @@
list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemPlatformLibDir)
list(FIND CMAKE_CXX_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemCxxLibDir)
@@ -229,9 +234,13 @@
@@ -228,9 +233,13 @@ endif("${_isSystemPlatformLibDir}" STREQ
# For FcitxMacro
set(FCITX4_ADDON_INSTALL_DIR ${addondir})

View File

@ -1,6 +1,6 @@
--- ./cmake/FcitxConfig.cmake.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./cmake/FcitxConfig.cmake 2014-03-19 13:45:08.000000000 +0900
@@ -76,9 +76,13 @@
--- cmake/FcitxConfig.cmake.orig 2015-12-12 08:02:09 UTC
+++ cmake/FcitxConfig.cmake
@@ -76,9 +76,13 @@ FIND_PROGRAM(FCITX4_FCITXCONFIG_EXECUTAB
IF(FCITX4_FCITXCONFIG_EXECUTABLE)
message(STATUS "fcitx4-config found ${FCITX4_FCITXCONFIG_EXECUTABLE}")
EXECUTE_PROCESS(COMMAND "${FCITX4_FCITXCONFIG_EXECUTABLE}" --addondir OUTPUT_VARIABLE FCITX4_ADDON_INSTALL_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)

View File

@ -1,6 +1,6 @@
--- ./cmake/FcitxMacro.cmake.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./cmake/FcitxMacro.cmake 2014-03-19 13:46:27.000000000 +0900
@@ -366,10 +366,10 @@
--- cmake/FcitxMacro.cmake.orig 2015-12-12 08:02:09 UTC
+++ cmake/FcitxMacro.cmake
@@ -366,10 +366,10 @@ function(fcitx_add_addon_full short_name
add_custom_target("${target_name}" ALL)
__fcitx_addon_config_file("${target_name}" "${FCITX_ADDON_CONF_SRC}"
@ -13,7 +13,7 @@
endforeach()
__fcitx_add_addon_lib("${FCITX_ADDON_LIB_NAME}" ${FCITX_ADDON_SOURCES})
if(FCITX_ADDON_LINK_LIBS)
@@ -393,7 +393,7 @@
@@ -393,7 +393,7 @@ function(__fcitx_add_addon_lib lib_name)
set_target_properties("${lib_name}" PROPERTIES PREFIX ""
COMPILE_FLAGS "-fvisibility=hidden")
add_dependencies("${lib_name}" fcitx-scan-addons.target)
@ -22,7 +22,7 @@
endfunction()
function(__fcitx_install_addon_desc target_name)
@@ -402,7 +402,7 @@
@@ -402,7 +402,7 @@ function(__fcitx_install_addon_desc targ
add_custom_target("${desc_target}" DEPENDS ${descs})
add_dependencies("${target_name}" "${desc_target}")
install(FILES ${descs}
@ -31,7 +31,7 @@
endfunction()
# Add additional config-desc files, the file will be added to extracte
@@ -893,7 +893,7 @@
@@ -897,7 +897,7 @@ MACRO(FCITX_ADD_ADDON_CONF_FILE conffile
__FCITX_CONF_FILE_GET_UNIQUE_TARGET_NAME(fcitx_addon_conf targetname)
add_custom_target(${targetname} ALL DEPENDS ${conffilename})
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${conffilename}"
@ -40,7 +40,7 @@
ENDMACRO(FCITX_ADD_ADDON_CONF_FILE conffilename)
MACRO(FCITX_ADD_INPUTMETHOD_CONF_FILE conffilename)
@@ -902,7 +902,7 @@
@@ -906,7 +906,7 @@ MACRO(FCITX_ADD_INPUTMETHOD_CONF_FILE co
__FCITX_CONF_FILE_GET_UNIQUE_TARGET_NAME(fcitx_inputmethod_conf targetname)
add_custom_target(${targetname} ALL DEPENDS ${conffilename})
install(FILES "${CMAKE_CURRENT_BINARY_DIR}/${conffilename}"

View File

@ -1,5 +1,5 @@
--- ./data/script/fcitx4-config.in.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./data/script/fcitx4-config.in 2014-03-19 13:45:08.000000000 +0900
--- data/script/fcitx4-config.in.orig 2015-12-12 08:02:09 UTC
+++ data/script/fcitx4-config.in
@@ -1,14 +1,26 @@
#! /bin/sh
@ -27,7 +27,7 @@
usage()
{
@@ -23,9 +35,13 @@
@@ -23,9 +35,13 @@ Known values for OPTION are:
--libdir Fcitx Library Prefix
--includedir Fcitx Include Prefix
--addondir Fcitx Addon Library Dir
@ -41,7 +41,7 @@
--help display this help and exit
--version output version information
EOF
@@ -72,18 +88,34 @@
@@ -72,18 +88,34 @@ while test $# -gt 0; do
echo $addondir
;;

View File

@ -1,5 +1,5 @@
--- ./tools/cli/CMakeLists.txt.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./tools/cli/CMakeLists.txt 2014-03-19 13:45:08.000000000 +0900
--- tools/cli/CMakeLists.txt.orig 2015-12-12 08:02:09 UTC
+++ tools/cli/CMakeLists.txt
@@ -1,3 +1,7 @@
+include_directories (
+ ${LIBICONV_INCLUDE_DIR}

View File

@ -1,8 +1,8 @@
--- ./tools/gui/quickphrase-editor/CMakeLists.txt.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./tools/gui/quickphrase-editor/CMakeLists.txt 2014-03-19 13:45:08.000000000 +0900
@@ -17,6 +17,7 @@
${QT_QTCORE_INCLUDE_DIR}
--- tools/gui/quickphrase-editor/CMakeLists.txt.orig 2015-12-12 08:02:09 UTC
+++ tools/gui/quickphrase-editor/CMakeLists.txt
@@ -18,6 +18,7 @@ include_directories(
${QT_QTGUI_INCLUDE_DIR}
${LIBINTL_INCLUDE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
+ ${LIBINTL_INCLUDE_DIR}
)

View File

@ -1,8 +1,8 @@
--- ./tools/gui/wrapper/CMakeLists.txt.orig 2013-09-28 17:33:14.000000000 +0900
+++ ./tools/gui/wrapper/CMakeLists.txt 2014-03-19 13:45:08.000000000 +0900
@@ -14,6 +14,7 @@
${QT_QTCORE_INCLUDE_DIR}
--- tools/gui/wrapper/CMakeLists.txt.orig 2015-12-12 08:02:09 UTC
+++ tools/gui/wrapper/CMakeLists.txt
@@ -15,6 +15,7 @@ include_directories(
${QT_QTGUI_INCLUDE_DIR}
${LIBINTL_INCLUDE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
+ ${LIBINTL_INCLUDE_DIR}
)