Add e2fsprogs 1.22, a set of utilities and library to manipulate an ext2

filesystem.

WARNING: The sole reason why I'm adding this port is to allow me upgrade
	 gnomeutils port to the latest version. For some very strange reason
	 this new version requires libext2fs to build. The only thing I know
	 for sure about e2fsprogs is that it compiles cleanly on 4-STABLE and
	 5-CURRENT systems - I have not tested it in action. Please use it
	 with extremal precaution, because due to its low-level nature and
	 Linux roots it can do Very Bad Things[tm] to your data, set fire
	 on your house, kill your cat or something else even more horrible. If
	 someone wants to take over maintainership please feel free to do so.
This commit is contained in:
Maxim Sobolev 2001-07-03 18:13:14 +00:00
parent ddf767d777
commit cbfe7948ca
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44716
13 changed files with 216 additions and 0 deletions

View File

@ -40,6 +40,7 @@
SUBDIR += doconfig
SUBDIR += du2ps
SUBDIR += dvdtape
SUBDIR += e2fsprogs
SUBDIR += eject
SUBDIR += extipl
SUBDIR += fcron

View File

@ -0,0 +1,37 @@
# New ports collection makefile for: e2fsprogs
# Date created: 3 July 2001
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= e2fsprogs
PORTVERSION= 1.22
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
USE_GMAKE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-elf-shlibs
CONFIGURE_ENV= CPPFLAGS="-I/usr/include -I${LOCALBASE}/include \
-Derrcode_t=long" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= chattr.1 lsattr.1 uuidgen.1
MAN8= badblocks.8 debugfs.8 dumpe2fs.8 e2fsck.8 e2image.8 e2label.8 fsck.8 \
mke2fs.8 mklost+found.8 resize2fs.8 tune2fs.8
post-patch:
@find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
's|LIST_HEAD|LIN_LST_HEAD|g ; \
s|et/com_err.h|com_err.h|g'
post-install:
${MKDIR} ${PREFIX}/include/ext2fs
${INSTALL_DATA} ${WRKSRC}/lib/ext2fs/*.h ${PREFIX}/include/ext2fs
.include <bsd.port.mk>

View File

@ -0,0 +1 @@
MD5 (e2fsprogs-1.22.tar.gz) = a2b689fda4e954df0258c2605bc65d9b

View File

@ -0,0 +1,25 @@
$FreeBSD$
--- MCONFIG.in.orig Sat Jun 23 07:25:59 2001
+++ MCONFIG.in Tue Jul 3 18:29:41 2001
@@ -57,15 +57,15 @@
# Library definitions
#
LIB = $(top_builddir)/lib
-LIBSS = $(LIB)/libss@LIB_EXT@
-LIBCOM_ERR = $(LIB)/libcom_err@LIB_EXT@
+LIBSS = /usr/lib/libss.so
+LIBCOM_ERR = /usr/lib/libcom_err.so
LIBE2P = $(LIB)/libe2p@LIB_EXT@
LIBEXT2FS = $(LIB)/libext2fs@LIB_EXT@
LIBUUID = $(LIB)/libuuid@LIB_EXT@ @SOCKET_LIB@
DEPLIBUUID = $(LIB)/libuuid@LIB_EXT@
-STATIC_LIBSS = $(LIB)/libss@STATIC_LIB_EXT@
-STATIC_LIBCOM_ERR = $(LIB)/libcom_err@STATIC_LIB_EXT@
+STATIC_LIBSS = /usr/lib/libss.a
+STATIC_LIBCOM_ERR = /usr/lib/libcom_err.a
STATIC_LIBE2P = $(LIB)/libe2p@STATIC_LIB_EXT@
STATIC_LIBEXT2FS = $(LIB)/libext2fs@STATIC_LIB_EXT@
STATIC_LIBUUID = $(LIB)/libuuid@STATIC_LIB_EXT@ @SOCKET_LIB@

View File

@ -0,0 +1,18 @@
$FreeBSD$
--- Makefile.in.orig Sat Jun 23 07:25:59 2001
+++ Makefile.in Tue Jul 3 18:51:42 2001
@@ -10,9 +10,9 @@
@RESIZER_CMT@RESIZE_DIR= resize
@DEBUGFS_CMT@DEBUGFS_DIR= debugfs
-LIB_SUBDIRS=lib/et lib/ss lib/e2p lib/ext2fs lib/uuid # lib/finddev
-PROG_SUBDIRS=e2fsck $(DEBUGFS_DIR) misc $(RESIZE_DIR) tests/progs
-SUBDIRS=util $(LIB_SUBDIRS) $(PROG_SUBDIRS) tests
+LIB_SUBDIRS=lib/e2p lib/ext2fs lib/uuid # lib/finddev
+PROG_SUBDIRS=e2fsck $(DEBUGFS_DIR) misc $(RESIZE_DIR)
+SUBDIRS=util $(LIB_SUBDIRS) $(PROG_SUBDIRS)
SUBS= lib/ext2fs/ext2_types.h

View File

@ -0,0 +1,26 @@
$FreeBSD$
--- debugfs/Makefile.in.orig Sat Jun 23 07:25:59 2001
+++ debugfs/Makefile.in Tue Jul 3 18:49:18 2001
@@ -14,7 +14,7 @@
PROGS= debugfs
MANPAGES= debugfs.8
-MK_CMDS= _SS_DIR_OVERRIDE=../lib/ss ../lib/ss/mk_cmds
+MK_CMDS= mk_cmds
DEBUG_OBJS= debug_cmds.o debugfs.o util.o ncheck.o icheck.o ls.o \
lsdel.o dump.o setsuper.o logdump.o
@@ -75,9 +75,9 @@
# the Makefile.in file
#
debug_cmds.o: debug_cmds.c $(top_srcdir)/lib/ss/ss.h \
- $(top_builddir)/lib/ss/ss_err.h
+
debugfs.o: $(srcdir)/debugfs.c $(top_srcdir)/lib/et/com_err.h \
- $(top_srcdir)/lib/ss/ss.h $(top_builddir)/lib/ss/ss_err.h \
+ $(top_srcdir)/lib/ss/ss.h \
$(srcdir)/debugfs.h $(top_srcdir)/lib/ext2fs/ext2_fs.h \
$(top_builddir)/lib/ext2fs/ext2_types.h $(top_srcdir)/lib/ext2fs/ext2fs.h \
$(top_srcdir)/lib/ext2fs/ext2_io.h $(top_builddir)/lib/ext2fs/ext2_err.h \

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- e2fsck/journal.c 2001/07/03 14:35:01 1.1
+++ e2fsck/journal.c 2001/07/03 14:35:13
@@ -13,6 +13,8 @@
*/
#ifdef HAVE_SYS_MOUNT_H
+#include <sys/param.h>
+#include <sys/types.h>
#include <sys/mount.h>
#define MNT_FL (MS_MGC_VAL | MS_RDONLY)
#endif

View File

@ -0,0 +1,22 @@
$FreeBSD$
--- lib/Makefile.elf-lib.orig Sat Jun 23 07:25:59 2001
+++ lib/Makefile.elf-lib Tue Jul 3 18:57:04 2001
@@ -39,13 +39,12 @@
installdirs:: installdirs-elf-lib
install-shlibs install:: $(ELF_LIB) installdirs-elf-lib
- $(INSTALL_PROGRAM) $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
+ $(INSTALL_PROGRAM) $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
+ $(INSTALL_DATA) $(ELF_IMAGE).a $(DESTDIR)$(ELF_INSTALL_DIR)/
$(STRIP) --strip-debug \
- $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
- $(LN_S) -f $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
+ $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
$(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
$(DESTDIR)$(libdir)/$(ELF_IMAGE).so
- -$(LDCONFIG)
uninstall-shlibs uninstall::
$(RM) -f $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB) \

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- lib/ext2fs/Makefile.in 2001/07/03 15:30:54 1.1
+++ lib/ext2fs/Makefile.in 2001/07/03 15:31:07
@@ -156,7 +156,7 @@
@ELF_CMT@ $(CC) $(ALL_CFLAGS) -fPIC -o elfshared/$*.o -c $<
@BSDLIB_CMT@ $(CC) $(ALL_CFLAGS) -fpic -o pic/$*.o -c $<
-COMPILE_ET=../et/compile_et
+COMPILE_ET=compile_et
DISTFILES= Makefile *.c *.h image

View File

@ -0,0 +1,13 @@
$FreeBSD$
--- lib/ext2fs/flushb.c 2001/07/03 14:28:59 1.1
+++ lib/ext2fs/flushb.c 2001/07/03 14:30:57
@@ -21,6 +21,7 @@
#include <sys/ioctl.h>
#endif
#if HAVE_SYS_MOUNT_H
+#include <sys/param.h>
#include <sys/mount.h> /* This may define BLKFLSBUF */
#endif

View File

@ -0,0 +1 @@
A set of utilities and library to manipulate an ext2 filesystem

View File

@ -0,0 +1,3 @@
Set of utilities and library to manipulate an ext2 filesystem.
WWW: http://e2fsprogs.sourceforge.net/

View File

@ -0,0 +1,41 @@
bin/chattr
bin/lsattr
bin/uuidgen
include/ext2fs/bitops.h
include/ext2fs/brel.h
include/ext2fs/dosio.h
include/ext2fs/e2image.h
include/ext2fs/ext2_err.h
include/ext2fs/ext2_fs.h
include/ext2fs/ext2_io.h
include/ext2fs/ext2_types.h
include/ext2fs/ext2fs.h
include/ext2fs/ext2fsP.h
include/ext2fs/irel.h
include/ext2fs/jfs_dat.h
include/ext2fs/jfs_user.h
info/libext2fs.info.gz
lib/libe2p.a
lib/libe2p.so
lib/libe2p.so.2
lib/libext2fs.a
lib/libext2fs.so
lib/libext2fs.so.2
lib/libuuid.a
lib/libuuid.so
lib/libuuid.so.1
sbin/badblocks
sbin/debugfs
sbin/dumpe2fs
sbin/e2fsck
sbin/e2image
sbin/e2label
sbin/fsck
sbin/fsck.ext2
sbin/fsck.ext3
sbin/mke2fs
sbin/mkfs.ext2
sbin/mklost+found
sbin/resize2fs
sbin/tune2fs
@dirrm include/ext2fs