Update to current version so it will build. Trevor's apparently gone for a

while, and this port is unfetchable as is.

Approved by:	kris (build fix)
This commit is contained in:
Alan Eldridge 2002-12-08 17:55:04 +00:00
parent 6cd6f2e2bf
commit cbe1ec8d99
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=71426
8 changed files with 11 additions and 54 deletions

View File

@ -6,12 +6,12 @@
#
PORTNAME= xc-mail
PORTVERSION= 1.3
PORTVERSION= 2.2
PORTREVISION= 0
PORTEPOCH= 1
CATEGORIES= mail
MASTER_SITES= http://js.zet.net/XCmail/download/ \
ftp://trier.linux.de/pub/XCmail/ \
ftp://ftp.myth.co.uk/pub/mirrors/xcmail/
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xcmail
MAINTAINER= trevor@FreeBSD.org
@ -33,4 +33,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LDFLAGS="-L${X11BASE}/lib" \
LIBS="-L${X11BASE}/lib"
post-install:
chown ${BINOWN}:mail ${PREFIX}/bin/xc-mail
chmod g+s ${PREFIX}/bin/xc-mail
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (xc-mail-1.3.tar.gz) = d37f56af205ece0c9356befc239b1c62
MD5 (xc-mail-2.2.tar.gz) = 249505fa6d95c1d07669b210c5f9a83b

View File

@ -1,11 +0,0 @@
--- plugins/linkshared.in.orig Tue Sep 15 16:18:07 1998
+++ plugins/linkshared.in Sun Oct 1 05:02:54 2000
@@ -26,7 +26,7 @@
case @host@ in
- *-linux-*|*-irix6*|*-freebsd3*|*solaris2*)
+ *-linux-*|*-irix6*|*-freebsd3*|*-freebsd4*|*-freebsd5*|*solaris2*)
echo @CXX@ -o $dest -shared -Wl,-soname,"$dest" $*
@CXX@ -o $dest -shared -Wl,-soname,"$dest" $* || die
;;

View File

@ -1,12 +0,0 @@
--- src/mail_class.cxx.orig Mon Jun 5 12:11:04 2000
+++ src/mail_class.cxx Sun Oct 1 05:07:19 2000
@@ -12,8 +12,8 @@
#include <string.h>
#include <stdlib.h>
#include <errno.h>
-#include <utime.h>
#include <sys/types.h>
+#include <utime.h>
#include <sys/stat.h>
#include <fcntl.h>
#include <ctype.h>

View File

@ -1,12 +0,0 @@
--- src/npop3get.cxx.orig Fri Jun 23 10:42:27 2000
+++ src/npop3get.cxx Sun Oct 1 05:08:18 2000
@@ -12,8 +12,8 @@
#include <string.h>
#include <stdlib.h>
#include <errno.h>
-#include <utime.h>
#include <sys/types.h>
+#include <utime.h>
#include <sys/stat.h>
#include <fcntl.h>
#include <ctype.h>

View File

@ -1,11 +0,0 @@
--- src/sendmail.cxx.orig Sat Sep 9 14:45:54 2000
+++ src/sendmail.cxx Mon Oct 2 00:07:59 2000
@@ -101,7 +101,7 @@
::send(sockfd,b,len,0);
// alarm(0);
}
- fcntl(sockfd,F_SETFL,O_SYNC);
+ fcntl(sockfd,F_SETFL,O_FSYNC);
return r;
}
int sendmail::RCPT(void)

View File

@ -6,7 +6,7 @@ history so mail which is left on the POP server but deleted on the
client is only downloaded once. XCmail has RFC 2015-compliant
support for encrypted mail in multipart MIME format.
WWW: http://www.fsai.fh-trier.de/~schmitzj/Xclasses/XCmail/
WWW: http://www.js-home.org/XCmail/
Trevor Johnson
trevor@freebsd.org

View File

@ -1,15 +1,14 @@
XCmail/converters/elm2xcmail
XCmail/converters/ns2xcmail
XCmail/plugins/babelfish_pl.o
XCmail/plugins/binhex_encoding_pl.o
XCmail/plugins/check_new_release_pl.o
XCmail/plugins/dateresend_pl.o
XCmail/plugins/dictionary_pl.o
XCmail/plugins/js_code_pl.o
XCmail/plugins/mhstyle_pl.o
XCmail/plugins/rot13_encoding_pl.o
XCmail/plugins/search_pl.o
XCmail/plugins/simple_filter_pl.o
XCmail/plugins/spam_bouncer_pl.o
XCmail/plugins/test_pl.o
XCmail/plugins/trashmgr_pl.o
bin/xc-mail