- Update to 1.1.6

- Take maintainership
- Fix LICENSE
- Add LICENSE_FILE
- Switch to USES=localbase
- Update WWW
This commit is contained in:
Dmitry Marakasov 2017-01-31 18:35:27 +00:00
parent f54d5fefc1
commit cb78a94c65
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=432942
5 changed files with 23 additions and 21 deletions

View File

@ -2,29 +2,26 @@
# $FreeBSD$
PORTNAME= toppler
PORTVERSION= 1.1.5
PORTREVISION= 5
PORTVERSION= 1.1.6
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Climb a tower and avoid monsters
LICENSE= GPLv2
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gettext gmake localbase
USE_SDL= mixer sdl
USES= gettext gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=/var/games
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
OPTIONS_DEFINE= DOCS
SCOREFILE= /var/games/toppler/toppler.hsc
post-install:
${MV} ${STAGEDIR}${SCOREFILE} ${STAGEDIR}${SCOREFILE}.sample
@${MV} ${STAGEDIR}${SCOREFILE} ${STAGEDIR}${SCOREFILE}.sample
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (toppler-1.1.5.tar.gz) = 26cab477cfc427827fc4dc584271148ba4d14b5a5f12c1752e262b795d814167
SIZE (toppler-1.1.5.tar.gz) = 2152897
TIMESTAMP = 1485788372
SHA256 (toppler-1.1.6.tar.gz) = 7dbc2905389c2adba0f8c459f3319cf04045ba53ed407e273a50a3a67564cc45
SIZE (toppler-1.1.6.tar.gz) = 2117137

View File

@ -0,0 +1,12 @@
--- main.cc.orig 2012-12-22 11:02:06 UTC
+++ main.cc
@@ -96,7 +96,8 @@ int main(int argc, char *argv[]) {
DIR *dir = opendir("locale");
bindtextdomain("toppler", dir == NULL ? LOCALEDIR : "locale");
- closedir(dir);
+ if (dir)
+ closedir(dir);
textdomain("toppler");
#endif

View File

@ -12,4 +12,4 @@ The only weapon of defence you have is to throw a little snowball. But
most of the other creatures just don't care about this. So you must
avoid them.
WWW: http://toppler.sf.net/
WWW: http://toppler.sourceforge.net/

View File

@ -13,14 +13,6 @@ share/locale/pt/LC_MESSAGES/toppler.mo
share/locale/ro/LC_MESSAGES/toppler.mo
share/locale/sv/LC_MESSAGES/toppler.mo
share/pixmaps/toppler.xpm
%%DATADIR%%/abc.ttm
%%DATADIR%%/ball1.ttm
%%DATADIR%%/ball2.ttm
%%DATADIR%%/ball3.ttm
%%DATADIR%%/david1.ttm
%%DATADIR%%/m1.ttm
%%DATADIR%%/m2.ttm
%%DATADIR%%/pasi2.ttm
%%DATADIR%%/toppler.dat
%%DATADIR%%/toppler.ogg
@sample(,games,664) /var/games/toppler/toppler.hsc.sample