misc/sfm: port of a simple file manager for Unix-like systems.

WWW: https://git.afify.dev/sfm/
This commit is contained in:
Alexey Dokuchaev 2021-11-12 03:57:16 +00:00
parent 8c130154d2
commit cb6dc5bf21
5 changed files with 49 additions and 0 deletions

View File

@ -460,6 +460,7 @@
SUBDIR += seabios
SUBDIR += sent
SUBDIR += seq2
SUBDIR += sfm
SUBDIR += shared-mime-info
SUBDIR += shc
SUBDIR += shuffle

19
misc/sfm/Makefile Normal file
View File

@ -0,0 +1,19 @@
# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
PORTNAME= sfm
PORTVERSION= 0.4
DISTVERSIONPREFIX= v
CATEGORIES= misc
MAINTAINER= danfe@FreeBSD.org
COMMENT= Simple file manager for Unix-like systems
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= afify
PLIST_FILES= bin/sfm share/man/man1/sfm.1.gz
.include <bsd.port.mk>

3
misc/sfm/distinfo Normal file
View File

@ -0,0 +1,3 @@
TIMESTAMP = 1636121495
SHA256 (afify-sfm-v0.4_GH0.tar.gz) = c0fe7f36a4050256b68c6e6c5cb3b7065527c6a8f6a1b0ca020814a7d511c652
SIZE (afify-sfm-v0.4_GH0.tar.gz) = 29483

View File

@ -0,0 +1,16 @@
--- config.mk.orig 2021-11-05 14:11:35 UTC
+++ config.mk
@@ -6,9 +6,9 @@ PREFIX = /usr/local
MANPREFIX = ${PREFIX}/share/man
# flags
-CPPFLAGS = -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DVERSION=\"${VERSION}\"
-CFLAGS = -std=c99 -pedantic -Wextra -Wall -Wno-unused-parameter -Os ${CPPFLAGS}
-LDFLAGS = -pthread -s
+CPPFLAGS += -D_DEFAULT_SOURCE -D_BSD_SOURCE -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DVERSION=\"${VERSION}\"
+CFLAGS += -pedantic -Wextra -Wall -Wno-unused-parameter ${CPPFLAGS}
+LDFLAGS += -pthread
# compiler and linker
-CC = cc
+CC ?= cc

10
misc/sfm/pkg-descr Normal file
View File

@ -0,0 +1,10 @@
sfm is a simple file manager for Unix-like systems. It features:
- pthread(3) to read events, no timers
- BSD kqueue(2) notification mechanism
- dual panel, bottom statusbar
- open files by extension
- bookmarks, filters
- vim-like key bindings
WWW: https://git.afify.dev/sfm/