Fix build on 4.x actually. We need to pass CPPFLAGS and LDFLAGS

to use USE_GETOPT_LONG.
This commit is contained in:
Hajimu UMEMOTO 2005-12-12 02:25:38 +00:00
parent 5363114c75
commit cb44dd834e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=150942
2 changed files with 9 additions and 4 deletions

View File

@ -15,4 +15,6 @@ COMMENT= ATI Radeon video card contoroling tool useful for laptops
USE_GETOPT_LONG=YES
MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.mk>

View File

@ -1,12 +1,15 @@
Index: Makefile
diff -u Makefile.orig Makefile
--- Makefile.orig Sun Jun 23 14:28:15 2002
+++ Makefile Fri Aug 19 00:34:31 2005
@@ -1,8 +1,9 @@
+++ Makefile Mon Dec 12 11:21:21 2005
@@ -1,8 +1,10 @@
-
+all:radeontool
radeontool: radeontool.c
gcc -Wall -O2 radeontool.c -o radeontool
-
- gcc -Wall -O2 radeontool.c -o radeontool
+ ${CC} -Wall ${CFLAGS} ${CPPFLAGS} radeontool.c -o radeontool ${LDFLAGS}
+install:
+ install -C -s radeontool ${PREFIX}/bin/