Update to 1.6.2

This commit is contained in:
Emanuel Haupt 2017-01-12 14:43:17 +00:00
parent 43847c8f57
commit cb31945303
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=431275
4 changed files with 12 additions and 31 deletions

View File

@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= birthday
PORTVERSION= 1.5
PORTVERSION= 1.6.2
CATEGORIES= misc
MASTER_SITES= http://users.zetnet.co.uk/mortia/source/
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Outputs reminders for upcoming events (e.g. birthdays)
@ -12,18 +12,16 @@ COMMENT= Outputs reminders for upcoming events (e.g. birthdays)
LICENSE= ART10 GPLv2
LICENSE_COMB= dual
PLIST_FILES= bin/birthday man/man1/birthday.1.gz
USES= gmake tar:bzip2
USES= gmake
MAKEFILE= ${WRKSRC}/Makefile.gnu
ALL_TARGET= birthday
MAKE_ARGS= CFLAGS="${CFLAGS} -DUNIX"
do-configure:
cd ${WRKSRC} && ${MAKE} Makefile.gnu
PLIST_FILES= bin/birthday man/man1/birthday.1.gz
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/birthday ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/birthday.man ${STAGEDIR}${MAN1PREFIX}/man/man1/birthday.1
${INSTALL_PROGRAM} ${WRKSRC}/birthday ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/birthday.man \
${STAGEDIR}${MAN1PREFIX}/man/man1/birthday.1
.include <bsd.port.mk>

View File

@ -1,2 +1,3 @@
SHA256 (birthday-1.5.tar.gz) = a34565f49adb80e605d2db387eeb30dfac61cec3b12c575e9f9ed52ed7ada1e7
SIZE (birthday-1.5.tar.gz) = 35689
TIMESTAMP = 1484229190
SHA256 (birthday-1.6.2.tar.bz2) = 355ad07ad3312d8f5c5b54c71596ac3a0e706c539167900d73cb65df30c8e2f4
SIZE (birthday-1.6.2.tar.bz2) = 85617

View File

@ -1,20 +0,0 @@
--- makemake.c.orig 2007-11-22 16:13:14.000000000 +0100
+++ makemake.c 2007-11-22 16:13:25.000000000 +0100
@@ -17,7 +17,7 @@
{ "UNIX", "ifeq (", ",", ")", "else", "endif" }
};
-main(int argc, char *argv[])
+int main(int argc, char *argv[])
{
enum {DOS=0,UNIX=1} os;
char buf[256];
@@ -51,6 +51,8 @@
} else
printf("%s", buf);
}
+
+ return (0);
}

View File

@ -2,3 +2,5 @@ Birthday displays a list of events which are coming up in the near future,
based on a config file (~/.birthdays) in the user's home directory.
Used in a user's .profile or crontab it can save the day for many
a terminally disorganised soul...
WWW: https://sourceforge.net/projects/birthday/