update to 3.1.9

This commit is contained in:
Michael Haro 2000-03-07 21:08:38 +00:00
parent 0a6a7d0ee3
commit cb2e456d00
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=26623
4 changed files with 19 additions and 18 deletions

View File

@ -1,12 +1,12 @@
# ports collection makefile for: libmikmod
# Version required: 3.1.8
# Version required: 3.1.9
# Date created: Sun Apr 11 13:06:01 PDT 1999
# Whom: Michael Haro <mharo@area51.fremont.ca.us>
#
# $FreeBSD$
#
DISTNAME= libmikmod-3.1.8
DISTNAME= libmikmod-3.1.9
CATEGORIES= audio
MASTER_SITES= http://www.mikmod.darkorb.net/libmikmod/

View File

@ -1 +1 @@
MD5 (libmikmod-3.1.8.tar.gz) = 79ff9b3eebf4e0cae663d44039f50d04
MD5 (libmikmod-3.1.9.tar.gz) = 0d50670d34653490a0c87a9fa5cc804a

View File

@ -1,11 +1,11 @@
--- docs/Makefile.in.orig Sat May 8 18:42:08 1999
+++ docs/Makefile.in Sat May 8 18:42:28 1999
@@ -75,7 +75,7 @@
--- docs/Makefile.in.orig Mon Feb 14 14:19:59 2000
+++ docs/Makefile.in Tue Mar 7 13:01:48 2000
@@ -76,7 +76,7 @@
LIB_LDADD = @LIB_LDADD@
LN_S = @LN_S@
MAINT = @MAINT@
-MAKEINFO = @MAKEINFO@
+MAKEINFO = @MAKEINFO@ --no-split
NM = @NM@
OBJDUMP = @OBJDUMP@
PACKAGE = @PACKAGE@
PLAYER_LIB = @PLAYER_LIB@

View File

@ -1,24 +1,25 @@
--- configure.orig Tue Jan 25 00:19:49 2000
+++ configure Tue Jan 25 00:20:51 2000
@@ -2045,14 +2045,14 @@
--- configure.orig Mon Feb 14 12:20:17 2000
+++ configure Tue Mar 7 13:04:53 2000
@@ -2063,14 +2063,14 @@
libmikmod_threads=-lpthread
else
echo "$ac_t""no" 1>&6
-echo $ac_n "checking for pthread_create in -lc_r""... $ac_c" 1>&6
-echo "configure:2050: checking for pthread_create in -lc_r" >&5
+echo $ac_n "checking for pthread_create in -pthread""... $ac_c" 1>&6
+echo "configure:2050: checking for pthread_create in -pthread" >&5
ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
-echo "configure:2068: checking for pthread_create in -lc_r" >&5
-ac_lib_var=`echo c_r'_'pthread_create | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
+echo "configure:2068: checking for pthread_create in -lpthread" >&5
+ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lc_r $LIBS"
+LIBS="-pthread $LIBS"
+LIBS="-lpthread $LIBS"
cat > conftest.$ac_ext <<EOF
#line 2058 "configure"
#line 2076 "configure"
#include "confdefs.h"
@@ -2080,7 +2080,7 @@
@@ -2098,7 +2098,7 @@
fi
if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
echo "$ac_t""yes" 1>&6
@ -27,7 +28,7 @@
else
echo "$ac_t""no" 1>&6
fi
@@ -3681,9 +3681,9 @@
@@ -3790,9 +3790,9 @@
#define HAVE_PTHREAD 1
EOF