Add taskjuggler, a project management tool for Linux and UNIX

system-based operating systems. Instead of clicking yourself painfully through
hundreds of dialog boxes you specify your Taskjuggler project in a simple text
format. You simply list all your tasks and their dependencies. The information
is sent through Taskjuggler and you will get all sorts of reports in HTML or
XML format.

PR:		ports/63342
Submitted by:	Dean Povey <povey@wedgetail.com>
This commit is contained in:
Pav Lucistnik 2004-03-30 18:20:16 +00:00
parent dbfd738360
commit cb28834342
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=105719
8 changed files with 239 additions and 0 deletions

View File

@ -90,6 +90,7 @@
SUBDIR += sliderule
SUBDIR += splashsetter
SUBDIR += superkaramba
SUBDIR += taskjuggler
SUBDIR += teapot
SUBDIR += tuxcards
SUBDIR += wmpinboard

View File

@ -0,0 +1,45 @@
# New ports collection makefile for: taskjuggler
# Date created: 23 February 2004
# Whom: Dean Povey <povey@wedgetail.com>
#
# $FreeBSD$
#
PORTNAME= taskjuggler
PORTVERSION= 2.0
CATEGORIES= deskutils
MASTER_SITES= http://www.taskjuggler.org/download/
MAINTAINER= povey@wedgetail.com
COMMENT= A project management tool for UNIX based operating systems
BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
${SITE_PERL}/Class/MethodMaker.pm:${PORTSDIR}/devel/p5-Class-MethodMaker \
${SITE_PERL}/PostScript/Simple.pm:${PORTSDIR}/print/p5-PostScript-Simple \
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
poster:${PORTSDIR}/print/poster \
xsltproc:${PORTSDIR}/textproc/libxslt
OPTIONS= KTJVIEW "Build KDE KTJView program (Requires KDE)" off
USE_BZIP2= yes
USE_QT_VER= 3
USE_PERL5_RUN= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
.if defined(WITH_KTJVIEW)
LIB_DEPENDS+= kwalletbackend:${PORTSDIR}/x11/kdelibs3
CONFIGURE_ARGS+= --with-kde-support=yes
.include "files/ktjview-plist.mk"
.endif
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|share/doc/packages/|share/doc/|g'
.include <bsd.port.post.mk>

View File

@ -0,0 +1,2 @@
MD5 (taskjuggler-2.0.tar.bz2) = bde3128d93595de5fc430f26a25d85e6
SIZE (taskjuggler-2.0.tar.bz2) = 889124

View File

@ -0,0 +1,14 @@
PLIST_FILES+= bin/ktjview \
lib/kde3/libktjviewpart.so \
lib/kde3/libktjviewpart.la \
share/icons/hicolor/16x16/apps/ktjview.png \
share/icons/hicolor/32x32/apps/ktjview.png \
share/icons/hicolor/48x48/apps/ktjview.png \
share/icons/locolor/16x16/apps/ktjview.png \
share/icons/locolor/32x32/apps/ktjview.png \
share/services/ktjview.desktop \
share/apps/ktjviewpart/ktjview_part.rc \
share/apps/ktjview/ktjview_shell.rc \
PLIST_DIRS+= share/apps/ktjviewpart \
share/apps/ktjview

View File

@ -0,0 +1,19 @@
*** TestSuite/testdir Mon Feb 23 13:10:52 2004
--- TestSuite/testdir.patch Mon Feb 23 13:11:05 2004
***************
*** 12,18 ****
export TASKJUGGLER=../$TASKJUGGLER
fi
! function do_testing
{
f=$1
op=$2
--- 12,18 ----
export TASKJUGGLER=../$TASKJUGGLER
fi
! do_testing()
{
f=$1
op=$2

View File

@ -0,0 +1,103 @@
--- tjx2gantt/tjx2gantt Mon Jul 14 22:31:53 2003
+++ tjx2gantt/tjx2gantt.patch Wed Feb 25 09:07:00 2004
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!/usr/bin/perl -w
#
# !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
# !!! This Software is __ALPHA__ !!!
@@ -18,12 +18,10 @@
$| = 1;
use strict;
-use warnings;
package tjTask;
use strict;
- use warnings;
use Class::MethodMaker
new_hash_init => 'new',
get_set => [ qw(Index ProjectID complete Priority Type Id Name ParentTask
@@ -393,10 +391,10 @@
my ($x2, $y2) = _trans_coord($_x2, $_y2);
#-- balken
$p->setcolour(222,222,222);
- $p->box($x1, $y1, $x2, $y2, 1);
+ $p->box({ filled => 1 }, $x1, $y1, $x2, $y2);
#-- rahmen drum
$p->setcolour(0,0,0);
- $p->box($x1, $y1, $x2, $y2, 0);
+ $p->box({ filled => 0 }, $x1, $y1, $x2, $y2);
#-- linie dazwischen
my $l_y = $y2+($task_space/2)-($task_height/2);
$p->line($page_border+5, $l_y, $page_x-($page_border*2), $l_y );
@@ -458,35 +456,35 @@
if ( Delta_Days($today_year, $today_month, $today_day, $end_year, $end_month, $end_day) < 0 ) {
if ( $persent < 100 ) {
$p->setcolour(255,0,0);
- $p->box($x1, $y1, $x2, $y2, 1);
+ $p->box({ filled => 1 }, $x1, $y1, $x2, $y2);
}
} else {
$p->setcolour(255,255,255);
- $p->box($x1, $y1, $x2, $y2, 1);
+ $p->box({ filled => 1 }, $x1, $y1, $x2, $y2);
}
#-- buffer balken pinseln
if ( $task->startBuffer ) {
my $buf = $task->startBuffer;
my ($buf_length, $d) = _trans_coord($_x1 + (($task_length/100*$buf) * $day_x), 0);
$p->setcolour(222,222,222);
- $p->box($x1, $y1, $buf_length, $y2, 1);
+ $p->box({ filled => 1 }, $x1, $y1, $buf_length, $y2);
}
if ( $task->endBuffer ) {
my $buf = $task->endBuffer;
my ($buf_length, $d) = _trans_coord($_x2 - (($task_length/100*$buf) * $day_x), 0);
$p->setcolour(222,222,222);
- $p->box($buf_length, $y1, $x2, $y2, 1);
+ $p->box({ filled => 1 }, $buf_length, $y1, $x2, $y2);
}
#-- länge von % feritg balken
my ($per_length, $d) = _trans_coord($_x1 + (($task_length/100*$persent) * $day_x), 0);
#-- % done balken pinseln
if ($persent > 0) {
$p->setcolour(0,255,0);
- $p->box($x1, $y1, $per_length, $y2, 1);
+ $p->box({ filled => 1 }, $x1, $y1, $per_length, $y2);
}
#-- rahmen um den task
$p->setcolour(0,0,0);
- $p->box($x1, $y1, $x2, $y2, 0);
+ $p->box({ filled => 0 }, $x1, $y1, $x2, $y2);
#-- text
$task->label($name);
$task->label_x($x1+1);
@@ -494,7 +492,7 @@
}
if ( $task->Type eq 'Container' ) {
$p->setcolour(0,0,0);
- $p->box($x1-1, $y1, $x2+1, $y2+($task_height/1.2), 1);
+ $p->box({ filled => 1 }, $x1-1, $y1, $x2+1, $y2+($task_height/1.2));
#-- pfeil vorn
$p->polygon(
$x1+1, $y2+($task_height/1.2),
@@ -517,7 +515,7 @@
if ( $task->Type eq 'Milestone' ) {
$p->setcolour(0,0,0);
my ($x, $y) = _trans_coord($_x1, $_y1+($task_height/2));
- $p->circle($x, $y, 1, 1);
+ $p->circle({ filled => 1 }, $x, $y, 1);
$p->setfont("Helvetica", 6);
my $am = sprintf('%02d', $start_month);
my $ad = sprintf('%02d', $start_day);
@@ -585,7 +583,7 @@
my $h_month_week = 3;
my ($_x, $_y) = ($i*$day_x, $day_x*$h_month_week);
my ($x, $y) = _trans_coord($_x, $_y);
- $p->box($x, $y, $x+$day_x, $page_border, 1);
+ $p->box({ filled => 1 }, $x, $y, $x+$day_x, $page_border);
#-- die linien haben unterschiedliche höhe
#-- is es ein wochen-anfang
if ( $act_dow == 1 ) {

View File

@ -0,0 +1,11 @@
This is a port of Taskjuggler, a project management tool for Linux and UNIX
system-based operating systems. Instead of clicking yourself painfully through
hundreds of dialog boxes you specify your Taskjuggler project in a simple text
format. You simply list all your tasks and their dependencies. The information
is sent through Taskjuggler and you will get all sorts of reports in HTML or
XML format.
WWW: http://www.taskjuggler.org/
- Dean Povey
povey@wedgetail.com

View File

@ -0,0 +1,44 @@
bin/taskjuggler
share/doc/taskjuggler/Examples/FirstProject/Accounting.html
share/doc/taskjuggler/Examples/FirstProject/Calendar.html
share/doc/taskjuggler/Examples/FirstProject/Staff-Details.html
share/doc/taskjuggler/Examples/FirstProject/Staff-Overview.html
share/doc/taskjuggler/Examples/FirstProject/Status-Report.html
share/doc/taskjuggler/Examples/FirstProject/Tasks-Details.html
share/doc/taskjuggler/Examples/FirstProject/Tasks-Overview.html
share/doc/taskjuggler/Examples/FirstProject/AccountingSoftware.tjp
share/doc/taskjuggler/Examples/FirstProject/AccountingSoftware.tjx
share/doc/taskjuggler/Examples/BigProject/Common/Resources.tjsp
share/doc/taskjuggler/Examples/BigProject/Project1/Project1.html
share/doc/taskjuggler/Examples/BigProject/Project1/Project1.tjp
share/doc/taskjuggler/Examples/BigProject/Project1/Project1-Interface.tjsp
share/doc/taskjuggler/Examples/BigProject/Project2/Project2.html
share/doc/taskjuggler/Examples/BigProject/Project2/Project2.tjp
share/doc/taskjuggler/Examples/BigProject/README
share/doc/taskjuggler/Examples/ShiftSchedule/Calendar-anders.html
share/doc/taskjuggler/Examples/ShiftSchedule/Calendar-joe.html
share/doc/taskjuggler/Examples/ShiftSchedule/Calendar-khaled.html
share/doc/taskjuggler/Examples/ShiftSchedule/Calendar-paul.html
share/doc/taskjuggler/Examples/ShiftSchedule/Calendar-sally.html
share/doc/taskjuggler/Examples/ShiftSchedule/ResourceUsage-Jun.html
share/doc/taskjuggler/Examples/ShiftSchedule/ShiftTimes-06-03.html
share/doc/taskjuggler/Examples/ShiftSchedule/ShiftTimes-06-10.html
share/doc/taskjuggler/Examples/ShiftSchedule/TaskCoverage-Jun.html
share/doc/taskjuggler/Examples/ShiftSchedule/ShiftSchedule.tjp
bin/tjx2gantt
share/doc/taskjuggler/tjx2gantt/README
share/doc/taskjuggler/tjx2gantt/BUGS
share/doc/taskjuggler/tjx2gantt/TODO
share/doc/taskjuggler/tjx2gantt/testProject.tjp
share/doc/taskjuggler/Examples/FirstProject/acso.eps
share/doc/taskjuggler/Examples/FirstProject/acso_poster.eps
@dirrm share/doc/taskjuggler/Examples/FirstProject
@dirrm share/doc/taskjuggler/Examples/BigProject/Common
@dirrm share/doc/taskjuggler/Examples/BigProject/Project1
@dirrm share/doc/taskjuggler/Examples/BigProject/Project2
@dirrm share/doc/taskjuggler/Examples/BigProject
@dirrm share/doc/taskjuggler/Examples/ShiftSchedule
@dirrm share/doc/taskjuggler/Examples
@dirrm share/doc/taskjuggler/manual
@dirrm share/doc/taskjuggler/tjx2gantt
@dirrm share/doc/taskjuggler