science/chemtool-devel: Fix build on FreeBSD 13.1R and 14
- Same fix as 4bfc3a9
for science/chemtool.
- While we are at it, define LICENSE. The license is not
shipped, but from the README it is clearly the authors
intent to have the same license as for science/chemtool.
while I'm here:
- cleanup Makefile
- remove unnecessary patch and reinplace cmd
- add EXAMPLES option
- add missing LIB_DEPENDS and USE_GNOME deps (Q/A check)
- adopt port
PR: 265614
This commit is contained in:
parent
998a548dca
commit
cb127c6a8d
@ -1,37 +1,48 @@
|
||||
PORTNAME= chemtool
|
||||
PORTVERSION= 1.7.20050716
|
||||
PORTREVISION= 10
|
||||
PORTREVISION= 11
|
||||
CATEGORIES= science
|
||||
MASTER_SITES= http://ruby.chemie.uni-freiburg.de/~martin/chemtool/
|
||||
PKGNAMESUFFIX= -devel
|
||||
DISTNAME= ct17a15
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= eduardo@FreeBSD.org
|
||||
COMMENT= Drawing organic molecules easily and store them (developer version)
|
||||
|
||||
BROKEN_FreeBSD_13= ld: error: duplicate symbol: babelin
|
||||
BROKEN_FreeBSD_14= ld: error: duplicate symbol: babelin
|
||||
LICENSE= GPLv2
|
||||
|
||||
LIB_DEPENDS= libEMF.so:graphics/libemf
|
||||
LIB_DEPENDS= libEMF.so:graphics/libemf \
|
||||
libfontconfig.so:x11-fonts/fontconfig \
|
||||
libfreetype.so:print/freetype2 \
|
||||
libharfbuzz.so:print/harfbuzz
|
||||
RUN_DEPENDS= fig2dev:print/fig2dev
|
||||
|
||||
USES= compiler:c++11-lang gettext gmake gnome pkgconfig tar:tgz xorg
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
|
||||
USE_GNOME= gtk20
|
||||
USE_GNOME= cairo gdkpixbuf2 gtk20
|
||||
USE_XORG= x11
|
||||
GNU_CONFIGURE= yes
|
||||
CONFIGURE_ARGS= --enable-emf=yes
|
||||
MAKE_ARGS+= MAKE=${MAKE_CMD}
|
||||
MAKE_JOBS_UNSAFE= yes
|
||||
CFLAGS+= -fcommon
|
||||
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libEMF
|
||||
LIBS+= -L${LOCALBASE}/lib
|
||||
|
||||
CONFLICTS_INSTALL= chemtool
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}-1.7alpha15/
|
||||
|
||||
PORTEXAMPLES= *
|
||||
OPTIONS_DEFINE= EXAMPLES
|
||||
|
||||
post-patch:
|
||||
@${REINPLACE_CMD} 's/-lstdc++//' ${WRKSRC}/configure
|
||||
@${REINPLACE_CMD} '/^SYS_LIBRARIES =/s/$$/ -lX11/' ${WRKSRC}/Makefile.in
|
||||
|
||||
post-install:
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/chemtool
|
||||
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cht
|
||||
|
||||
post-install-EXAMPLES-on:
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
|
||||
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,22 +0,0 @@
|
||||
--- configure.in~ Sun Jul 17 01:15:14 2005
|
||||
+++ configure.in Sun Nov 20 11:30:35 2005
|
||||
@@ -252,7 +252,7 @@
|
||||
if test x$enable_emf = xyes; then
|
||||
AC_MSG_RESULT(yes)
|
||||
AC_DEFINE(EMF)
|
||||
- EMFLIBS="-lEMF -lstdc++"
|
||||
+ EMFLIBS="-L%%LOCALBASE%%/lib -lEMF -lstdc++"
|
||||
else
|
||||
AC_MSG_RESULT(no)
|
||||
EMFLIBS=""
|
||||
--- configure~ Sun Nov 20 11:29:37 2005
|
||||
+++ configure Sun Nov 20 11:31:32 2005
|
||||
@@ -2859,7 +2859,7 @@
|
||||
#define EMF 1
|
||||
EOF
|
||||
|
||||
- EMFLIBS="-lEMF -lstdc++"
|
||||
+ EMFLIBS="-L%%LOCALBASE%%/lib -lEMF -lstdc++"
|
||||
else
|
||||
echo "$ac_t""no" 1>&6
|
||||
EMFLIBS=""
|
@ -2,45 +2,6 @@ bin/chemtool
|
||||
bin/cht
|
||||
man/man1/chemtool.1.gz
|
||||
man/man1/cht.1.gz
|
||||
%%EXAMPLESDIR%%/14263232.mol
|
||||
%%EXAMPLESDIR%%/AMP.cht
|
||||
%%EXAMPLESDIR%%/Adenosine.cht
|
||||
%%EXAMPLESDIR%%/Dehydrotubifolin.cht
|
||||
%%EXAMPLESDIR%%/G-host.pdb
|
||||
%%EXAMPLESDIR%%/Indolizomycin.cht
|
||||
%%EXAMPLESDIR%%/Lepicidin-A-Aglycon.cht
|
||||
%%EXAMPLESDIR%%/Neu2
|
||||
%%EXAMPLESDIR%%/amine.mol
|
||||
%%EXAMPLESDIR%%/anabsinthin.cht
|
||||
%%EXAMPLESDIR%%/anthocyanidine.cht
|
||||
%%EXAMPLESDIR%%/atp.cht
|
||||
%%EXAMPLESDIR%%/bcarotin.pdb
|
||||
%%EXAMPLESDIR%%/breve.cht
|
||||
%%EXAMPLESDIR%%/breve.mol
|
||||
%%EXAMPLESDIR%%/breve_frag.cht
|
||||
%%EXAMPLESDIR%%/breve_frag.mol
|
||||
%%EXAMPLESDIR%%/bufotalin.cht
|
||||
%%EXAMPLESDIR%%/byrostatin1.cht
|
||||
%%EXAMPLESDIR%%/c70.cht
|
||||
%%EXAMPLESDIR%%/camphor.cht
|
||||
%%EXAMPLESDIR%%/chlorophyll.cht
|
||||
%%EXAMPLESDIR%%/claisen.cht
|
||||
%%EXAMPLESDIR%%/dodecahedran.cht
|
||||
%%EXAMPLESDIR%%/indigo.cht
|
||||
%%EXAMPLESDIR%%/kdo.cht
|
||||
%%EXAMPLESDIR%%/krebs.cht
|
||||
%%EXAMPLESDIR%%/labeltest
|
||||
%%EXAMPLESDIR%%/pagodan.cht
|
||||
%%EXAMPLESDIR%%/penicillin_v.cht
|
||||
%%EXAMPLESDIR%%/pteridin.cht
|
||||
%%EXAMPLESDIR%%/reaction.cht
|
||||
%%EXAMPLESDIR%%/rutamycin_b.cht
|
||||
%%EXAMPLESDIR%%/sample.sdf
|
||||
%%EXAMPLESDIR%%/tbutylazulene.cht
|
||||
%%EXAMPLESDIR%%/tcdd.cht
|
||||
%%EXAMPLESDIR%%/tetracyclin.cht
|
||||
%%EXAMPLESDIR%%/v3000.mol
|
||||
%%EXAMPLESDIR%%/viagra.cht
|
||||
share/locale/cs/LC_MESSAGES/chemtool.mo
|
||||
share/locale/de/LC_MESSAGES/chemtool.mo
|
||||
share/locale/fr/LC_MESSAGES/chemtool.mo
|
||||
|
Loading…
Reference in New Issue
Block a user