Stagify, remove NOPORTDOCS & NOPORTEXAMPLES
This commit is contained in:
parent
403d5e11a8
commit
caf48a8384
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=361236
@ -11,18 +11,16 @@ DISTFILES= onigd${PORTVERSION:S/./_/g}${EXTRACT_SUFX}:onig \
|
||||
DIST_SUBDIR= ruby
|
||||
EXTRACT_ONLY= onigd${PORTVERSION:S/./_/g}${EXTRACT_SUFX}
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= BSDL Regular Expressions library compatible with POSIX/GNU/Perl
|
||||
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
NO_LATEST_LINK= yes
|
||||
CONFLICTS_INSTALL= oniguruma-4.*
|
||||
|
||||
GNU_CONFIGURE= yes
|
||||
DOCS= HISTORY README doc/*
|
||||
OPTIONS_DEFINE= DOCS EXAMPLES
|
||||
|
||||
NO_STAGE= yes
|
||||
post-patch:
|
||||
${CP} ${DISTDIR}/${DIST_SUBDIR}/ruby187p248-oniguruma.patch \
|
||||
${WRKSRC}/ruby187.patch
|
||||
@ -32,16 +30,12 @@ post-configure:
|
||||
${FILESDIR}/onig-config > ${WRKSRC}/onig-config
|
||||
|
||||
post-install:
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${PREFIX}/bin/
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${DOCSDIR}
|
||||
${INSTALL_SCRIPT} ${WRKSRC}/onig-config ${STAGEDIR}${PREFIX}/bin/
|
||||
${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
.for f in ${DOCS}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/
|
||||
.endfor
|
||||
.endif
|
||||
.if !defined(NOPORTEXAMPLES)
|
||||
${MKDIR} ${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/* ${EXAMPLESDIR}/
|
||||
.endif
|
||||
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/* ${STAGEDIR}${EXAMPLESDIR}/
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,6 +1,27 @@
|
||||
--- Makefile.in.orig 2006-11-08 08:45:50.000000000 +0300
|
||||
+++ Makefile.in 2009-02-12 18:37:58.000000000 +0300
|
||||
@@ -214,6 +214,9 @@
|
||||
--- Makefile.in.orig 2006-11-08 13:45:50.000000000 +0800
|
||||
+++ Makefile.in 2014-07-08 21:29:18.562095970 +0800
|
||||
@@ -146,13 +146,13 @@ make_enc_dir:
|
||||
test -d enc || mkdir enc
|
||||
|
||||
install: all
|
||||
- test -d $(libdir) || mkdir $(libdir)
|
||||
- test -d $(includedir) || mkdir $(includedir)
|
||||
- $(INSTALL) -m 644 $(libname) $(libdir)/$(libname)
|
||||
- $(RANLIB) $(libdir)/$(libname)
|
||||
- $(INSTALL) -m 644 $(srcdir)/oniguruma.h $(includedir)/oniguruma.h
|
||||
- $(INSTALL) -m 644 $(srcdir)/onigposix.h $(includedir)/onigposix.h
|
||||
- $(INSTALL) -m 644 $(srcdir)/oniggnu.h $(includedir)/oniggnu.h
|
||||
+ test -d $(DESTDIR)$(libdir) || mkdir $(DESTDIR)$(libdir)
|
||||
+ test -d $(DESTDIR)$(includedir) || mkdir $(DESTDIR)$(includedir)
|
||||
+ $(INSTALL) -m 644 $(libname) $(DESTDIR)$(libdir)/$(libname)
|
||||
+ $(RANLIB) $(DESTDIR)$(libdir)/$(libname)
|
||||
+ $(INSTALL) -m 644 $(srcdir)/oniguruma.h $(DESTDIR)$(includedir)/oniguruma.h
|
||||
+ $(INSTALL) -m 644 $(srcdir)/onigposix.h $(DESTDIR)$(includedir)/onigposix.h
|
||||
+ $(INSTALL) -m 644 $(srcdir)/oniggnu.h $(DESTDIR)$(includedir)/oniggnu.h
|
||||
|
||||
uninstall:
|
||||
-rm -f $(libdir)/$(libname)
|
||||
@@ -214,6 +214,9 @@ distclean: clean
|
||||
185: cpruby
|
||||
patch -d $(RUBYDIR) -p0 < $(srcdir)/ruby185.patch
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user