- Simplify plist.

- Regenereate patches by 'make makepatch'.
- Pet portlint.

PR:		213181
Submitted by:	Yasuhiro KIMURA <yasu@utahime.org>
This commit is contained in:
MANTANI Nobutaka 2016-11-13 13:18:12 +00:00
parent 4471a6e109
commit cad9c5325e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=426048
9 changed files with 31 additions and 41 deletions

View File

@ -8,8 +8,8 @@ CATEGORIES= editors elisp
MASTER_SITES= http://git.chise.org/elisp/dist/apel/
PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER?= nobutaka@FreeBSD.org
COMMENT?= Portable Emacs Library
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Portable Emacs Library
LICENSE= GPLv2
@ -33,14 +33,6 @@ MAKE_ARGS+= PREFIX="${STAGEDIR}${LOCALBASE}" \
OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
.if ${EMACS_VER:C/\..*//} >= 23
PLIST_SUB+= EMACS23="" NOEMACS23="@comment "
.else
PLIST_SUB+= EMACS23="@comment " NOEMACS23=""
.endif
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC} ; \
@ -48,4 +40,4 @@ post-install-DOCS-on:
${INSTALL_DATA} $${i} ${STAGEDIR}${DOCSDIR} ; \
done)
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1,5 +1,5 @@
--- APEL-MK.orig Wed Dec 22 13:14:21 1999
+++ APEL-MK Wed May 10 23:45:36 2000
--- APEL-MK.orig 2006-12-20 17:24:49 UTC
+++ APEL-MK
@@ -41,7 +41,7 @@
;; Make "emu" subdirectory.
"emu"

View File

@ -1,8 +1,8 @@
Index: broken.el
===================================================================
--- broken.el (revision 2)
+++ broken.el (working copy)
@@ -58,51 +58,51 @@
--- broken.el.orig 2005-07-06 02:08:52 UTC
+++ broken.el
@@ -58,51 +58,51 @@ FACILITY must be symbol.
If ASSERTION is not omitted and evaluated to nil and NO-NOTICE is nil,
it is noticed."

View File

@ -1,8 +1,8 @@
Index: filename.el
===================================================================
--- filename.el (revision 2)
+++ filename.el (working copy)
@@ -102,26 +102,26 @@
--- filename.el.orig 2005-07-06 02:08:52 UTC
+++ filename.el
@@ -102,26 +102,26 @@ Moreover, if you want to convert Japanes
inc-i '(1+ i))
(setq sref 'aref
inc-i '(+ i (char-length chr))))

View File

@ -1,7 +1,7 @@
Index: pccl.el
===================================================================
--- pccl.el (revision 2)
+++ pccl.el (working copy)
--- pccl.el.orig 2005-07-06 02:08:53 UTC
+++ pccl.el
@@ -27,138 +27,138 @@
(require 'broken)

View File

@ -1,8 +1,8 @@
Index: product.el
===================================================================
--- product.el (revision 2)
+++ product.el (working copy)
@@ -232,21 +232,21 @@
--- product.el.orig 2006-04-24 05:53:58 UTC
+++ product.el
@@ -232,21 +232,21 @@ PRODUCT-DEF is a definition of the produ
(product-version (product-version product))
(product-code-name (product-code-name product))
(product-version-string (product-version-string product)))
@ -39,7 +39,7 @@ Index: product.el
(defun product-version-as-string (product)
"Return version number of product as a string.
@@ -293,13 +293,13 @@
@@ -293,13 +293,13 @@ The 1st argument is a product structure.
PRODUCT is a product structure which returned by `product-define'."
(let (dest)
(product-for-each product nil
@ -60,7 +60,7 @@ Index: product.el
dest))
(defun product-string-verbose (product)
@@ -307,13 +307,13 @@
@@ -307,13 +307,13 @@ PRODUCT is a product structure which ret
PRODUCT is a product structure which returned by `product-define'."
(let (dest)
(product-for-each product nil

View File

@ -1,7 +1,7 @@
Index: pym.el
===================================================================
--- pym.el (revision 2)
+++ pym.el (working copy)
--- pym.el.orig 2005-07-06 02:08:53 UTC
+++ pym.el
@@ -63,15 +63,15 @@
See also the function `defun'."
(or (and (fboundp name)
@ -27,7 +27,7 @@ Index: pym.el
(put 'defmacro-maybe 'lisp-indent-function 'defun)
(defmacro defmacro-maybe (name &rest everything-else)
@@ -79,15 +79,15 @@
@@ -79,15 +79,15 @@ See also the function `defun'."
See also the function `defmacro'."
(or (and (fboundp name)
(not (get name 'defmacro-maybe)))
@ -52,7 +52,7 @@ Index: pym.el
(put 'defsubst-maybe 'lisp-indent-function 'defun)
(defmacro defsubst-maybe (name &rest everything-else)
@@ -95,15 +95,15 @@
@@ -95,15 +95,15 @@ See also the function `defmacro'."
See also the macro `defsubst'."
(or (and (fboundp name)
(not (get name 'defsubst-maybe)))
@ -77,7 +77,7 @@ Index: pym.el
(defmacro defalias-maybe (symbol definition)
"Define SYMBOL as an alias for DEFINITION if SYMBOL is not defined.
@@ -111,35 +111,35 @@
@@ -111,35 +111,35 @@ See also the function `defalias'."
(setq symbol (eval symbol))
(or (and (fboundp symbol)
(not (get symbol 'defalias-maybe)))
@ -130,7 +130,7 @@ Index: pym.el
(defmacro defun-maybe-cond (name args &optional doc &rest clauses)
"Define NAME as a function if NAME is not defined.
@@ -152,26 +152,26 @@
@@ -152,26 +152,26 @@ See also the function `defun'."
doc nil))
(or (and (fboundp name)
(not (get name 'defun-maybe)))
@ -177,7 +177,7 @@ Index: pym.el
(defmacro defmacro-maybe-cond (name args &optional doc &rest clauses)
"Define NAME as a macro if NAME is not defined.
@@ -184,26 +184,26 @@
@@ -184,26 +184,26 @@ See also the function `defmacro'."
doc nil))
(or (and (fboundp name)
(not (get name 'defmacro-maybe)))
@ -224,7 +224,7 @@ Index: pym.el
(defmacro defsubst-maybe-cond (name args &optional doc &rest clauses)
"Define NAME as an inline function if NAME is not defined.
@@ -216,26 +216,26 @@
@@ -216,26 +216,26 @@ See also the macro `defsubst'."
doc nil))
(or (and (fboundp name)
(not (get name 'defsubst-maybe)))
@ -271,7 +271,7 @@ Index: pym.el
;;; Edebug spec.
@@ -246,7 +246,7 @@
@@ -246,7 +246,7 @@ See also the macro `defsubst'."
"Set the edebug-form-spec property of SYMBOL according to SPEC.
Both SYMBOL and SPEC are unevaluated. The SPEC can be 0, t, a symbol
\(naming a function\), or a list."

View File

@ -1,7 +1,7 @@
Index: static.el
===================================================================
--- static.el (revision 2)
+++ static.el (working copy)
--- static.el.orig 2005-07-06 02:08:53 UTC
+++ static.el
@@ -29,38 +29,38 @@
"Like `if', but evaluate COND at compile time."
(if (eval cond)

View File

@ -14,10 +14,8 @@
%%EMACS_VERSION_SITE_LISPDIR%%/emu/broken.elc
%%EMACS_VERSION_SITE_LISPDIR%%/emu/emu.el
%%EMACS_VERSION_SITE_LISPDIR%%/emu/emu.elc
%%NOEMACS23%%%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-19.el
%%NOEMACS23%%%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-19.elc
%%EMACS23%%%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-23.el
%%EMACS23%%%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-23.elc
%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-23.el
%%EMACS_VERSION_SITE_LISPDIR%%/emu/inv-23.elc
%%EMACS_VERSION_SITE_LISPDIR%%/emu/invisible.el
%%EMACS_VERSION_SITE_LISPDIR%%/emu/invisible.elc
%%EMACS_VERSION_SITE_LISPDIR%%/emu/mcharset.el