Provide a patch to support SNI.
This has been discussed upstream: https://sylpheed.sraoss.jp/redmine/issues/306 While here: - remove extra space after URL - use options helpers Obtained from: OpenBSD
This commit is contained in:
parent
dca9e1994b
commit
cacd9fc917
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541118
@ -3,7 +3,7 @@
|
||||
|
||||
PORTNAME= sylpheed
|
||||
PORTVERSION= 3.7.0
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= mail
|
||||
MASTER_SITES= http://sylpheed.sraoss.jp/sylpheed/v${PORTVERSION:C/\.[^\.]*$//}/ \
|
||||
LOCAL/ehaupt
|
||||
@ -95,16 +95,16 @@ post-patch:
|
||||
@${REINPLACE_CMD} -e 's|^\(DEFS.*\.\.\)$$|\1 -I../libsylph|' \
|
||||
${WRKSRC}/src/Makefile.in
|
||||
|
||||
.if empty(PORT_OPTIONS:MDOCS)
|
||||
post-patch-DOCS-off:
|
||||
@${REINPLACE_CMD} -e '/^SUBDIRS = /s/manual faq//' \
|
||||
${WRKSRC}/Makefile.in
|
||||
.else
|
||||
|
||||
post-patch-DOCS-on:
|
||||
.for i in ${MAKEFILES}
|
||||
@${REINPLACE_CMD} -e 's|^faqdir = @faqdir@$$|faqdir = ${DOCSDIR}/faq|g; \
|
||||
s|^manualdir = @manualdir@$$|manualdir = ${DOCSDIR}/manual|g' \
|
||||
${WRKSRC}/${i}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
post-install:
|
||||
@${MKDIR} ${STAGEDIR}${DOCSDIR}
|
||||
|
16
mail/sylpheed/files/patch-libsylph_ssl.c
Normal file
16
mail/sylpheed/files/patch-libsylph_ssl.c
Normal file
@ -0,0 +1,16 @@
|
||||
--- libsylph/ssl.c.orig 2017-02-02 08:02:49 UTC
|
||||
+++ libsylph/ssl.c
|
||||
@@ -258,6 +258,13 @@ gboolean ssl_init_socket_with_method(SockInfo *sockinf
|
||||
return FALSE;
|
||||
}
|
||||
|
||||
+#ifdef SSL_CTRL_SET_TLSEXT_HOSTNAME
|
||||
+ if (!SSL_set_tlsext_host_name(sockinfo->ssl, sockinfo->hostname)) {
|
||||
+ g_warning("Error setting servername extension\n");
|
||||
+ return FALSE;
|
||||
+ }
|
||||
+#endif
|
||||
+
|
||||
SSL_set_fd(sockinfo->ssl, sockinfo->sock);
|
||||
while ((ret = SSL_connect(sockinfo->ssl)) != 1) {
|
||||
err = SSL_get_error(sockinfo->ssl, ret);
|
Loading…
Reference in New Issue
Block a user