Add ruby-gd, Ruby extension library to use Thomas Boutell's gd library.
This commit is contained in:
parent
9366dd9c29
commit
cabfb05641
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=33326
@ -156,6 +156,7 @@
|
||||
SUBDIR += quickpics
|
||||
SUBDIR += qvplay
|
||||
SUBDIR += rayshade
|
||||
SUBDIR += ruby-gd
|
||||
SUBDIR += ruby-libpng
|
||||
SUBDIR += ruby-opengl
|
||||
SUBDIR += sane
|
||||
|
93
graphics/ruby-gd/Makefile
Normal file
93
graphics/ruby-gd/Makefile
Normal file
@ -0,0 +1,93 @@
|
||||
# New ports collection makefile for: Ruby/gd
|
||||
# Date created: 27 Sep 2000
|
||||
# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= GD
|
||||
PORTVERSION= 0.7.0
|
||||
CATEGORIES= graphics ruby
|
||||
MASTER_SITES= http://kirara.prec.kyoto-u.ac.jp/~tam/GD/
|
||||
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
|
||||
DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
|
||||
DIST_SUBDIR= ruby
|
||||
|
||||
MAINTAINER= knu@FreeBSD.org
|
||||
|
||||
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
|
||||
|
||||
USE_RUBY= yes
|
||||
USE_RUBY_EXTCONF= yes
|
||||
.if !defined(NOPORTDOCS)
|
||||
USE_RUBY_RD= yes
|
||||
.endif
|
||||
|
||||
CONFIGURE_ARGS= --with-gd-include="${LOCALBASE}/include/gd" --with-jpeg
|
||||
INSTALL_TARGET= site-install
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
|
||||
WITH_X11_CHECK!= ldd ${LOCALBASE}/bin/gd2topng | grep -w 'libX11\.so' || true
|
||||
|
||||
.if !empty(WITH_X11_CHECK)
|
||||
USE_XLIB= yes
|
||||
USE_XPM= yes
|
||||
USE_FREETYPE= yes
|
||||
|
||||
CONFIGURE_ARGS+= --with-x-dir="${X11BASE}" --with-xpm --with-ttf
|
||||
.endif
|
||||
|
||||
EXAMPLES_EN= example.rb \
|
||||
gdtestttf.png \
|
||||
gdtestttf.rb \
|
||||
webpng.rb
|
||||
DOCS_EN= readme.en \
|
||||
doc/INSTALL.en \
|
||||
doc/manual.html \
|
||||
doc/manual.rd
|
||||
DOCS_JA= readme.ja \
|
||||
doc/INSTALL.ja
|
||||
TUTORIAL_JA= gd_intro-ja.html \
|
||||
imgs/0.png \
|
||||
imgs/1.png \
|
||||
imgs/arc.png \
|
||||
imgs/brush1.png \
|
||||
imgs/brush2.png \
|
||||
imgs/copy.png \
|
||||
imgs/copy_merge.png \
|
||||
imgs/demoin.png \
|
||||
imgs/demoout.png \
|
||||
imgs/line.png \
|
||||
imgs/poly.png \
|
||||
imgs/poly_setPt.png \
|
||||
imgs/rectangle.png \
|
||||
imgs/string.png \
|
||||
imgs/string2.png \
|
||||
imgs/stringttf1.png \
|
||||
imgs/stringttf2.png \
|
||||
imgs/styled_line.png \
|
||||
imgs/styled_line_transparent.png \
|
||||
imgs/top.png \
|
||||
imgs/xpy.png
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
${MKDIR} ${RUBY_EXAMPLESDIR}/gd
|
||||
.for f in ${EXAMPLES_EN}
|
||||
${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_EXAMPLESDIR}/gd/
|
||||
.endfor
|
||||
${MKDIR} ${RUBY_DOCDIR}/gd/ja/imgs
|
||||
.for f in ${DOCS_EN}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/gd/
|
||||
.endfor
|
||||
.for f in ${DOCS_JA}
|
||||
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/gd/ja/
|
||||
.endfor
|
||||
.for f in ${TUTORIAL_JA}
|
||||
${INSTALL_DATA} ${WRKSRC}/doc/${f} ${RUBY_DOCDIR}/gd/ja/${f}
|
||||
.endfor
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
1
graphics/ruby-gd/distinfo
Normal file
1
graphics/ruby-gd/distinfo
Normal file
@ -0,0 +1 @@
|
||||
MD5 (ruby/ruby-GD-0.7.0.tar.gz) = e7c7c3ac6820d441eaaf787dca258ab9
|
12
graphics/ruby-gd/files/patch-aa
Normal file
12
graphics/ruby-gd/files/patch-aa
Normal file
@ -0,0 +1,12 @@
|
||||
--- extconf.rb.orig Mon Oct 2 08:17:23 2000
|
||||
+++ extconf.rb Mon Oct 2 23:32:21 2000
|
||||
@@ -18,8 +18,7 @@
|
||||
dir_config("gd")
|
||||
|
||||
if with_config("xpm")
|
||||
- $CFLAGS += " -I/usr/X11R6/include"
|
||||
- $LDFLAGS += " -L/usr/X11R6/lib"
|
||||
+ dir_config('x')
|
||||
end
|
||||
|
||||
if with_config('jpeg')
|
1
graphics/ruby-gd/pkg-comment
Normal file
1
graphics/ruby-gd/pkg-comment
Normal file
@ -0,0 +1 @@
|
||||
Ruby extension library to use Thomas Boutell's gd library
|
6
graphics/ruby-gd/pkg-descr
Normal file
6
graphics/ruby-gd/pkg-descr
Normal file
@ -0,0 +1,6 @@
|
||||
Ruby/GD is an extension library to use Thomas Boutell's gd library
|
||||
(http://www.boutell.com/gd/) from Ruby.
|
||||
|
||||
Author: Matsumoto Yukihiro <matz@ruby-lang.org> (original author)
|
||||
Ryuichi Tamura <tam@kais.kyoto-u.ac.jp> (current maintainer)
|
||||
WWW: http://kirara.prec.kyoto-u.ac.jp/~tam/GD/index.en.html
|
37
graphics/ruby-gd/pkg-plist
Normal file
37
graphics/ruby-gd/pkg-plist
Normal file
@ -0,0 +1,37 @@
|
||||
%%RUBY_SITEARCHLIBDIR%%/GD.so
|
||||
%%RUBY_EXAMPLESDIR%%/gd/example.rb
|
||||
%%RUBY_EXAMPLESDIR%%/gd/gdtestttf.png
|
||||
%%RUBY_EXAMPLESDIR%%/gd/gdtestttf.rb
|
||||
%%RUBY_EXAMPLESDIR%%/gd/webpng.rb
|
||||
@dirrm %%RUBY_EXAMPLESDIR%%/gd
|
||||
%%RUBY_DOCDIR%%/gd/INSTALL.en
|
||||
%%RUBY_DOCDIR%%/gd/manual.html
|
||||
%%RUBY_DOCDIR%%/gd/manual.rd
|
||||
%%RUBY_DOCDIR%%/gd/readme.en
|
||||
%%RUBY_DOCDIR%%/gd/ja/INSTALL.ja
|
||||
%%RUBY_DOCDIR%%/gd/ja/gd_intro-ja.html
|
||||
%%RUBY_DOCDIR%%/gd/ja/readme.ja
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/0.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/1.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/arc.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/brush1.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/brush2.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/copy.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/copy_merge.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/demoin.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/demoout.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/line.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/poly.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/poly_setPt.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/rectangle.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/string.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/string2.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/stringttf1.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/stringttf2.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/styled_line.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/styled_line_transparent.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/top.png
|
||||
%%RUBY_DOCDIR%%/gd/ja/imgs/xpy.png
|
||||
@dirrm %%RUBY_DOCDIR%%/gd/ja/imgs
|
||||
@dirrm %%RUBY_DOCDIR%%/gd/ja
|
||||
@dirrm %%RUBY_DOCDIR%%/gd
|
Loading…
Reference in New Issue
Block a user