- Remove, it's ancient and newer version is included in base of all supported
releases Suggested by: sam
This commit is contained in:
parent
8776c921c7
commit
caab36701d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=211993
1
MOVED
1
MOVED
@ -3459,3 +3459,4 @@ net/dhcp-agent||2008-04-25|Has expired: Dhcp-agent has not been updated since 20
|
||||
net/ocaml-netclient||2008-04-25|Has expired: is part of ocaml-net
|
||||
net/samplicator||2008-04-25|Has expired: Project has vanished
|
||||
graphics/entice||2008-04-25|Has expired: Broken and unmaintained
|
||||
security/wpa_supplicant||2008-04-26|Obsolete, newer version in base
|
||||
|
@ -779,7 +779,6 @@
|
||||
SUBDIR += wapiti
|
||||
SUBDIR += webfwlog
|
||||
SUBDIR += wipe
|
||||
SUBDIR += wpa_supplicant
|
||||
SUBDIR += xca
|
||||
SUBDIR += xinetd
|
||||
SUBDIR += xmlsec
|
||||
|
@ -1,63 +0,0 @@
|
||||
# New ports collection makefile for: wpa_supplicant
|
||||
# Date created: 7 December 2004
|
||||
# Whom: sam
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
# WITH_STATIC_SUPPLICANT - If you use wpa_supplicant with devd(8) to
|
||||
# start your wireless NIC at boot, it will not be able to resolve
|
||||
# the libdnet library dependency because devd is run before
|
||||
# ldconfig. Defining this variable will get around the problem by
|
||||
# static-linking the wpa_supplicant executable. A static-linked
|
||||
# version of the executable is about 1.25MB larger and you will be
|
||||
# required to rebuild this port whenever the net/libdnet port is
|
||||
# updated.
|
||||
|
||||
PORTNAME= wpa_supplicant
|
||||
PORTVERSION= 0.3.8
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= security net
|
||||
MASTER_SITES= http://hostap.epitest.fi/releases/
|
||||
|
||||
MAINTAINER= ports@FreeBSD.org
|
||||
COMMENT= Supplicant (client) for WPA/802.1x protocols
|
||||
|
||||
LIB_DEPENDS= dnet.1:${PORTSDIR}/net/libdnet
|
||||
|
||||
PLIST_FILES= sbin/wpa_supplicant \
|
||||
sbin/wpa_passphrase \
|
||||
sbin/wpa_cli
|
||||
|
||||
PLIST_FILES+= etc/${PORTNAME}.conf.sample
|
||||
|
||||
PORTDOCS= README ChangeLog
|
||||
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}
|
||||
USE_GMAKE= yes
|
||||
|
||||
.if defined(WITH_STATIC_SUPPLICANT)
|
||||
SUPPLICANT_STATIC= -static
|
||||
.else
|
||||
SUPPLICANT_STATIC=
|
||||
.endif
|
||||
MAKE_ENV+= SUPPLICANT_STATIC=${SUPPLICANT_STATIC}
|
||||
|
||||
post-patch:
|
||||
@${CP} ${FILESDIR}/config.bsd ${WRKSRC}/.config
|
||||
@${REINPLACE_CMD} 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/.config
|
||||
|
||||
post-install:
|
||||
.if !defined(NOPORTDOCS)
|
||||
@${MKDIR} ${DOCSDIR}
|
||||
@${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
|
||||
.endif
|
||||
@${INSTALL_DATA} ${WRKSRC}/wpa_supplicant.conf ${PREFIX}/etc/wpa_supplicant.conf.sample
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if ${OSVERSION} < 600007
|
||||
IGNORE=is not supported on FreeBSD < 6.0
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
@ -1,3 +0,0 @@
|
||||
MD5 (wpa_supplicant-0.3.8.tar.gz) = c9ced104f0322f834a84336c293b4b57
|
||||
SHA256 (wpa_supplicant-0.3.8.tar.gz) = f24a344e19a513d5725b1cdce9b0393676a80a7dc083e053a04fb3b703cf7115
|
||||
SIZE (wpa_supplicant-0.3.8.tar.gz) = 301163
|
@ -1,16 +0,0 @@
|
||||
CONFIG_DRIVER_BSD=y
|
||||
CONFIG_CTRL_IFACE=y
|
||||
CONFIG_IEEE8021X_EAPOL=y
|
||||
CONFIG_EAP_MD5=y
|
||||
CONFIG_EAP_MSCHAPV2=y
|
||||
CONFIG_EAP_TLS=y
|
||||
CONFIG_EAP_PEAP=y
|
||||
CONFIG_EAP_TTLS=y
|
||||
CONFIG_EAP_GTC=y
|
||||
CONFIG_EAP_OTP=y
|
||||
CONFIG_EAP_SIM=y
|
||||
CONFIG_EAP_AKA=y
|
||||
CONFIG_EAP_PSK=y
|
||||
CONFIG_EAP_LEAP=y
|
||||
CFLAGS += -I%%LOCALBASE%%/include
|
||||
LIBS += -L%%LOCALBASE%%/lib
|
@ -1,14 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- Makefile.orig
|
||||
+++ Makefile
|
||||
@@ -303,7 +303,7 @@
|
||||
OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
|
||||
|
||||
wpa_supplicant: .config $(OBJS)
|
||||
- $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
|
||||
+ $(CC) ${SUPPLICANT_STATIC} -o wpa_supplicant $(OBJS) $(LIBS)
|
||||
|
||||
eapol_test: .config $(OBJS_t)
|
||||
$(CC) -o eapol_test $(OBJS_t) $(LIBS)
|
@ -1,13 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- crypto.c.orig
|
||||
+++ crypto.c
|
||||
@@ -12,6 +12,7 @@
|
||||
* See README and COPYING for more details.
|
||||
*/
|
||||
|
||||
+#include <sys/types.h>
|
||||
#include <openssl/md4.h>
|
||||
#include <openssl/des.h>
|
||||
|
@ -1,86 +0,0 @@
|
||||
--- wpa_supplicant.c.orig Sat Feb 5 15:51:25 2005
|
||||
+++ wpa_supplicant.c Wed Feb 16 01:16:55 2005
|
||||
@@ -32,6 +32,9 @@
|
||||
#endif /* CONFIG_NATIVE_WINDOWS */
|
||||
#include <fcntl.h>
|
||||
|
||||
+#include <sys/param.h>
|
||||
+#include <paths.h>
|
||||
+
|
||||
#define OPENSSL_DISABLE_OLD_DES_SUPPORT
|
||||
#include "common.h"
|
||||
#include "eapol_sm.h"
|
||||
@@ -2285,12 +2288,43 @@
|
||||
wpa_supplicant_cleanup(wpa_s);
|
||||
}
|
||||
|
||||
+static const char* pid_filename = _PATH_VARRUN "wpa_supplicant.pid";
|
||||
+
|
||||
+static
|
||||
+void
|
||||
+remove_pid_file(void) {
|
||||
+ unlink(pid_filename);
|
||||
+}
|
||||
+
|
||||
+static
|
||||
+void
|
||||
+create_pidfile(const char* path_pid_file) {
|
||||
+ FILE* fd;
|
||||
+
|
||||
+ if (path_pid_file) {
|
||||
+ pid_filename = path_pid_file;
|
||||
+ }
|
||||
+
|
||||
+ fd = fopen(pid_filename, "w");
|
||||
+ if (fd) {
|
||||
+ pid_t pid;
|
||||
+
|
||||
+ pid = getpid();
|
||||
+
|
||||
+ fprintf(fd, "%ld\n", pid);
|
||||
+ fclose(fd);
|
||||
+
|
||||
+ atexit(remove_pid_file);
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
|
||||
int main(int argc, char *argv[])
|
||||
{
|
||||
struct wpa_supplicant *head, *wpa_s;
|
||||
int c;
|
||||
const char *confname, *driver, *ifname;
|
||||
+ const char *path_pid_file = NULL;
|
||||
int daemonize = 0, wait_for_interface = 0, disable_eapol = 0, exitcode;
|
||||
|
||||
#ifdef CONFIG_NATIVE_WINDOWS
|
||||
@@ -2312,7 +2346,7 @@
|
||||
ifname = confname = driver = NULL;
|
||||
|
||||
for (;;) {
|
||||
- c = getopt(argc, argv, "Bc:D:dehi:KLNqtvw");
|
||||
+ c = getopt(argc, argv, "Bc:D:dehi:KLNp:qtvw");
|
||||
if (c < 0)
|
||||
break;
|
||||
switch (c) {
|
||||
@@ -2347,6 +2381,9 @@
|
||||
case 'L':
|
||||
license();
|
||||
return -1;
|
||||
+ case 'p':
|
||||
+ path_pid_file = optarg;
|
||||
+ break;
|
||||
case 'q':
|
||||
wpa_debug_level++;
|
||||
break;
|
||||
@@ -2405,6 +2442,10 @@
|
||||
exitcode = -1;
|
||||
goto cleanup;
|
||||
}
|
||||
+ }
|
||||
+
|
||||
+ if (daemonize) {
|
||||
+ create_pidfile(path_pid_file);
|
||||
}
|
||||
|
||||
eloop_register_signal(SIGINT, wpa_supplicant_terminate, NULL);
|
@ -1,27 +0,0 @@
|
||||
|
||||
$FreeBSD$
|
||||
|
||||
--- wpa_ctrl.c.orig
|
||||
+++ wpa_ctrl.c
|
||||
@@ -88,7 +88,7 @@
|
||||
}
|
||||
|
||||
ctrl->local.sun_family = AF_UNIX;
|
||||
- snprintf(ctrl->local.sun_path, sizeof(ctrl->local.sun_path),
|
||||
+ snprintf(ctrl->local.sun_path, sizeof(ctrl->local.sun_path) - 1,
|
||||
"/tmp/wpa_ctrl_%d-%d", getpid(), counter++);
|
||||
if (bind(ctrl->s, (struct sockaddr *) &ctrl->local,
|
||||
sizeof(ctrl->local.sun_family) +
|
||||
@@ -99,10 +99,9 @@
|
||||
}
|
||||
|
||||
ctrl->dest.sun_family = AF_UNIX;
|
||||
- strncpy(ctrl->dest.sun_path, ctrl_path, sizeof(ctrl->dest.sun_path));
|
||||
+ strncpy(ctrl->dest.sun_path, ctrl_path, sizeof(ctrl->dest.sun_path) - 1);
|
||||
if (connect(ctrl->s, (struct sockaddr *) &ctrl->dest,
|
||||
- sizeof(ctrl->dest.sun_family) +
|
||||
- strlen(ctrl->dest.sun_path)) < 0) {
|
||||
+ sizeof(ctrl->dest)) < 0) {
|
||||
close(ctrl->s);
|
||||
unlink(ctrl->local.sun_path);
|
||||
free(ctrl);
|
@ -1,9 +0,0 @@
|
||||
wpa_supplicant is a client (supplicant) for the WPA, 802.11i, and
|
||||
802.1x security protocols typically used over wireless networks.
|
||||
You must have a WPA, 802.11i, or 802.1x authenticator (server) to
|
||||
make use of this program.
|
||||
|
||||
WWW: http://hostap.epitest.fi/wpa_supplicant/
|
||||
|
||||
- Sam Leffler
|
||||
sam@FreeBSD.org
|
Loading…
Reference in New Issue
Block a user