Remove expired port:
2019-10-13 palm/synce-libsynce: obsolete technology
This commit is contained in:
parent
a74675e62d
commit
caa769eea3
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=514450
1
MOVED
1
MOVED
@ -13077,3 +13077,4 @@ print/py-fonttools-woff|print/py-fonttools|2019-10-07|Folded back into main port
|
|||||||
java/jakarta-commons-lang3|java/apache-commons-lang3|2019-10-07|Renamed upstream
|
java/jakarta-commons-lang3|java/apache-commons-lang3|2019-10-07|Renamed upstream
|
||||||
x11-clocks/xfce4-timer-out-plugin|x11-clocks/xfce4-time-out-plugin|2019-10-09|Port was incorrectly named different to upstream
|
x11-clocks/xfce4-timer-out-plugin|x11-clocks/xfce4-time-out-plugin|2019-10-09|Port was incorrectly named different to upstream
|
||||||
x11-toolkits/gai||2019-10-10|Abandonware since 2005
|
x11-toolkits/gai||2019-10-10|Abandonware since 2005
|
||||||
|
palm/synce-libsynce||2019-10-14|Has expired: obsolete technology
|
||||||
|
@ -4,6 +4,5 @@
|
|||||||
COMMENT = Software support for handheld devices (Palm, PocketPC, ...)
|
COMMENT = Software support for handheld devices (Palm, PocketPC, ...)
|
||||||
|
|
||||||
SUBDIR += p5-Palm
|
SUBDIR += p5-Palm
|
||||||
SUBDIR += synce-libsynce
|
|
||||||
|
|
||||||
.include <bsd.port.subdir.mk>
|
.include <bsd.port.subdir.mk>
|
||||||
|
@ -1,28 +0,0 @@
|
|||||||
# Created by: Sam Lawrance <boris@brooknet.com.au>
|
|
||||||
# $FreeBSD$
|
|
||||||
|
|
||||||
PORTNAME= libsynce
|
|
||||||
PORTVERSION= 0.14
|
|
||||||
PORTREVISION= 2
|
|
||||||
CATEGORIES= palm
|
|
||||||
MASTER_SITES= SF/synce/SynCE/${PORTVERSION}
|
|
||||||
PKGNAMEPREFIX= synce-
|
|
||||||
|
|
||||||
MAINTAINER= webmaster@kibab.com
|
|
||||||
COMMENT= Library to support communication with WinCE devices
|
|
||||||
|
|
||||||
DEPRECATED= obsolete technology
|
|
||||||
EXPIRATION_DATE= 2019-10-13
|
|
||||||
|
|
||||||
LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
|
|
||||||
libhal.so:sysutils/hal
|
|
||||||
|
|
||||||
USE_LDCONFIG= yes
|
|
||||||
GNU_CONFIGURE= yes
|
|
||||||
USES= pathfix iconv pkgconfig libtool
|
|
||||||
CONFIGURE_ARGS+= ${ICONV_CONFIGURE_ARG} \
|
|
||||||
--enable-dccm-file-support=no \
|
|
||||||
--enable-hal-support=yes \
|
|
||||||
--enable-odccm-support=no
|
|
||||||
|
|
||||||
.include <bsd.port.mk>
|
|
@ -1,2 +0,0 @@
|
|||||||
SHA256 (libsynce-0.14.tar.gz) = a1522495b0dd73a006d95d61e5eec2149e16f77d8cf06c3b3ed1960d7c6c4350
|
|
||||||
SIZE (libsynce-0.14.tar.gz) = 372404
|
|
@ -1,41 +0,0 @@
|
|||||||
--- lib/synce_socket.c.orig Thu Sep 14 17:38:41 2006
|
|
||||||
+++ lib/synce_socket.c Fri Jan 26 01:18:32 2007
|
|
||||||
@@ -138,32 +138,31 @@
|
|
||||||
|
|
||||||
bool synce_socket_connect_proxy(SynceSocket* syncesock, const char* remoteIpAddress)
|
|
||||||
{
|
|
||||||
+ char *path;
|
|
||||||
+ char socketPath[256];
|
|
||||||
+ struct sockaddr_un proxyaddr;
|
|
||||||
+ size_t size;
|
|
||||||
+
|
|
||||||
synce_socket_close(syncesock);
|
|
||||||
|
|
||||||
if (!synce_socket_create_proxy(syncesock))
|
|
||||||
goto fail;
|
|
||||||
|
|
||||||
|
|
||||||
- char *path;
|
|
||||||
-
|
|
||||||
if (!synce_get_subdirectory("rapi2", &path)) {
|
|
||||||
goto fail;
|
|
||||||
}
|
|
||||||
|
|
||||||
- char socketPath[256];
|
|
||||||
-
|
|
||||||
strncpy(socketPath, path, 256);
|
|
||||||
strncat(socketPath, "/", 256 - strlen(socketPath));
|
|
||||||
strncat(socketPath, remoteIpAddress, 256 - strlen(socketPath));
|
|
||||||
|
|
||||||
free(path);
|
|
||||||
|
|
||||||
- struct sockaddr_un proxyaddr;
|
|
||||||
-
|
|
||||||
proxyaddr.sun_family = AF_LOCAL;
|
|
||||||
strncpy(proxyaddr.sun_path, socketPath, sizeof(proxyaddr.sun_path));
|
|
||||||
|
|
||||||
- size_t size = (offsetof (struct sockaddr_un, sun_path) + strlen(proxyaddr.sun_path) + 1);
|
|
||||||
+ size = (offsetof (struct sockaddr_un, sun_path) + strlen(proxyaddr.sun_path) + 1);
|
|
||||||
|
|
||||||
if (connect(syncesock->fd, (struct sockaddr *) &proxyaddr, size) < 0)
|
|
||||||
goto fail;
|
|
@ -1,5 +0,0 @@
|
|||||||
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
|
|
||||||
Libsynce provides common functions needed for communication with a Windows CE
|
|
||||||
device.
|
|
||||||
|
|
||||||
WWW: http://synce.sourceforge.net/
|
|
@ -1,47 +0,0 @@
|
|||||||
include/synce.h
|
|
||||||
include/synce_hash.h
|
|
||||||
include/synce_ini.h
|
|
||||||
include/synce_log.h
|
|
||||||
include/synce_socket.h
|
|
||||||
include/synce_types.h
|
|
||||||
include/synce_vector_template.h
|
|
||||||
include/synce_sys_error.h
|
|
||||||
lib/libsynce.a
|
|
||||||
lib/libsynce.so
|
|
||||||
lib/libsynce.so.0
|
|
||||||
lib/libsynce.so.0.0.0
|
|
||||||
libdata/pkgconfig/libsynce.pc
|
|
||||||
man/man3/date_from_tm.3.gz
|
|
||||||
man/man3/date_to_tm.3.gz
|
|
||||||
man/man3/synce_debug.3.gz
|
|
||||||
man/man3/synce_error.3.gz
|
|
||||||
man/man3/synce_get_connection_filename.3.gz
|
|
||||||
man/man3/synce_get_directory.3.gz
|
|
||||||
man/man3/synce_get_script_directory.3.gz
|
|
||||||
man/man3/synce_get_subdirectory.3.gz
|
|
||||||
man/man3/synce_info.3.gz
|
|
||||||
man/man3/synce_info_destroy.3.gz
|
|
||||||
man/man3/synce_info_new.3.gz
|
|
||||||
man/man3/synce_log_set_level.3.gz
|
|
||||||
man/man3/synce_log_use_syslog.3.gz
|
|
||||||
man/man3/synce_set_connection_filename.3.gz
|
|
||||||
man/man3/synce_set_default_connection_filename.3.gz
|
|
||||||
man/man3/synce_strerror.3.gz
|
|
||||||
man/man3/synce_trace.3.gz
|
|
||||||
man/man3/synce_warning.3.gz
|
|
||||||
man/man3/synce_warning_unless.3.gz
|
|
||||||
man/man3/time_fields_from_filetime.3.gz
|
|
||||||
man/man3/time_fields_to_filetime.3.gz
|
|
||||||
man/man3/wstr_append.3.gz
|
|
||||||
man/man3/wstr_equal.3.gz
|
|
||||||
man/man3/wstr_free_string.3.gz
|
|
||||||
man/man3/wstr_from_ascii.3.gz
|
|
||||||
man/man3/wstr_from_current.3.gz
|
|
||||||
man/man3/wstr_from_utf8.3.gz
|
|
||||||
man/man3/wstr_to_ascii.3.gz
|
|
||||||
man/man3/wstr_to_current.3.gz
|
|
||||||
man/man3/wstr_to_utf8.3.gz
|
|
||||||
man/man3/wstrcpy.3.gz
|
|
||||||
man/man3/wstrdup.3.gz
|
|
||||||
man/man3/wstrlen.3.gz
|
|
||||||
man/man7/synce.7.gz
|
|
Loading…
Reference in New Issue
Block a user